Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 239738

Summary: games-fps/alephone-20080721 stabilization request
Product: Gentoo Linux Reporter: David Sveningsson <eXt>
Component: [OLD] GamesAssignee: Gentoo Games <games>
Status: RESOLVED FIXED    
Severity: enhancement CC: fauli
Priority: High Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 245160    

Description David Sveningsson 2008-10-04 21:29:38 UTC
alephone-20061228 does not build with glibc-2.8. 20080721 does at least build on ~amd64. I don't have the datafiles so I cannot try to run it.

Reproducible: Always

Steps to Reproduce:
Comment 1 Tristan Heaven (RETIRED) gentoo-dev 2008-10-04 22:29:01 UTC
You can use games-fps/alephone-infinity to test it.
Comment 2 David Sveningsson 2008-10-04 22:52:35 UTC
I did install games-fps/alephone-infinity and played for a while. Seems to work.
Comment 3 Víctor Enríquez 2008-10-06 12:31:19 UTC
====AMD64 AT REPORT====

*Installation[OK]
*No src_test in ebuild[OK]
*Functionality[FAIL]: I'm not able to launch the game I get this error using infinity:
DISPLAY=:0 alephone.sh infinity
Aleph One SDL linux-gnu x86_64 Oct  6 2008
http://marathon.sourceforge.net/

Original code by Bungie Software <http://www.bungie.com/>
Additional work by Loren Petrich, Chris Pruett, Rhys Hill et al.
TCP/IP networking by Woody Zenfell
Expat XML library by James Clark
SDL port by Christian Bauer <Christian.Bauer@uni-mainz.de>

This is free software with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
For details, see the file COPYING.

Built with network play enabled.
-------------------- Mon Oct  6 14:29:53 2008


while initializing fonts (sdl_fonts.cpp:61)
  Can't open font resource file (sdl_fonts.cpp:73)

*Documentation[OK]

emerge --info:
Portage 2.1.4.4 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.26-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.26-gentoo-r1 x86_64 Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz
Timestamp of tree: Fri, 03 Oct 2008 15:15:02 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks metadata-transfer multilib-strict parallel-fetch sandbox sfperms strict test unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/var/vquicksilver-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 berkdb bzip2 cairo cdr cli cracklib crypt dbus dga dri dvd dvdr ffmpeg flac fortran gdbm glitz gmp gnome gpm gstreamer gtk hal iconv ipv6 isdnlog ithreads java jpeg lcms libnotify mad midi mmx mono mp3 mpeg mudflap multilib ncurses network nls nptl nptlonly nsplugin ogg opengl openmp pam pcre perl png pppd python readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora threads truetype unicode v4l vorbis x264 xcomposite xinerama xorg xprint xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia none"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 4 Víctor Enríquez 2008-10-06 12:42:35 UTC
Duh!, forget previous report, I was usinig wrong version of alephone (the stable one, because I did a typo in package.keywords) , it now WORKS here. Stabilize Please. 
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-10-09 18:31:47 UTC
amd64 stable, thanks Victor!
Comment 6 Mr. Bones. (RETIRED) gentoo-dev 2008-11-02 20:57:18 UTC
*** Bug 245298 has been marked as a duplicate of this bug. ***
Comment 7 Raúl Porcel (RETIRED) gentoo-dev 2008-12-05 10:07:59 UTC
x86 stable, closing