Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 238947

Summary: [QA] www-client/mozilla-firefox-3.0.10: Pre-stripped files found: set QA_PRESTRIPPED for preventing warning
Product: Gentoo Linux Reporter: Pacho Ramos <pacho>
Component: Current packagesAssignee: Mozilla Gentoo Team <mozilla>
Status: RESOLVED FIXED    
Severity: minor CC: eva, flameeyes, loki_val, pesa, sandro.bonazzola
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 239866    

Description Pacho Ramos gentoo-dev 2008-09-28 15:21:32 UTC
I get the following:
QA Notice: Pre-stripped files found:
/var/tmp/portage/www-client/mozilla-firefox-3.0.3/image/usr/lib64/mozilla-firefox/firefox

When merging firefox with:
www-client/mozilla-firefox-3.0.3  USE="dbus gnome java startup-notification xulrunner -bindist -custom-optimization -iceweasel -ipv6 -mozdevelop -restrict-javascript" LINGUAS="en_US es es_ES -af -ar -be -bn -bn_IN -ca -cs -da -de -el -en -en_GB -es_AR -eu -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hu -id -is -it -ja -ka -kn -ko -ku -lt -mk -mn -mr -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -th -tr -uk -zh -zh_CN -zh_TW"

Portage 2.1.4.4 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.26-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.26-gentoo-r1 x86_64 AMD Athlon(tm) 64 Processor 3200+
Timestamp of tree: Sun, 28 Sep 2008 14:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -msse3"
DISTDIR="/usr/distfiles"
FEATURES="autoaddcvs ccache collision-protect cvs distlocks metadata-transfer multilib-strict parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 asf audiofile avahi bash-completion beagle berkdb bzip2 bzlib cairo caps cdb cdda cddb cdparanoia cdr cli consolekit cpdflib cpudetection cracklib cross crypt cups curl daap dbus dga divx4linux djvu dlloader dri dts dv dvb dvd dvdr dvdread dvi eds emboss encode epiphany erandom escreen evo evolution exif fam fame fbcon ffmpeg flac foomaticdb fortran ftp fuse galago gb gcj gd ggi gif gimp gimpprint git glitz glut glx gnome gnome-keyring gnome-print gphoto2 gpm gstreamer gtk gtk2 hal hddtemp iconv idn imagemagick imlib inotify isdnlog ithreads jabber java jpeg kdeenablefinal kdehiddenvisibility kpathsea ladspa lame latex lcms libnotify lm_sensors logrotate lzma mad madwifi midi mikmod mime mjpeg mmx mmxext mng mono moonlight motif mp3 mpeg mpi mplayer mudflap multilib musepack musicbrainz nas nautilus ncurses nethack network nls nocardbus nptl nptlonly nvidia ogg oggvorbis openal opengl openmp pam pch pcre pdf perl plotutils png posix postscript ppds pppd python qt3 qt3support qt4 quicktime readline reflection remote rtc scanner sdl session slang slp sockets spell spl sse sse2 sse3 ssl startup-notification subversion svg sysfs sysvipc t1lib tcpd theora threads thunderbird tiff timidity totem trayicon truetype unicode usb v4l v4l2 vcd videos vim vorbis wma wmf xattr xcb xcomposite xft xine xml xml2 xorg xpm xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa fbdev vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 Raúl Porcel (RETIRED) gentoo-dev 2008-09-28 15:28:37 UTC
Thats because is a copy of the system's xulrunner binary, nothing we can do.
Comment 2 Pacho Ramos gentoo-dev 2008-09-28 15:35:05 UTC
OK, thanks for the info
Comment 3 Raúl Porcel (RETIRED) gentoo-dev 2008-12-22 15:27:49 UTC
*** Bug 252074 has been marked as a duplicate of this bug. ***
Comment 4 Raúl Porcel (RETIRED) gentoo-dev 2009-02-11 23:24:08 UTC
*** Bug 258644 has been marked as a duplicate of this bug. ***
Comment 5 Pacho Ramos gentoo-dev 2009-02-12 08:21:28 UTC
Now that bug 251976 is fixed, this can be fixed :-D
Comment 6 Davide Pesavento gentoo-dev 2009-07-24 16:37:32 UTC
Still not fixed in mozilla-firefox-3.5.1
Comment 7 Jory A. Pratt gentoo-dev 2009-07-24 22:52:26 UTC
(In reply to comment #6)
> Still not fixed in mozilla-firefox-3.5.1
> 

show me a list of these files that are prestripped please.
Comment 8 Davide Pesavento gentoo-dev 2009-07-25 19:15:44 UTC
QA Notice: Pre-stripped files found:
/usr/lib64/mozilla-firefox/firefox
Comment 9 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-08-20 08:53:43 UTC
Still present in 3.5.2-r1:
 * QA Notice: Pre-stripped files found:
 * /usr/lib/mozilla-firefox/firefox
Comment 10 Jory A. Pratt gentoo-dev 2009-12-27 01:16:53 UTC
Has been fixed in 3.5.6 for icecat/firefox along with mozilla overlay.
Comment 11 Pacho Ramos gentoo-dev 2009-12-27 12:54:49 UTC
Thanks a lot