Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 236565

Summary: ebuild for ultrastar deluxe/ultrastardx
Product: Gentoo Linux Reporter: Account removed <96bd763529be62c7350d43e8ae67f9623c998ddc>
Component: [OLD] GamesAssignee: Gentoo Games <games>
Status: RESOLVED LATER    
Severity: enhancement CC: blog, devurandom, flokli, kripton, markus.heier
Priority: High Keywords: EBUILD
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://ultrastardx.sourceforge.net/
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: games-arcade/ultrastardx/ultrastardx-9999.ebuild
games-arcade/ultrastardx/ultrastardx-9999.ebuild
games-arcade/ultrastardx/ultrastardx-9999.ebuild
games-arcade/ultrastardx/ultrastardx-9999.ebuild
games-arcade/ultrastardx/ultrastardx-9999.ebuild
games-arcade/ultrastardx/ultrastardx-9999.ebuild

Description Account removed 2008-09-03 13:36:36 UTC
initial svn ebuild for the karaoke game ultrastardx

Reproducible: Always
Comment 1 Account removed 2008-09-03 13:37:15 UTC
Created attachment 164484 [details]
games-arcade/ultrastardx/ultrastardx-9999.ebuild
Comment 2 Account removed 2008-09-03 13:49:48 UTC
Created attachment 164486 [details]
games-arcade/ultrastardx/ultrastardx-9999.ebuild

removed some unneeded functions
Comment 3 Account removed 2008-09-03 15:58:59 UTC
Created attachment 164497 [details]
games-arcade/ultrastardx/ultrastardx-9999.ebuild

uses keepdir instead of dodir for empty songs directory now - thanks MrBones
Comment 4 Account removed 2008-09-27 14:39:44 UTC
Created attachment 166585 [details]
games-arcade/ultrastardx/ultrastardx-9999.ebuild

upstream changed font path
new fixed ebuild
Comment 5 Account removed 2009-02-11 12:19:46 UTC
Created attachment 181658 [details]
games-arcade/ultrastardx/ultrastardx-9999.ebuild

cosmetics for repoman
Comment 6 Jens Mueller 2009-05-18 19:35:58 UTC
lib/ffmpeg/avutil.pas(86,4) Error: User defined: Linked version of libavutil is not yet supported!
lib/ffmpeg/avutil.pas(318,1) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode (normal if you did not specify a source file to be compiled)
make[1]: *** [../game/ultrastardx] Fehler 1
make[1]: Leaving directory `/mnt/sda5/usr-tmp-portage/portage/games-arcade/ultrastardx-9999/work/ultrastardx-9999/src'
make: *** [all] Fehler 2
 *
 * ERROR: games-arcade/ultrastardx-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2892:  Called die
 * The specific snippet of code:
 *       emake LDFLAGS="" || die "emake failed"
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/mnt/sda5/usr-tmp-portage/portage/games-arcade/ultrastardx-9999/temp/build.log'.
 * The ebuild environment file is located at '/mnt/sda5/usr-tmp-portage/portage/games-arcade/ultrastardx-9999/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/'
 *
Comment 8 Account removed 2009-05-20 14:01:04 UTC
This is an upstream-"problem" and I'm not going to fix this.
Comment 9 Tim Teichmann 2009-06-25 00:10:07 UTC
rm -f ../build/fpc-x86_64-linux/Hold_The_Line.o ../build/fpc-x86_64-linux/libHold_The_Line.*
fpc -Si -Sg- -Sc- -v0Binwe -Xs- -O2 -k"-z noexecstack" -FE../game/plugins -Fu../build/fpc-x86_64-linux -FU../build/fpc-x86_64-linux Don\'t_Get_Worse/Hold_The_Line.dpr
Free Pascal Compiler version 2.2.0 [2009/06/25] for x86_64
Copyright (c) 1993-2007 by Florian Klaempfl
Target OS: Linux for x86-64
Compiling Don't_Get_Worse/Hold_The_Line.dpr
Linking ../game/plugins/libHold_The_Line.so
/usr/bin/ld: ../build/fpc-x86_64-linux/gl.o: relocation R_X86_64_32S against `U_GL_GLACCUM' can not be used when making a shared object; recompile with -fPIC
../build/fpc-x86_64-linux/gl.o: could not read symbols: Bad value
Hold_The_Line.dpr(228) Error: Error while linking
Hold_The_Line.dpr(228) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode (normal if you did not specify a source file to be compiled)
make[1]: *** [Dont_Get_Worse] Error 1
make[1]: Leaving directory `/var/tmp/portage/games-arcade/ultrastardx-9999/work/ultrastardx-9999/plugins'
make: *** [all] Error 2
 *
 * ERROR: games-arcade/ultrastardx-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2943:  Called die
 * The specific snippet of code:
 *       emake LDFLAGS="" || die "emake failed"
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/games-arcade/ultrastardx-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/games-arcade/ultrastardx-9999/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/'
 *
Comment 10 Account removed 2009-06-25 07:14:31 UTC
I can't reproduce your error, but I'm on x86.
I also have problems with linking the plugins
("Error: Can't call the linker, switching to external linking"),
but I guess the bug is outside of the ebuild.
maybe our ffmpeg version still doesn't work with the game or some libs are missing in the linker - no idea.
btw there's also an ebuild directly in the svn-trunk under
dists/gentoo, which probably also doesn't work atm.
Comment 11 Tim Teichmann 2009-06-26 11:23:49 UTC
It was my fault.
Everything worked fine after adding the option "-Cg" in /etc/fpc.cfg...
Comment 12 Account removed 2009-06-26 11:39:24 UTC
thx for heads up!
not unlikely that the build error with the plugins also is fixable within
fpc.cfg, but I know almost /dev/null about fpc :)
Comment 13 Account removed 2010-01-14 08:37:09 UTC
Created attachment 216465 [details]
games-arcade/ultrastardx/ultrastardx-9999.ebuild

update for latest upstream changes.
atm you'll have to build with USE="-libprojectM" as the plugin is broken upstream.
Comment 14 Florian Klink 2010-01-18 00:31:31 UTC
Big things happened the last days ;-)

I think the lua branch was merged back to master and projectm works again, too!

I modified the ebuild to reflect the changes and fixed some other things, too.
You can download it from my gitorious: http://gitorious.org/flokli-overlay/flokli-overlay/trees/master/games-arcade/ultrastardx

Commit message (1bb0fc935e33667db5ceafad6030168d3506d56e):

add ebuild for games-arcade/ultrastardx
- upstream merged lua branch to master, so it is a dependency
- renamed "libprojectM" useflag to "projectm", because it's called like
that in many other ebuilds, too.
- changed RDEPEND packages to DEPEND packages (you already need most of
them to build the package)
- added a patch to remove annoying ffmpeg checks inside pascal code,
it would be better to use gentoo-ish version-dependencies
- fixed application icon and .desktop file
Comment 15 Account removed 2010-01-18 07:54:38 UTC
hi!
hey, thx for your help!
tbh my latest update was quick&dirty... :)
- removed the ffmpeg check here locally before upload, as it isn't required atm,
  sure this can change anytime, so good the patch is back in :)
- maybe we should split DEPEND and RDEPEND completely
- projectm still aborts build with

projectM-cwrapper.cpp:(.text+0x193): undefined reference to `__dso_handle'

haven't looked at it yet.

if you'd like to maintain this ebuild and also are looking for a
nice game overlay checkout our gamerlay.
http://git.overlays.gentoo.org/gitweb/?p=proj/gamerlay.git;
haven't pushed ultrastardx there yet.

catch us f.e. on freenodes irc #gentoo-gamerlay


Comment 16 Account removed 2010-06-15 07:05:12 UTC
commited an updated live ebuild to gamerlay overlay.
soon to be released 1.1 will be there too.
closing this bug...
Comment 17 Dennis Schridde 2012-02-26 16:39:20 UTC
1.1 final has been released - will it appear in portage?