Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 236430

Summary: XEN kernel compiles always with PAE support even when I set "-pae" as USE flag
Product: Gentoo Linux Reporter: Wojciech Pawlikowski <wojtekp>
Component: Current packagesAssignee: Gentoo Xen Devs <xen>
Status: RESOLVED WORKSFORME    
Severity: major CC: gentoo
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Wojciech Pawlikowski 2008-09-02 10:31:25 UTC
app-emulation/xen-3.3.0:

I'm fighting with this problem since yesterday. I've decided to install gentoo-xen (XEN 3.3.0), but because it's just my home box I've got only 2 GB of ram - I simply do not need PAE support. I disabled it during the xen xen-tools and xen-sources installation:

# USE="-pae" emerge -va xen-sources xen-tools xen

Then I compiled linux-2.6.21-xen, copied vmlinuz to /boot, edited grub.conf to actually use /boot/xen.gz as a kernel and vmlinux-2.6.21-xen as a module, then I restarted it and all the time I've got the same stuff:

(XEN) *** LOADING DOMAIN 0 ***
(XEN)  Xen  kernel: 32-bit, lsb
(XEN)  Dom0 kernel: 32-bit, PAE, lsb, paddr 0x100000 -> 0x664000
(XEN) Mismatch between Xen and DOM0 kernel
(XEN)
(XEN) ****************************************
(XEN) Panic on CPU 0:
(XEN) Could not set up DOM0 guest OS
(XEN) ****************************************
(XEN)
(XEN) Reboot in five seconds... 

BUT

When I compile Dom0 kernel with high memory support (64 GB) it works well, however PAE is reasonable new feature in Operating Systems which I'd like to use as DomUs, so that's why I'd like to solve this problem.

My emerge --info from the same machine, but running gentoo-sources-2.6.25-r7:

Portage 2.1.4.4 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 i686)
=================================================================
System uname: 2.6.25-gentoo-r7 i686 Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz
Timestamp of tree: Tue, 02 Sep 2008 07:04:02 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.4.4-r13, 2.5.2-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r2
sys-devel/automake:  1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -mno-tls-direct-seg-refs"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://88.156.78.16/gentoo/ http://gentoo.mirror.web4u.cz/ ftp://ftp.fi.muni.cz/pub/linux/gentoo/ ftp://gentoo.mirror.web4u.cz/ http://mirror.uni-c.dk/pub/gentoo/"
LDFLAGS="-Wl,-O1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups dri gdbm gpm hvm iconv isdnlog midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection sdl session spl ssl sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY



Reproducible: Always

Steps to Reproduce:
1. Compile xen-sources, xen-tools and xen without PAE support
2. Reboot the machine
3. Check for errors
Comment 1 Wojciech Pawlikowski 2008-09-02 10:34:03 UTC
(XEN) *** LOADING DOMAIN 0 ***
(XEN)  Xen  kernel: 32-bit, PAE
(XEN)  Dom0 kernel: 32-bit, lsb, paddr 0x100000 -> 0x664000
(XEN) Mismatch between Xen and DOM0 kernel
(XEN)
(XEN) ****************************************
(XEN) Panic on CPU 0:
(XEN) Could not set up DOM0 guest OS
(XEN) ****************************************
(XEN)
(XEN) Reboot in five seconds... 

It looks more like this, I just taken it from other bug report with very similar output. XEN kernel is PAE and Dom0 kernel lacks PAE.
Comment 2 Micheal Marineau (RETIRED) gentoo-dev 2008-09-02 17:49:19 UTC
Upstream Xen has dropped support for non-pae builds since it didn't receive extensive testing (XenSource and most distros all ship pae builds). We'll need to remove the pae flag from the 3.3 xen ebuild and add an ewarn about the change. Older versions of xen will respect the pae flag though. Also, you might want to use the latest 2.6.18 xen kernel instead of 2.6.21, it is actually more up-to-date with newer xen and security patches.

Sorry for the confusion!
Comment 3 Wojciech Pawlikowski 2008-09-02 18:42:47 UTC
Thanks for the info, however 2.6.21 was chosen by emerge when I wanted to merge it into my system.
Comment 4 Micheal Marineau (RETIRED) gentoo-dev 2008-09-02 19:33:02 UTC
Yeah, I'll mask .20 and .21 later today to nudge people towards .18 until the day when we have a non-sucky kernel. :-)
Comment 5 Simon Gao 2008-10-24 22:06:03 UTC
(In reply to comment #4)
> Yeah, I'll mask .20 and .21 later today to nudge people towards .18 until the
> day when we have a non-sucky kernel. :-)

However, kernel 2.6.21 has the driver fix for Broadcom ExtremeII NIC (bnx2) which confusing Xen daemon when NICs flip the order being found.

It's really nice to put all the patches into 2.6.21.

 
Comment 6 Alexey Shvetsov gentoo-dev 2011-03-26 11:40:51 UTC
Xen 4.1 in tree. Please test with it and reopen if it doesnt work