Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 234293

Summary: net-misc/asterisk-1.2.27 channel_find_locked: Avoided initial deadlock for ...
Product: Gentoo Linux Reporter: Joseph <syscon780>
Component: Current packagesAssignee: Tony Vroon <chainsaw>
Status: RESOLVED CANTFIX    
Severity: normal CC: rajiv, voip+disabled
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Joseph 2008-08-09 06:01:28 UTC
I've compiled asterisk-1.2.27 on Via Eden mini-itx but when I try to make a call I get:

WARNING[16224]: channel.c:780 channel_find_locked: Avoided initial 
deadlock for '0x818a3b8', 9 retries!

I'm running save version of asterisk on two other systems and don't see this error.
Looking up on Digium bug-board that another Gentoo user posted with the same error:
http://bugs.digium.com/view.php?id=12435#bugnotes

I see that Digium no longer accept but post for Asterisk-1.2 so there will be no fix.
Is it time to move to Asterisk-1.4 ??




Reproducible: Always




Portage 2.1.4.4 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 
i686)
=================================================================
System uname: 2.6.25-gentoo-r7 i686 VIA Eden Processor 1200MHz
Timestamp of tree: Fri, 08 Aug 2008 14:30:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=c3-2 -mtune=c3-2 -pipe -mfpmath=sse,387 -msse2 -mmmx -msse"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/fax /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf 
/etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=c3-2 -mtune=c3-2 -pipe -mfpmath=sse,387 -msse2 -mmmx -msse"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distcc distlocks metadata-transfer parallel-fetch 
sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distro.ibiblio.org/pub/linux/distributions/gentoo/ 
ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://mirror.mdfnet.se/mirror/gentoo 
"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress 
--force --whole-file --delete --stats --timeout=180 --exclude=/distfiles 
--exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl apache2 berkdb bzip2 cli cracklib crypt cups dbus dri fam foomaticdb 
fortran gdbm gpm hal iconv ipv6 isdnlog java jpeg midi mudflap mysql ncurses nls nptl 
nptlonly opengl openmp pam pcre perl png ppds pppd python readline reflection scanner 
session spl ssl startup-notification sysfs tcpd tetex tiff truetype type1 unicode usb 
x86 xorg xscreensaver zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x 
ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 
intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" 
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks 
iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route 
share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon 
authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host 
authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env 
expires ext_filter file_cache filter headers include info log_config logio mem_cache 
mime mime_magic negotiation rewrite setenvif speling status unique_id userdir 
usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" 
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" 
LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="vga vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, 
PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ɓukasz Damentko (RETIRED) gentoo-dev 2009-03-17 23:12:24 UTC
Moving to other maintainers since stkn left Gentoo.
Comment 2 Tony Vroon gentoo-dev 2009-03-17 23:52:21 UTC
It would be worth trying Asterisk 1.6.0.6 which is in the tree for you now. But, if you want to stay on the 1.2 branch, there's also 1.2.31.1 for you. For the record, I see this message occur without ill effects on our production system. This message by itself might not tell the full story.

I'm sorry to say that I can't take bug reports for Asterisk 1.2 as Digium have discontinued this branch entirely.