Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 232290

Summary: Sendmail is blocked by sSMTP even though sSMTP isn't installed
Product: Gentoo Linux Reporter: Matt Rechkemmer <matt+bugzilla>
Component: [OLD] ServerAssignee: Portage team <dev-portage>
Status: RESOLVED DUPLICATE    
Severity: normal CC: jer
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://forums.gentoo.org/viewtopic-t-609569-highlight-sendmail+ssmtp+block.html
Whiteboard:
Package list:
Runtime testing required: ---

Description Matt Rechkemmer 2008-07-19 04:02:43 UTC
On a brand new Gentoo 2008.0 system with only gentoo-sources merged, attempting to merge sendmail fails.  Portage complains that Sendmail is blocking sSMTP and sSMTP is blocking Sendmail.  sSMTP isn't even installed...

Reproducible: Always

Steps to Reproduce:
1.  Get a fresh Gentoo system going.
2.  emerge -av sendmail
Actual Results:  
Portage complains about the following blockers:

[blocks B     ] mail-mta/sendmail (is blocking mail-mta/ssmtp-2.61-r2)
[blocks B     ] mail-mta/ssmtp (is blocking mail-mta/sendmail-8.14.0)

Expected Results:  
Portage should just install Sendmail.  It's the MTA being requested.

Portage 2.1.4.4 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r6-kagami i686)
=================================================================
System uname: 2.6.25-gentoo-r6-kagami i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Timestamp of tree: Fri, 18 Jul 2008 22:15:01 +0000
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.iawnet.sandia.gov/pub/gentoo/ http://gentoo.osuosl.org/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage-overlay"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt dri fortran gdbm gpm iconv ipv6 isdnlog midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl ssl tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2008-07-19 12:29:32 UTC
What happens, when you mask mail-mta/ssmtp locally?
Comment 2 Rafał Mużyło 2008-07-19 13:08:18 UTC
Actually the real question should be:
what does 'emerge -pvt sendmail' print ?
Comment 3 Jeroen Roovers gentoo-dev 2008-07-19 13:23:19 UTC
Another good question would be - what does `emerge -vpC ssmpt' print?
Comment 4 Jeroen Roovers gentoo-dev 2008-07-19 13:30:29 UTC
Calculating dependencies... done!
[ebuild  N    ] mail-mta/sendmail-8.14.0  USE="ipv6 ldap mailwrapper ssl tcpd -mbox -nis -sasl -sockets" 0 kB
[ebuild  N    ]  mail-filter/procmail-3.22-r7  USE="-mbox (-selinux)" 0 kB
[ebuild  N    ]   mail-mta/ssmtp-2.61-r2  USE="ipv6 mailwrapper ssl -md5sum" 0 kB
[ebuild  N    ]  net-nds/openldap-2.3.41  USE="berkdb crypt gdbm ipv6 perl ssl tcpd -debug -kerberos -minimal -odbc -overlays -samba -sasl (-selinux) -slp -smbkrb5passwd" 0 kB
[ebuild  N    ]  net-mail/mailwrapper-0.2.1  0 kB
[ebuild  N    ]  net-mail/mailbase-1  USE="pam" 0 kB

Total: 6 packages (6 new), Size of downloads: 0 kB

You probably want to set USE=mailwrapper globally.
Comment 5 Matt Rechkemmer 2008-07-19 21:08:57 UTC
=====================
emerge -pvt sendmail:
=====================

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  N    ] mail-mta/sendmail-8.14.0  USE="ipv6 ssl tcpd -ldap -mailwrapper -mbox -nis -sasl -sockets" 2,009 kB
[ebuild  N    ]  mail-filter/procmail-3.22-r7  USE="-mbox (-selinux)" 222 kB
[ebuild  N    ]   mail-mta/ssmtp-2.61-r2  USE="ipv6 ssl -mailwrapper -md5sum" 53 kB
[ebuild  N    ]    net-mail/mailbase-1  USE="pam" 0 kB
[blocks B     ] mail-mta/ssmtp (is blocking mail-mta/sendmail-8.14.0)
[blocks B     ] mail-mta/sendmail (is blocking mail-mta/ssmtp-2.61-r2)

Total: 4 packages (4 new, 2 blocks), Size of downloads: 2,283 kB

==================
emerge -vpC ssmtp:
==================

>>> These are the packages that would be unmerged:

--- Couldn't find 'ssmtp' to unmerge.

>>> No packages selected for removal by unmerge

==================================================

* Masking ssmtp seems to resolve the problem, but this seems like it shouldn't be necessary.
* Even with the mailwrapper USE flag set, Portage still tries to pull in ssmtp.  ssmtp isn't the desired MTA, so it shouldn't be pullled in.
Comment 6 Carsten Lohrke (RETIRED) gentoo-dev 2008-07-20 17:11:22 UTC
The only relating reference I could find wrt. virtual dependency resolution is bug 68220, even though I was almost sure this particular issue has been filed as a bug long ago. But the open bugs blocking bug 155723 do not relate to this particular problem either.


Portage doesn't take into account that one of the packages it is emerging satisfies a virtual, grabs the first package satisfying the virtual and creates this blocker-nonsense.
Comment 7 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2008-07-20 22:05:20 UTC
How is this not bug 1343 ?
Comment 8 Zac Medico gentoo-dev 2008-07-20 22:44:53 UTC
(In reply to comment #7)
> How is this not bug 1343 ?

It is. However, it's worth noting that this particular case of bug 1343 is handled much better by >=portage-2.1.5 than it was by previous versions (like 2.1.4.4).


*** This bug has been marked as a duplicate of bug 1343 ***
Comment 9 Carsten Lohrke (RETIRED) gentoo-dev 2008-07-21 01:13:37 UTC
(In reply to comment #7)
> How is this not bug 1343 ?
> 

Ah, of course - there's a reason I were glasses. ;)