Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 230998

Summary: 2008.0 LiveCD for x86/amd64 messes up when copying kernel/initramfs into tmpfs
Product: Gentoo Release Media Reporter: Chris Spencer <millionaire317>
Component: LiveCD/DVDAssignee: Gentoo Release Team <release>
Status: RESOLVED FIXED    
Severity: critical CC: ama.noname, flamedunord, itsashowtime, jer, truefusion
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Chris Spencer 2008-07-06 21:28:12 UTC
Halfway through the install (I believe around the kernel copy process) words pop up in the background of the console with the message "ls: cannot access /mnt/gentoo/boot/kernel-*: No such file or directory" The install continues, but eventually crashes with the message

MountError :FATAL: mount_load_partitioner: Could not mount partition

You can try to ignore it and go forward, but this only causes more errors.

After a reboot, Grub stops with an error.This leaves my old installation formatted, and my new installation unusable.

Complete install log is posted below in Additional Information.

Reproducible: Always

Steps to Reproduce:
1.Install the AMD64 LiveCD
2.Pick the console installer
3.Format partitions and perform a clean install




GLI: July 06 2008 16:35:15 - Gentoo Linux Installer version 0.6.6
GLI: July 06 2008 16:38:40 - Mounted mountpoint: /
GLI: July 06 2008 16:46:16 - Stage3 was generated successfully
GLI: July 06 2008 16:46:17 - fstab configured.
GLI: July 06 2008 16:46:17 - Config files updated using etc-update.  make.conf/fstab/rc.conf restored.
GLI: July 06 2008 16:46:18 - Make.conf configured
GLI: July 06 2008 16:46:19 - Chroot environment ready.
GLI: July 06 2008 16:47:24 - Portage tree install was custom.
GLI: July 06 2008 16:47:25 - fstab configured.
GLI: July 06 2008 16:47:25 - Config files updated using etc-update.  make.conf/fstab/rc.conf restored.
GLI: July 06 2008 16:47:26 - Make.conf configured
GLI: July 06 2008 16:48:03 - Root Password set on the new system.
GLI: July 06 2008 16:48:04 - Edited Config file /mnt/gentoo/etc/conf.d/clock
GLI: July 06 2008 16:48:04 - Edited Config file /mnt/gentoo/etc/conf.d/clock
GLI: July 06 2008 16:48:04 - Timezone set.
GLI: July 06 2008 16:48:05 - Starting emerge_kernel, package is livecd-kernel
GLI: July 06 2008 16:48:30 -  -- MARK -- 
GLI: July 06 2008 16:48:30 - Starting build_kernel
GLI: July 06 2008 16:49:06 - Edited Config file /mnt/gentoo/etc/conf.d/hostname
GLI: July 06 2008 16:49:06 - Edited Config file /mnt/gentoo/etc/conf.d/domainname
GLI: July 06 2008 16:49:06 - ERROR! Failure adding domainname to runlevel default because it was not found!
GLI: July 06 2008 16:49:06 - ERROR! Could not add domainname to runlevel default. returned a bad status code.
GLI: July 06 2008 16:49:06 - Edited Config file /mnt/gentoo/etc/hosts
GLI: July 06 2008 16:49:06 - Added net.eth0 to runlevel default
GLI: July 06 2008 16:49:06 - Edited Config file /mnt/gentoo/etc/conf.d/net
GLI: July 06 2008 16:49:10 - dhcpcd emerged.
GLI: July 06 2008 16:49:28 - Added syslog-ng to runlevel default
GLI: July 06 2008 16:49:28 - Logging daemon installed: syslog-ng
GLI: July 06 2008 16:49:46 - Added vixie-cron to runlevel default
GLI: July 06 2008 16:49:46 - Cron daemon installed and configured: vixie-cron
GLI: July 06 2008 16:49:58 - Emerged the selected bootloader.
GLI: July 06 2008 16:49:59 - Output of Kernel Names:
ls: cannot access /mnt/gentoo/boot/kernel-*: No such file or directory

GLI: July 06 2008 16:49:59 - Exception received during 'Configuring and installing bootloader': BootloaderError :FATAL: _configure_grub: Error listing the kernels in /boot
GLI: July 06 2008 16:49:59 - Traceback (most recent call last):
GLI: July 06 2008 16:49:59 - File "/opt/installer/GLIClientController.py", line 122, in run
    func()
GLI: July 06 2008 16:49:59 - File "/opt/installer/templates/x86ArchitectureTemplate.py", line 46, in install_bootloader
    self._configure_grub()
GLI: July 06 2008 16:49:59 - File "/opt/installer/templates/x86ArchitectureTemplate.py", line 61, in _configure_grub
    raise GLIException("BootloaderError", 'fatal', '_configure_grub', "Error listing the kernels in /boot")
GLI: July 06 2008 16:49:59 - GLIException: BootloaderError :FATAL: _configure_grub: Error listing the kernels in /boot
GLI: July 06 2008 16:52:21 - Exception received during 'Configuring and installing bootloader': GetDepListError :FATAL: get_deps: Dep list is empty. This usually means there is no portage tree in the chroot
GLI: July 06 2008 16:52:21 - Traceback (most recent call last):
GLI: July 06 2008 16:52:21 - File "/opt/installer/GLIClientController.py", line 122, in run
    func()
GLI: July 06 2008 16:52:21 - File "/opt/installer/templates/x86ArchitectureTemplate.py", line 35, in install_bootloader
    exitstatus = self._portage.emerge(bootloader_pkg, self._install_profile.get_grp_install())
GLI: July 06 2008 16:52:21 - File "/opt/installer/GLIPortage.py", line 295, in emerge
    pkglist = self.get_deps(packages, grp_install)
GLI: July 06 2008 16:52:21 - File "/opt/installer/GLIPortage.py", line 54, in get_deps
    raise GLIException("GetDepListError", 'fatal', 'get_deps', "Dep list is empty. This usually means there is no portage tree in the chroot")
GLI: July 06 2008 16:52:21 - GLIException: GetDepListError :FATAL: get_deps: Dep list is empty. This usually means there is no portage tree in the chroot
GLI: July 06 2008 16:54:03 - Exception received during 'Configuring and installing bootloader': GetDepListError :FATAL: get_deps: Dep list is empty. This usually means there is no portage tree in the chroot
GLI: July 06 2008 16:54:03 - Traceback (most recent call last):
GLI: July 06 2008 16:54:03 - File "/opt/installer/GLIClientController.py", line 122, in run
    func()
GLI: July 06 2008 16:54:03 - File "/opt/installer/templates/x86ArchitectureTemplate.py", line 35, in install_bootloader
    exitstatus = self._portage.emerge(bootloader_pkg, self._install_profile.get_grp_install())
GLI: July 06 2008 16:54:03 - File "/opt/installer/GLIPortage.py", line 295, in emerge
    pkglist = self.get_deps(packages, grp_install)
GLI: July 06 2008 16:54:03 - File "/opt/installer/GLIPortage.py", line 54, in get_deps
    raise GLIException("GetDepListError", 'fatal', 'get_deps', "Dep list is empty. This usually means there is no portage tree in the chroot")
GLI: July 06 2008 16:54:03 - GLIException: GetDepListError :FATAL: get_deps: Dep list is empty. This usually means there is no portage tree in the chroot
Comment 1 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-06 22:17:24 UTC
This one isn't really the installer's fault. We're working on a fix, which we'll put out as 2008.0-r1 for the x86 and amd64 LiveCDs.
Comment 2 Preston Cody (RETIRED) gentoo-dev 2008-07-07 01:39:58 UTC
Andrew,
Seeing as how we're likely to get dupes of this if the livecds are indeed broken, can you provide a more detailed explanation?  Was grub left out?
-Codeman
Comment 3 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-07 02:16:10 UTC
A hack was added at the last minute in order to get the size of the LiveCD down below 700MB. We empty out /boot in the squashfs and then at boot time, we mount a tmpfs and copy back in the kernel/initramfs from the ISO root. This procedure was mostly untested and apparently a bit buggy.
Comment 4 Chris Spencer 2008-07-07 05:32:02 UTC
Would it be possible to boot from a livecd, then manually copy the kernel over to the partition, and then reconfigure grub?

Either that, or I'll just revert back to Beta 2.
Comment 5 Dawid Węgliński (RETIRED) gentoo-dev 2008-07-07 10:56:26 UTC
*** Bug 231037 has been marked as a duplicate of this bug. ***
Comment 6 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-07 16:11:43 UTC
The 2008.0-r1 x86/amd64 LiveCDs have been released and will be hitting a mirror near you soon.
Comment 7 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-07 20:18:51 UTC
*** Bug 231080 has been marked as a duplicate of this bug. ***
Comment 8 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-07 23:48:46 UTC
*** Bug 231121 has been marked as a duplicate of this bug. ***
Comment 9 Dawid Węgliński (RETIRED) gentoo-dev 2008-08-25 00:56:46 UTC
*** Bug 235640 has been marked as a duplicate of this bug. ***
Comment 10 Wormo (RETIRED) gentoo-dev 2008-09-06 06:19:16 UTC
*** Bug 236830 has been marked as a duplicate of this bug. ***
Comment 11 Dawid Węgliński (RETIRED) gentoo-dev 2009-03-17 17:15:17 UTC
*** Bug 262815 has been marked as a duplicate of this bug. ***