Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 230780

Summary: net-im/licq-1.3.5-r1 fails with libtool-2.2.4
Product: Gentoo Linux Reporter: Matthias Schwarzott <zzam>
Component: New packagesAssignee: Gentoo net-im Herd <net-im>
Status: RESOLVED FIXED    
Severity: normal CC: lordcris, polynomial-c
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 212763    

Description Matthias Schwarzott gentoo-dev 2008-07-04 18:24:18 UTC
net-im/licq-1.3.5-r1 fails with libtool-2.2.4

# emerge licq
...
if i686-pc-linux-gnu-gcc -DLOCALEDIR=\"/usr/share/locale\" -DHAVE_CONFIG_H -I/usr/include/gpgme -I. -I. -I..  -Wall -I../include  -fPIC -DPIC -D_REENTRANT -I/usr/include/gpgme  -O2 -march=pentium3 -mtune=athlon-xp -fomit-frame-pointer -pipe -MT providers.o -MD -MP -MF ".deps/providers.Tpo" -c -o providers.o providers.c; \
        then mv -f ".deps/providers.Tpo" ".deps/providers.Po"; else rm -f ".deps/providers.Tpo"; exit 1; fi
if i686-pc-linux-gnu-g++ -DLOCALEDIR=\"/usr/share/locale\" -DHAVE_CONFIG_H -I/usr/include/gpgme -I. -I. -I..  -Wall -I../include  -fPIC -DPIC -D_REENTRANT -I/usr/include/gpgme  -O2 -march=pentium3 -mtune=athlon-xp -fomit-frame-pointer -pipe -fno-exceptions -fno-check-new -MT rtf.o -MD -MP -MF ".deps/rtf.Tpo" -c -o rtf.o rtf.cc; \
        then mv -f ".deps/rtf.Tpo" ".deps/rtf.Po"; else rm -f ".deps/rtf.Tpo"; exit 1; fi
rtf.cc: In function 'int rtflex()':
rtf.cc:701: warning: label 'find_rule' defined but not used
rtf.cc: At global scope:
rtf.cc:1628: warning: 'void* yy_flex_realloc(void*, yy_size_t)' defined but not used
rtf.cc:1602: warning: 'int yy_flex_strlen(const char*)' defined but not used
/bin/sh ../libtool --tag=CXX --mode=link i686-pc-linux-gnu-g++  -O2 -march=pentium3 -mtune=athlon-xp -fomit-frame-pointer -pipe -fno-exceptions -fno-check-new  -Wl,-O1,--as-needed -o licq -export-dynamic   licq.o main.o icqpacket.o proxy.o socket.o icqd.o icqd-tcp.o icqd-srv.o icqd-threads.o icqevent.o buffer.o user.o history.o utility.o countrycodes.o log.o translate.o file.o message.o support.o pthread_rdwr.o onevent.o plugind.o sar.o languagecodes.o icqd-chat.o sighandler.o icqd-filetransfer.o hebrev.o icqcolor.o fifo.o protoplugind.o gpg.o occupationcodes.o homepagecodes.o interestcodes.o organizationcodes.o backgroundcodes.o providers.o rtf.o  -lssl -lcrypto -ldl -lpthread  -lnsl -lgpgme -lgpg-error
../libtool: line 463: CDPATH: command not found
../libtool: line 1148: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
make[2]: *** [licq] Error 63
make[2]: Leaving directory `/var/tmp/portage/net-im/licq-1.3.5-r1/work/licq-1.3.5/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-im/licq-1.3.5-r1/work/licq-1.3.5'
make: *** [all] Error 2
 *
 * ERROR: net-im/licq-1.3.5-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3387:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed";

$ emerge --info
Portage 2.2_rc1 (default-linux/x86/2007.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-tuxonice-r6 i686)
=================================================================
System uname: Linux-2.6.25-tuxonice-r6-i686-AMD_Athlon-tm-_XP_3000+-with-glibc2.0
Timestamp of tree: Fri, 04 Jul 2008 06:45:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     9999
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -mtune=athlon-xp -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium3 -mtune=athlon-xp -fomit-frame-pointer -pipe"
DISTDIR="/usr/my-distfiles"
FEATURES="autoaddcvs ccache collision-detect cvs distlocks parallel-fetch preserve-libs sandbox sfperms sign splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mneisen.org/"
LANG="de_DE.utf8"
LC_ALL="C"
LDFLAGS="-Wl,-O1,--as-needed"
LINGUAS="de en en_GB"
PKGDIR="/usr/my-packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/zzam /usr/local/overlays/vdr/experimental /usr/local/overlays/vdr/vdr-devel /usr/local/overlays/vdr/testing /usr/local/overlays/layman/sunrise /usr/local/overlays/gentoo.de /usr/local/overlays/dev-overlay"
SYNC="cvs://zzam@cvs.gentoo.org:/var/cvsroot"
USE="3dnow 3dnowext X Xaw3d a52 aac acl acpi alsa amr apache2 artswrappersuid audacious berkdb bluetooth bzip2 cairo cap caps cdaudio cddb cdparanoia cdr cli cracklib crypt cups curl dbus doc dri dts dvb dvd dvdr dvdread emboss encode evo exif fam fbcon ffmpeg firefox font-server fortran fuse gcj gdbm gif gimpprint glut gnutls gphoto2 gpm graphviz gstreamer gtk gtk2 hal hbci iconv imap ipv6 isdnlog java jpeg jpeg2k kde kdexdeltas kerberos libdvdread lirc logitech-mouse mad midi mikmod mjpeg mmx mmxext mng mp3 mpeg mplayer mudflap musicbrainz mysql ncurses nls nptl nptlonly nsplugin nvram offensive ogg opengl openmp oss pam pcre pdf perl php png ppds pppd projectx python qt3 qt3support qt4 quotes readline reflection regex samba session sms sndfile spell spl sql sqlite sse ssl svg taglib tcltk tcpd theora threads tiff truetype unicode usb userlocales v4l v4l2 vcd vdr visualization vorbis webdav win32codecs wma wmf x264 x86 xcomposite xext xinerama xml xorg xrandr xslt xulrunner xv xvid zlib zvbi" ALSA_CARDS="emu10k1 intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" DVB_CARDS="ttpci usb-wt220u dibusb-usb2 usb-dib0700" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text xosd" LINGUAS="de en en_GB" LIRC_DEVICES="all" USERLAND="GNU" VIDEO_CARDS="nvidia v4l vesa vbdev nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Rafał Mużyło 2008-07-04 19:28:09 UTC
Could you please add from build log the whole src_unpack phase ?
But I think this is another case of the 'brilliant' way some KDE descendants
used autotools - namely this automake rule:
$(top_srcdir)/acinclude.m4: $(top_srcdir)/acinclude.m4.in $(top_srcdir)/admin/acinclude.m4.in $(top_srcdir)/admin/libtool.m4.in
 	    @cd $(top_srcdir) && cat acinclude.m4.in admin/acinclude.m4.in admin/libtool.m4.in > acinclude.m4

It's effect is that libtool.m4 landed in acinclude.m4 and
when eautoreconf updates ltmain.sh, it can't update libtool macro,
as the old version in acinclude.m4 can't be overridden.
Comment 2 Matthias Schwarzott gentoo-dev 2008-07-04 19:39:22 UTC
(In reply to comment #1)
> Could you please add from build log the whole src_unpack phase ?
Here is it:
>>> Unpacking source...
>>> Unpacking licq-1.3.5.tar.bz2 to /var/tmp/portage/net-im/licq-1.3.5-r1/work
 * Applying licq-1.3.5-logonfix.patch ...                                  [ ok ]
 * Applying licq-1.3.5-prevent-dos.patch ...                               [ ok ]
 * Applying licq-1.3.5-gcc43.patch ...                                     [ ok ]
 * Applying 1.3.0-suse_bool.patch ...                                      [ ok ]
 * Setting kde plugin as default ...                                       [ ok ]
 * Running eautoreconf in '/var/tmp/portage/net-im/licq-1.3.5-r1/work/licq-1.3.5/plugins/msn' ...
 * Running aclocal ...                                                     [ ok ]
 * Running libtoolize --copy --force --install --automake ...              [ ok ]
 * Running aclocal ...                                                     [ ok ]
 * Running autoconf ...                                                    [ ok ]
 * Running autoheader ...                                                  [ ok ]
 * Running automake --add-missing --copy --foreign ...                     [ ok ]
 * Running elibtoolize in: licq-1.3.5/admin
 *   Applying sed-1.5.6.patch ...
 * Running eautoreconf in '/var/tmp/portage/net-im/licq-1.3.5-r1/work/licq-1.3.5/plugins/auto-reply' ...
 * Running aclocal ...                                                     [ ok ]
 * Running libtoolize --copy --force --install --automake ...              [ ok ]
 * Running aclocal ...                                                     [ ok ]
 * Running autoconf ...                                                    [ ok ]
 * Running autoheader ...                                                  [ ok ]
 * Running automake --add-missing --copy --foreign ...                     [ ok ]
 * Running eautoreconf in '/var/tmp/portage/net-im/licq-1.3.5-r1/work/licq-1.3.5/plugins/email' ...
 * Running aclocal ...                                                     [ ok ]
 * Running libtoolize --copy --force --install --automake ...              [ ok ]
 * Running aclocal ...                                                     [ ok ]
 * Running autoconf ...                                                    [ ok ]
 * Running autoheader ...                                                  [ ok ]
 * Running automake --add-missing --copy --foreign ...                     [ ok ]
>>> Source unpacked.
Comment 3 Rafał Mużyło 2008-07-04 21:02:11 UTC
Looks like I'm right.
Just in case, check your build log for “missing --run”,
but if you don't see any, my description of the problem is complete.

the only way to fix that is to recreate every acinclude.m4 in a dir where
eautoreconf was run, using the same procedure it was created in the first place,
just omitting admin/libtool.m4.in.
Comment 4 Rafał Mużyło 2008-07-04 23:39:31 UTC
To make it clear, it has to be recreated BEFORE eautoreconf is run.
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-05 14:35:49 UTC
+  05 Jul 2008; Peter Alfredsen <loki_val@gentoo.org> licq-1.3.5-r1.ebuild:
+  Fix for libtool-2.2 wrt bug #230780. Thanks to Rafał Mużyło
+  <galtgendo@o2.pl>.
+