Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 230693

Summary: sci-chemistry/reduce-3.13.080428 (Update)
Product: Gentoo Linux Reporter: Philipp Psurek <philipp.psurek+gentoo>
Component: New packagesAssignee: Gentoo Chemistry-Related Packages <sci-chemistry>
Severity: enhancement    
Priority: Lowest    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: ebuild

Description Philipp Psurek 2008-07-04 00:53:21 UTC
Hi all!

This is my first ebuild ;-D I'm a Gentoo noob, but i try...

I'm trying to emerge sci-chemistry/coot on my phenom cpu, but some sources won't compile. Here is the first one I tried to improve: sci-chemistry/reduce.

The developers homepage contains a new version, so I took the new source and wrote the new ebuild based on the old one and hope it's O.K.

The compiled program works on amd64, i tell you soon if it works on x86.

Thanx 4 Gentoo

Portage 2.2_rc1 (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r6 x86_64)
System uname: Linux-2.6.25-gentoo-r6-x86_64-AMD_Phenom-tm-_9750_Quad-Core_Processor-with-glibc2.2.5
Timestamp of tree: Thu, 03 Jul 2008 12:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r5
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=amdfam10 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/zen-overlay /usr/local/portage/local-overlay"
USE="# #prozzi 3dnow 3dnowext X Xaw3d a52 aac acl acpi alsa amd64 apache2 avahi avc bash-completion berkdb bluetooth branding bzip2 cairo cdda cddb cdio cdr cli compiz cracklib crypt css cups dbus dc1394 divx dlloader dri dts dv dvb dvd dvdr dvdread eds emboss encode esd evo exif fam ffmpeg fftw fglrx firefox flac font-server fontconfig fortran framebuffer gd gdbm gif gimp gnome gpm gstreamer gtk hal httpd iconv id3tag ieee1394 imagemagic imap ipv6 isdnlog java joystick jpeg kde kerberos latex ldap libgcrypt libnotify mad matroska md5sum mdnsresponder-compat mesa midi mikmod mmx mmx2 mmxext mono mp2 mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz mysql ncurses netpbm new-interface nls nptl nptlonly odbc ogg opengl openmp pam pcre pda pdf perl php pic png ppds pppd pvr python qt3 qt3support qt4 quicktime rar raw readline reflection samba sdl sdl-image session slang spell spl sse sse2 sse3 sse4a ssl startup-notification svg swat symlink tcpd tiff tk truetype unicode unzip v4l v4l2 vcd vcdx vorbis wifi wmf wxwindows x11 x264 xinerama xlib xml xorg xulrunner xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="fglrx"
Comment 1 Philipp Psurek 2008-07-04 00:59:21 UTC
Created attachment 159475 [details]

I set the environment variable REDUCE_HET_DICT to the old HET directory 'cause the manual don't tell anything about the new.
Comment 2 Donnie Berkholz (RETIRED) gentoo-dev 2008-07-04 04:21:36 UTC
The important part here is to keep coot working. Does coot actually work with version 3 pdb's, with the reduce/probe integration?
Comment 3 Philipp Psurek 2008-07-04 10:22:05 UTC
Coot should work with the old version which is the default in this ebuild. If anybody wants to test the new HET directory then the /etc/env.d/20reduce should be changed:



I can't test it because my coot installation stops at sci-libs/cifparse-obj compilation. I can't compile this library even from scratch. More in another bug...
Comment 4 Donnie Berkholz (RETIRED) gentoo-dev 2008-07-07 06:06:21 UTC
I just bumped this. Thanks for looking into exactly what needed to change! I didn't base the bump off your ebuild, though -- I tried to minimize changes from the existing one instead.