Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 229959

Summary: iwl3945: crash/freeze, unpredictable behavior, when running /sbin/iwconfig wlan0 txpower on
Product: Gentoo Linux Reporter: Alex Zorach <cazort>
Component: [OLD] Core systemAssignee: Mobile Herd (OBSOLETE) <mobile+disabled>
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: Output from emerge --info
Kernel Configuration

Description Alex Zorach 2008-06-28 23:09:24 UTC
I am experiencing this bug:

And a workaround is given to run:

/sbin/iwconfig wlan0 txpower on

But when I run this command, my system exhibits unpredictable behavior.  One time, the screen faded to white and became unusable, but I was able to log on in a terminal and halt the system.  Other times I have tried to reproduce it, the system has either crashed/locked up outright, or has become unstable and crashed shortly thereafter.  I suspect this may be a kernel bug because of the crashing, but I really have no clue.

Reproducible: Always

Steps to Reproduce:
1. Stop wireless: /etc/init.d/net.wlan0 stop
2. Try to restart wireless: /etc/init.d/net.wlan0 start, this generates an error message.
3. Run /sbin/iwconfig wlan0 txpower on

Actual Results:  
Different things happen each time.  Most common experience is a crash.

Expected Results:  
It should have turned on the power for the wireless card, without any weird and unpredictable system behavior or crashes, and then allowed me to start the wireless service again.

2.6.24-gentoo-r8 #5 SMP Thu May 29 08:53:16 PDT 2008 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux


I'm a bit scared to try to keep replicating this bug because I'm worried something might happen to b0rk my system.
Comment 1 Alex Zorach 2008-06-28 23:10:20 UTC
Created attachment 158823 [details]
Output from emerge --info
Comment 2 Alex Zorach 2008-06-28 23:11:07 UTC
Created attachment 158825 [details]
Kernel Configuration
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-29 16:48:43 UTC
More or less a dupe, but since bug 217992 is spammed by comments already...
Comment 4 Alex Zorach 2008-06-30 00:03:36 UTC
(In reply to comment #3)
> More or less a dupe, but since bug 217992 is spammed by comments already...

Is this a dupe?  I mentioned this in the comments but it seems that bug is talking about a separate problem, and most of the people experiencing that bug aren't experiencing the one I've encountered.  I'm currently trying to figure out if this is a "real" bug or if I've done something un-kosher in my configuration of things.
Comment 5 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2010-05-26 18:29:56 UTC
most likely this is not an issue anymore as recent kernels have much improved iwl3945 support.

please reopen if problem persists