Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 229465

Summary: mail-mta/courier-0.59.0 does not install esmtp, webmail to /etc/pam.d, not provided by net-mail/mailbase
Product: Gentoo Linux Reporter: Ed Catmur <ed>
Component: Current packagesAssignee: Hanno Böck <hanno>
Status: CONFIRMED ---    
Severity: normal CC: mmokrejs, net-mail
Priority: High    
Version: 2007.0   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Ed Catmur 2008-06-25 23:11:33 UTC
As above, mail-mta/courier installs example pam files to:
/etc/courier/imapd.authpam
/etc/courier/esmtp.authpam
/etc/courier/pop3d.authpam
/etc/courier/webmail.authpam
However it does not install them to /etc/pam.d, and only pop3 and imap are installed by net-mail/mailbase.

This means that esmtp and webmail facilities of courier do not work in default setup, and fail authentication with a fairly unhelpful error message.  This is particularly confusing because imap auth works fine.

Could /etc/pam.d/esmtp and /etc/pam.d/webmail be provided by mailbase?
Comment 1 Hanno Böck gentoo-dev 2008-09-16 22:12:54 UTC
net-mail, thoughts?
Comment 2 Eray Aslan gentoo-dev 2011-05-12 10:15:50 UTC
Have courier install them or ewarn the user.  No need to install esmtp and webmail for all users of mailbase.
Comment 3 Eray Aslan gentoo-dev 2011-06-07 07:18:29 UTC
Closing as wontfix.
Comment 4 Eray Aslan gentoo-dev 2011-06-07 07:21:14 UTC
Bleh, wrong bug.  Sorry for the bug spam.