Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 229443

Summary: sys-power/nut-2.2.2 does not compile (mv: cannot stat `.deps/parseconf.Tpo': No such file or directory )
Product: Gentoo Linux Reporter: Karel De Vriendt <Karel.De-Vriendt>
Component: Current packagesAssignee: Robin Johnson <robbat2>
Status: RESOLVED FIXED    
Severity: normal CC: base-system
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 212763    
Attachments: Complete build log
Environment file

Description Karel De Vriendt 2008-06-25 19:47:39 UTC
Compile dies:

libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include -I../include -mtune=amdfam10 -O2 -pipe -Wall -Wsign-compare -MT parseconf.lo -MD -MP -MF .deps/parseconf.Tpo -c parseconf.c  -fPIC -DPIC -o .libs/parseconf.o
mv -f .deps/parseconf.Tpo .deps/parseconf.Po
mv -f .deps/parseconf.Tpo .deps/parseconf.Plo
mv: cannot stat `.deps/parseconf.Tpo': No such file or directory
make[1]: *** [parseconf.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
mv -f .deps/upsconf.Tpo .deps/upsconf.Po
mv -f .deps/common.Tpo .deps/common.Po
mv -f .deps/state.Tpo .deps/state.Po
make[1]: Leaving directory `/var/tmp/portage/sys-power/nut-2.2.2/work/nut-2.2.2/common'
make: *** [all-recursive] Error 1
 *
 * ERROR: sys-power/nut-2.2.2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2609:  Called die
 * The specific snippet of code:
 *       emake || die "compile problem"
 *  The die message:
 *   compile problem
 *


Reproducible: Always

Steps to Reproduce:
1. upgrade nut to new version
2. 
3.

Actual Results:  
Compile fails

Expected Results:  
Compile succeeds

~ # emerge --info
Portage 2.2_rc1 (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.25-gentoo-r5-x86_64-AMD_Phenom-tm-_9850_Quad-Core_Processor-with-glibc2.2.5
Timestamp of tree: Wed, 25 Jun 2008 19:30:03 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.62
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-mtune=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-mtune=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/ "
LANG="en_US.utf8"
LDFLAGS=""
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 berkdb branding bzip2 cairo cdparanoia cdr cli cracklib cups dbus dri dts dvd dvdr dvdread encode evo fam ffmpeg flac fontconfig gdbm gif gpm hal iconv imagemagic java jpeg kde lame libnotify lm_sensors mad midi mikmod mime mmx mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 raw readline reflection rss samba scanner sdl session smp spell spl sse sse2 ssl startup-notification svg symlink tcpd tiff truetype unicode usb vorbis xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Karel De Vriendt 2008-06-25 19:48:58 UTC
Created attachment 158437 [details]
Complete build log
Comment 2 Karel De Vriendt 2008-06-25 19:49:33 UTC
Created attachment 158439 [details]
Environment file
Comment 3 Karel De Vriendt 2008-06-25 19:55:18 UTC
Tried a second time and compilation did run fine.

Can this have something to do with parallel tasks on a quadcore cpu?

If so, how to avoid (aside using one core of course - I paid for four)?

Many thanks in advance for helping.
Comment 4 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-06-26 01:27:20 UTC
Something is wrong with the libtool I think, not nut directly, since it contains no direct Makefile rule for moving .Tpo files around:

See ${S}/common/Makefile.am
Comment 5 SpanKY gentoo-dev 2008-06-28 19:01:05 UTC
problem is that apparently the same file name is being used for two different files ...

first there is the straight build:
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include    -I../include -O -Wall -Wsign-compare -MT parseconf.o -MD -MP -MF .deps/parseconf.Tpo -c -o parseconf.o parseconf.c
mv -f .deps/parseconf.Tpo .deps/parseconf.Po

and then there is the libtool build:
/bin/sh ../libtool --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include    -I../include -O -Wall -Wsign-compare -MT parseconf.lo -MD -MP -MF .deps/parseconf.Tpo -c -o parseconf.lo parseconf.c
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include -I../include -O -Wall -Wsign-compare -MT parseconf.lo -MD -MP -MF .deps/parseconf.Tpo -c parseconf.c  -fPIC -DPIC -o .libs/parseconf.o
mv -f .deps/parseconf.Tpo .deps/parseconf.Plo
Comment 6 SpanKY gentoo-dev 2008-06-28 19:35:46 UTC
and this is because nut is doing some weird stuff in common/Makefile.am:

all: libcommon.a upsconf.o parseconf.o state.o parseconf.lo
# Define a dummy library so that Automake builds rules for the
# corresponding object files.  This library is not actually built,
EXTRA_LIBRARIES = libdummy.a
libdummy_a_SOURCES = parseconf.c state.c upsconf.c

this bypasses some libtool checks and violates libtool's handling of things.  if declared things differently, we see that this is indeed the case:
common/Makefile.am: object `parseconf.$(OBJEXT)' created both with libtool and without
Comment 7 Robert Holzknecht 2008-06-30 08:41:29 UTC
Hi everybody! Got the same problem - here are my information about this error:
------------------------------
shadowghost ~ # emerge --info
Portage 2.1.4.4 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r8 i686)
=================================================================
System uname: 2.6.24-gentoo-r8 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Timestamp of tree: Sun, 29 Jun 2008 17:31:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.3.5-r3, 2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/confcache:  0.4.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.qubenet.net/mirror/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gentoo.ynet.sk/pub http://gd.tuwien.ac.at/opsys/linux/gentoo/ http://mirrors.evolva.ro/gentoo/"
LANG="de"
LC_ALL="de_DE.UTF-8"
LINGUAS="de"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="16bit 3dnow 3dnowext X X509 a52 aac aalib acl acpi ada adns aio alsa amr ao aotuv apache2 ares arts aspnet2 async atm audiofile authdaemond authfile automount bash-completion bcmath berkdb bidi big-tables bigpatch branding bzip2 cairo calendar capi caps ccache cdb cdda cddb cdf cdio cdparanoia cdr cdrom cgi cjk clamav cli cman cmdsubmenu corba cpudetection cpufreq cracklib crciprec crypt css ctype cups curl curlwrappers daap dbase dbox2 dbus dedicated dga dhcp discard-path diskio dri dts dv dvb dvbplayer dvd dvdr dvdread dvi dxr3 eds elf emboss encode enscript esd etwin evo exif fam fasttrack ffmpeg fftw fidonet file-icons filepro firefox flac flash flatfile fontconfig foomaticdb fortran fpx freebox ftp gd gdbm geoip gif glade glep glitz glut gmp gnome gnustep gnutella gnutls gpm grace graphviz gstreamer gtk guile gulm hal hash haskell hddtemp hdf hdf5 hdhomerun hfs hpn httpd icecast iconv icq idn ifsession imagemagick imap imlib inifile iodbc ipf-transparent ipv6 irda isdnlog java javacomm javamail javascript jbig jikes joystick jpeg jpeg2k jumpplay kde kerberos krb4 latex lcd lcms ldap libcaca libnotify lirc live lm_sensors lnbsharing logrotate lua mad madwifi magic maildir mailwrapper math matroska max-idx-128 mbox mcve md5sum memlimit menu-plugin messages mfd-rewrites mhash midi mikmod milter ming mjpeg mmap mmx mmxext mng modelock motif mp2 mp3 mpeg mpeg2 mplayer msn mssql mudflap musepack musicbrainz mysql mysqli ncurses net netboot network networking nis nls nptl nptlonly nsplugin ntlm nvidia ocaml odbc ogg opengl openmp openssl opensslcrypt optimisememory oss pam parse-clocks pcntl pcre pdf perl php pic png posix postgres ppds pppd pulseaudio python qos qt3 qt3support qt4 quicktime quotas radius readline reflection reiserfs remote rewrite rle rotor rrdcgi rrdtool rtc rtsp ruby samba sasl sdk sdl sdl-image search sendmail sensord server session setup-plugin shaper sharedext shorten shout simplexml skins slang slp smartcard smp sms smtp smux sndfile snmp soap sockets socks5 softquota speex spell spl sql sse sse2 ssl startup-notification stats stream submenu subtitles suexec svg svga svgz svnserve sysvipc tcl tcpd tga theora threads tidy tiff tk tokenizer trace trash-plugin truetype underscores unicode upnp ups urandom usb utempter v4l v4l2 vcd vda vhosts vidix vlm vnc vorbis vroot wav wavpack wddx wifi win32codecs winbind wma wmf wmp x264 x86 xanim xchatdccserver xcomposite xfce xfs xine xinerama xinetd xml xmlreader xmlrpc xmlwriter xorg xosd xpm xprint xrandr xscreensaver xsl xtended xv xvid xvmc yaepg yaz zip zlib" ALSA_CARDS="ca0106 intel8x0 intel8x0m hdaintel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
-----------------------------------------
Comment 8 Robert Holzknecht 2008-06-30 08:42:55 UTC
config.status: creating Makefile
config.status: creating include/config.h
config.status: executing depfiles commands
config.status: executing include/nut_stdint.h commands
config.status: creating include/nut_stdint.h : _NUT_INCLUDE_NUT_STDINT_H

Configuration summary:
enable SSL development code: yes
enable IPv6 support: yes
build CGI programs: yes
build and install the development files: yes
build serial drivers: yes
build SNMP drivers: yes
build USB drivers: yes
enable HAL support: yes
build neon based XML driver: yes
Making all in include
make[1]: Entering directory `/var/tmp/portage/sys-power/nut-2.2.2/work/nut-2.2.2/include'
NUT_VERSION: "2.2.2-exportiert "
test -f nut_version.h || cp _nut_version.h nut_version.h
cmp -s _nut_version.h nut_version.h || cp _nut_version.h nut_version.h
rm -f _nut_version.h
make  all-am
make[2]: Entering directory `/var/tmp/portage/sys-power/nut-2.2.2/work/nut-2.2.2/include'
make[2]: Für das Ziel »all-am« ist nichts zu tun.
make[2]: Leaving directory `/var/tmp/portage/sys-power/nut-2.2.2/work/nut-2.2.2/include'
make[1]: Leaving directory `/var/tmp/portage/sys-power/nut-2.2.2/work/nut-2.2.2/include'
Making all in common
make[1]: Entering directory `/var/tmp/portage/sys-power/nut-2.2.2/work/nut-2.2.2/common'
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include    -I../include -march=athlon64 -O2 -pipe -fomit-frame-pointer -Wall -Wsign-compare -MT common.o -MD -MP -MF .deps/common.Tpo -c -o common.o common.c
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include    -I../include -march=athlon64 -O2 -pipe -fomit-frame-pointer -Wall -Wsign-compare -MT upsconf.o -MD -MP -MF .deps/upsconf.Tpo -c -o upsconf.o upsconf.c
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include    -I../include -march=athlon64 -O2 -pipe -fomit-frame-pointer -Wall -Wsign-compare -MT parseconf.o -MD -MP -MF .deps/parseconf.Tpo -c -o parseconf.o parseconf.c
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include    -I../include -march=athlon64 -O2 -pipe -fomit-frame-pointer -Wall -Wsign-compare -MT state.o -MD -MP -MF .deps/state.Tpo -c -o state.o state.c
/bin/sh ../libtool --tag=CC   --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include    -I../include -march=athlon64 -O2 -pipe -fomit-frame-pointer -Wall -Wsign-compare -MT parseconf.lo -MD -MP -MF .deps/parseconf.Tpo -c -o parseconf.lo parseconf.c
mkdir .libs
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include -I../include -march=athlon64 -O2 -pipe -fomit-frame-pointer -Wall -Wsign-compare -MT parseconf.lo -MD -MP -MF .deps/parseconf.Tpo -c parseconf.c  -fPIC -DPIC -o .libs/parseconf.o
mv -f .deps/parseconf.Tpo .deps/parseconf.Po
mv -f .deps/upsconf.Tpo .deps/upsconf.Po
mv -f .deps/common.Tpo .deps/common.Po
mv -f .deps/parseconf.Tpo .deps/parseconf.Plo
rm -f libcommon.a
mv: Aufruf von stat für „.deps/parseconf.Tpo“ nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/ar cru libcommon.a common.o
make[1]: *** [parseconf.lo] Fehler 1
make[1]: *** Warte auf noch nicht beendete Prozesse...
i686-pc-linux-gnu-ranlib libcommon.a
mv -f .deps/state.Tpo .deps/state.Po
make[1]: Leaving directory `/var/tmp/portage/sys-power/nut-2.2.2/work/nut-2.2.2/common'
make: *** [all-recursive] Fehler 1
 *
 * ERROR: sys-power/nut-2.2.2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2569:  Called die
 * The specific snippet of code:
 *       emake || die "compile problem"
 *  The die message:
 *   compile problem
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-power/nut-2.2.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-power/nut-2.2.2/temp/environment'.
 *
Comment 9 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-07-05 03:15:35 UTC
fixed in cvs, rev 1.3 with files/nut-2.2.2-no-libdummy.patch