Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 228621

Summary: net-firewall/fwbuilder-3.0.4 ~sparc keyword request
Product: Gentoo Linux Reporter: Frederico Freire Boaventura <frederico>
Component: New packagesAssignee: Andreas K. Hüttel <dilfridge>
Status: RESOLVED CANTFIX    
Severity: enhancement CC: bberberov+gentoo, bekkra, cesarg9, dev-zero, glua, herber, m.debruijne, qt, sparc, tschenturs, vanquirius
Priority: High Keywords: KEYWORDREQ
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://www.fwbuilder.org/
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 159780    
Bug Blocks: 235809    
Attachments: proposed ebuild for net-libs/libfwbuilder-2.1.19
proposed ebuild for net-firewall/fwbuilder-1.2.19
fwbuilder-3.0.3.ebuild diff to current fwbuilder-2.1.18.ebuild
libfwbuilder-3.0.3.ebuild diff to current libfwbuilder-2.1.18.ebuild

Description Frederico Freire Boaventura 2008-06-20 20:39:32 UTC
There is a new stable version of fwbuilder.

From the site: Major update: Policy compilers for Cisco PIX (supports FWSM and ASA appliances) and IOS extended access lists have been released under GPL and included in the main package.

Reproducible: Always
Comment 1 Frederico Freire Boaventura 2008-06-20 20:41:03 UTC
Created attachment 157827 [details]
proposed ebuild for net-libs/libfwbuilder-2.1.19
Comment 2 Frederico Freire Boaventura 2008-06-20 20:49:54 UTC
Created attachment 157829 [details]
proposed ebuild for net-firewall/fwbuilder-1.2.19
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-20 22:38:55 UTC
Don't attach anything without a comment. If the ebuild doesn't need to be changed - just say it. If you attach something, a unified diff is preferred.
Comment 4 Marcelo Goes (RETIRED) gentoo-dev 2008-06-22 01:17:21 UTC
For libfwbuilder: only modification is removing the 4.3 patch.
For fwbuilder: ebuild renamed.

libfwbuilder is not compiling for me with gcc-4.3 (new error):
dns.cpp:784: error: 'void* libfwbuilder::DNS_bulkBackResolve_Thread(void*)' should have been declared inside 'libfwbuilder'
Comment 5 Frederico Freire Boaventura 2008-06-23 19:25:09 UTC
Sorry about the attachments, won't happen again.

And about the compilation, I got no error with GCC 4.3.1.

here is my emerge --info

Portage 2.1.5.5 (default-linux/x86/2007.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 i686)
=================================================================
System uname: 2.6.25-gentoo-r4 i686 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz
Timestamp of tree: Mon, 23 Jun 2008 11:13:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r6, 2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-mtune=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-mtune=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US"
LDFLAGS=""
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/fred"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib accessibility acct acl acpi addbookmarks administrator ads aim alias alsa amazon amrnb amrwb ao apache2 apm archive arts artswrappersuid async audiofile automount bash-completion bcmath berkdb bidi binary-drivers bind-mysql bluetooth bzip2 calendar caps captury ccache cdda cddb cdio cdparanoia cdr cgi chm cisco clamav cli connectionstatus contentcache cpudetection cracklib crypt css ctype cups curl curlwrappers daap dbase dbm dbmaker dbtool dbus dbx dga dialup directfb diskio divx djvu dlz dmx dri dts dv dvb dvd dvdr dvdread dxr3 dynamic dynamicplugin eap-tls elf enca encode enscript epson exif expat extensions extrafilters fam fame fastbuild fastcgi fax fbcon fbcondecor fbsplash ffmpeg firefox flac flash font-server fontconfig foomaticdb fortran fpx ftp fuse gadu gd gdbm ggi gif glib gnokii gnutls gphoto2 gpm graphviz gsm gtk hal hardware-carrier hddtemp htmlhandbook ical iconv ieee1394 imagemagick imlib ipv6 irda isdnlog jack java jbig john joystick jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kerberos ladspa lame laptop latex lcms ldap libcaca lirc live lm_sensors logrotate lzo mad md5sum midi mjpeg mmap mmx mmxext mng mp2 mp3 mpeg mplayer mudflap musepack musicbrainz mysql nas ncurses nemesi network networkmanager nforce2 nls nptl nptlonly nsplugin nss nvidia odbc ogg openal openct openexr opengl openmp oscar oss pae pam pch pcmcia pcre pda pdf perl php pmu png pnm povray pppd pulseaudio python qt3 qt3support qt4 quicktime quotas radio rar readline real reflection rrdcgi rrdtool rtc ruby samba scanner sdl session slang smp sms sndfile speex spell spl sqlite sqlite3 srt sse sse2 ssl ssse3 subversion svg svga syslog tcl tcpd teletext tga theora threads tidy tiff truetype unicode usb utempter v4l v4l2 vcd video vidix vim-syntax vnc vorbis wavpack wifi win32codecs winbind wmf x264 x86 xanim xcomposite xforms xine xinerama xml xorg xprint xscreensaver xulrunner xv xvid xvmc yahoo zeroconf zip zlib zoran zrtp" ALSA_CARDS="hda-intel bt87x mpu401" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias imagemap proxy proxy_ftp proxy_http version" APACHE2_MPMS="worker" CAMERAS="ptp2 sony_dscf1" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia vesa v4l fbdev nv vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

gcc-config -E
export PATH="/usr/i686-pc-linux-gnu/gcc-bin/4.3.1:/lib/rc/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/staff/fred/bin:/usr/games/bin:/usr/kde/3.5/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.3.1:/opt/sun-jdk-1.4.2.17/bin:/opt/sun-jdk-1.4.2.17/jre/bin:/opt/sun-jdk-1.4.2.17/jre/javaws:/usr/kde/4.0/bin:/usr/qt/3/bin:/usr/lib/subversion/bin"

Comment 6 Carsten Lohrke (RETIRED) gentoo-dev 2008-09-07 13:08:04 UTC
*** Bug 236827 has been marked as a duplicate of this bug. ***
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2008-10-29 03:39:47 UTC
*** Bug 244844 has been marked as a duplicate of this bug. ***
Comment 8 Julian Golderer 2008-11-06 00:27:35 UTC
is there any help needed to get the ebuild ready?
Comment 9 stupendoussteve 2008-11-10 23:01:45 UTC
There is an ebuild for the most recent version in "duplicate" bug 244844
Comment 10 Francesco Riosa 2008-11-26 08:04:41 UTC
patch from bug#244844 apply for 3.0.2 too

emerge --info
 * Overlay eclasses override eclasses from PORTDIR:
 *
 *   '/g/ovl/kde-crazy/eclass/kde4-base.eclass'
 *   '/g/ovl/kde-crazy/eclass/kde4-functions.eclass'
 *   '/g/ovl/kde-crazy/eclass/kde4-meta.eclass'
 *
 * It is best to avoid overriding eclasses from PORTDIR because it will
 * trigger invalidation of cached ebuild metadata that is distributed with
 * the portage tree. If you must override eclasses from PORTDIR then you
 * are advised to add FEATURES="metadata-transfer" to /etc/make.conf and to
 * run `emerge --regen` after each time that you run `emerge --sync`. Set
 * PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if you would like to
 * disable this warning.
Portage 2.2_rc16 (selinux/2007.0/amd64, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27 x86_64)
=================================================================
System uname: Linux-2.6.27-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9300_@_2.50GHz-with-glibc2.2.5
Timestamp of tree: Wed, 26 Nov 2008 02:15:01 +0000
distcc 3.0 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=nocona -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=nocona -pipe"
DISTDIR="/g/distfiles"
FEATURES="distlocks loadpolicy metadata-transfer parallel-fetch protect-owned sandbox selinux sesandbox sfperms sign strict unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://mirror.datapipe.net/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://ftp.linux.ee/pub/gentoo/distfiles/ http://128.213.5.34/gentoo/ http://ftp.gentoo.skynet.be/pub/gentoo/ http://gentoo.tiscali.nl/gentoo/ http://gentoo.inode.at/"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LDFLAGS="-Wl,--hash-style=both"
LINGUAS="it"
MAKEOPTS="-j1"
PKGDIR="/g/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/g/tmp"
PORTDIR="/home/portage/portage"
PORTDIR_OVERLAY="/g/ovl/mysql /g/ovl/tmp /g/ovl/kde-crazy"
SYNC="rsync://sources.pnpitalia.it/gentoo-portage"
USE="3dnow X a52 aac alsa amd64 amr apache2 apm asf automount avahi avi bash-completion berkdb bitmap-fonts bluetooth browserplugin bzip2 cairo caps captury cdda cddb chm cjk cli compositor cracklib crypt cups curl dbus decibel dedicated device-mapper djvu dri dvdread emboss encode engines erandom exif exiv2 extrafilters fam fame ffmpeg firefox flac foomaticdb fortran gdbm geos gif glitz gpm gstreamer gtk2 hal hdf hdf5 hpn htmlhandbook iconv idn imagemagick imlib iproute2 ipv6 isdnlog ithreads jack java jingle jpeg jpeg2k justify kde kdeenablefinal kdehiddenvisibility kdepim kdeprefix kontact latex libg++ libwww lua lzo mad messenger midi mikmod mjpeg mmx mng motif mp3 mpeg mplayer mudflap mysql ncurses nepomuk newxkb nls nptl nptlonly odbc ogdi ogg openexr opengl openmp pam pam_chroot pcre perl plasma plugins png pppd pulseaudio python qt qt3 qt3support qt4 quicktime rdesktop readline reflection reiserfs samba sasl schroedinger screen sdl selinux server session skey slang spell spl sqlite3 sse sse2 ssl svg taglib tcltk tcpd telepathy theora threads tiff tls truetype truetype-fonts ucs2 udev unicode urandom usb userlocales utempter utils vnc vorbis xcb xcomposite xine xinerama xml xorg xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x     ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3         trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CAMERAS="directory" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 11 Przemyslaw Hoppe 2008-12-09 15:28:28 UTC
patch from bug#244844 applies for 3.0.3 too
Comment 12 Mick Reed 2009-01-08 18:18:38 UTC
(In reply to comment #11)
> patch from bug#244844 applies for 3.0.3 too
> 
Works for me too 3.0.3
# portage --version
Portage 2.2_rc20 (hardened/linux/x86, gcc-4.3.1, glibc-2.9_p20081201-r1, 2.6.27-hardened-r3 i686) ++riced++
Comment 13 Nico Schlömer 2009-01-11 22:20:24 UTC
hi!
the 3.0.3 works for me too (tm) on amd64.
cheers,
nico
Comment 14 Ben de Groot (RETIRED) gentoo-dev 2009-02-02 18:55:19 UTC
Latest version is 3.0.3, so I updated the summary. As this app uses Qt4 now, we (the Qt team) may take this one up.
Comment 15 Markos Chandras (RETIRED) gentoo-dev 2009-02-02 20:06:40 UTC
Created attachment 180731 [details]
fwbuilder-3.0.3.ebuild diff to current fwbuilder-2.1.18.ebuild
Comment 16 Markos Chandras (RETIRED) gentoo-dev 2009-02-02 20:20:17 UTC
Created attachment 180734 [details]
libfwbuilder-3.0.3.ebuild diff to current libfwbuilder-2.1.18.ebuild
Comment 17 Markos Chandras (RETIRED) gentoo-dev 2009-02-02 20:21:39 UTC
I forgot to mention that libfwbuilder-3.0.3 can work with bind dns server. Hence, it's good imho to introduce a new local use flag "bind" to use it with this package :)
Comment 18 Boian Berberov 2009-03-02 22:28:54 UTC
Alternative libfwbuilder-3.0.3.ebuild and fwbuilder-3.0.3.ebuild:

http://bazaar.launchpad.net/~bberberov/%2Bjunk/dev-overlay/files/head%3A/net-libs/libfwbuilder/
http://bazaar.launchpad.net/~bberberov/%2Bjunk/dev-overlay/files/head%3A/net-firewall/fwbuilder/

QMAKE_STRIP is now handled in the qt4.eclass
Added pch use flag in fwbuilder-3.0.3.ebuild

Only tested on amd64, but I preserved all the remaining KEYWORDS.
Comment 19 Tiziano Müller (RETIRED) gentoo-dev 2009-03-17 16:00:39 UTC
Version bump done. Dropped keywords since it's a large change compared to previous versions.

CC'ing arches for rekeywording.
Comment 20 Tobias Klausmann gentoo-dev 2009-03-18 19:13:24 UTC
[lib]fwbuilder-3.0.3 needs java (via antlr), which is nonexistant for Alpha, so we pass on this one.
Comment 21 Markus Meier gentoo-dev 2009-03-19 21:37:35 UTC
~x86 added
Comment 22 Brent Baude (RETIRED) gentoo-dev 2009-03-20 13:09:30 UTC
did as part of bug 235809
Comment 23 Tiziano Müller (RETIRED) gentoo-dev 2009-03-20 14:03:09 UTC
removing ppc/ppc64 then :)
Comment 24 Laszlo Radanyi 2009-04-03 20:58:51 UTC
Version 3.0.4 is out and compiles and runs with unmodified 3.0.3 ebuild on amd64

//
Comment 25 Tiziano Müller (RETIRED) gentoo-dev 2009-04-05 09:54:30 UTC
Version bump done, thanks Laszlo.
Sparc?
Comment 26 Friedrich Oslage (RETIRED) gentoo-dev 2009-04-05 11:01:44 UTC
> Sparc?

fwbuilder-3.* depends on dev-java/antlr, but we don't have a working jdk (except the gcj stuff from gcc). However since Betelgeuse is in the process of moving icedtea to the tree, which works for sparc but still needs more work, we should soon be able to do this.
Comment 27 Andreas K. Hüttel archtester gentoo-dev 2011-03-30 20:53:52 UTC
Not in tree anymore, please consider keywording a newer version instead.