Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 227299

Summary: cinelerra-cvs-20080602 Make problems (libtool 2.2 issue)
Product: Gentoo Linux Reporter: Chuck Wegrzyn <chuck.wegrzyn>
Component: Current packagesAssignee: media-video herd <media-video>
Status: RESOLVED FIXED    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 212763    

Description Chuck Wegrzyn 2008-06-15 19:25:03 UTC
I ran: emerge =media-video/cinelerra-cvs-20080602 and it failed in the make. The error returned was 

/bin/sh ../../libtool  --mode=compile ../../admin/nasm  -O2 -march=i686 -pipe -c -o mmxidct.lo mmxidct.S
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[3]: *** [mmxidct.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-video/cinelerra-cvs-20080602/work/hvirtual/libmpeg3/video'


Reproducible: Always

Steps to Reproduce:
1.emerge =media-video/cinelerra-cvs-20080602 
2.
3.

Actual Results:  
libtool: compile:  i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I./.. -DHAVE_MMX -DUSE_MMX -DX86_CPU -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -march=i686 -pipe -MT vlc.lo -MD -MP -MF .deps/vlc.Tpo -c vlc.c  -fPIC -DPIC -o .libs/vlc.o
/bin/sh ../../libtool  --mode=compile ../../admin/nasm  -O2 -march=i686 -pipe -c -o mmxidct.lo mmxidct.S
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[3]: *** [mmxidct.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-video/cinelerra-cvs-20080602/work/hvirtual/libmpeg3/video'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-video/cinelerra-cvs-20080602/work/hvirtual/libmpeg3'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-video/cinelerra-cvs-20080602/work/hvirtual'
make: *** [all] Error 2
 *
 * ERROR: media-video/cinelerra-cvs-20080602 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2820:  Called die
 * The specific snippet of code:
 *       emake || die "make failed"
 *  The die message:
 *   make failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-video/cinelerra-cvs-20080602/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/cinelerra-cvs-20080602/temp/environment'.
 *

 * Messages for package media-video/cinelerra-cvs-20080602:

 *
 * ERROR: media-video/cinelerra-cvs-20080602 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2820:  Called die
 * The specific snippet of code:
 *       emake || die "make failed"
 *  The die message:
 *   make failed


Expected Results:  
For the make to work...

localhost src # emerge --info
Portage 2.1.5.5 (default-linux/x86/2006.1/desktop, gcc-4.1.2, glibc-2.8_p20080602-r0, 2.6.24-gentoo-r2 i686)
=================================================================
System uname: 2.6.24-gentoo-r2 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
Timestamp of tree: Fri, 13 Jun 2008 16:33:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13, 2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS=""
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/opt/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility addbookmarks aim alias alsa arts artswrappersuid asf automount autoreplace avahi bluetooth bonjour bzip2 cdparanoia cdr cli connectionstatus contactnotes cracklib crypt cups curl dbus divx doc dri dvd dvdr dvdread eds emboss encode esd fam firefox foomaticdb gcj gdbm gif gmedia gnutls gphoto2 gpm grub gstreamer gtk gtk2 hal highlight history html iconv ieee1394 ipv6 irc isdnlog java jingle jpeg jpeg2k kde kdepim kdm kexi kipi libnotify libwww mad mdnsresponder-compat midi mikmod mmx mmxext mp3 mpeg mplayer msn mudflap mysql ncurses netmeeting nls nowlistening nptl nptlonly nsplugin ntfs ogg openal opengl openmp oss pam pcre pdf perl png postgres ppds pppd python qt3 qt3support qt4 quicktime rdesktop readline real realmedia reflection reiser4 reiserfs samba sdl session silc slp sms spell spl sql sqlite3 ssl startup-notification statistics subversion svg tcpd tetex texteffect threads threadsafe tiff tordns translator truetype unicode usb v4l2 vorbis webpresence win32codecs winpopup wmp x86 xine xinerama xml xorg xscreensaver xv yahoo zeroconf zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fglrx radeon vesa fbdev vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-15 21:20:44 UTC
Does rebuilding libtool help?
Comment 2 Chuck Wegrzyn 2008-06-16 15:24:29 UTC
I think you jumped the gun in classifying this as "Resolved". I had already tried re-emerging libtools and doing the emerge of cinelerra-cvs again without success.

Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-16 16:22:17 UTC
(In reply to comment #2)
> I think you jumped the gun in classifying this as "Resolved".

I resolved to TEST-REQUEST, asking you test, because these issues turn out to be system local toolchain problems, most often. Nothing like "jumped the gun", normal procedure.
Comment 4 Rafał Mużyło 2008-06-23 13:09:12 UTC
Actually, it pretty simple.
I configure.in, there's following section:
# hack for libtool 1.5 -- this is ugly and probably wrong, but works
if test `libtool --version | grep ltmain.sh | cut -b 25-27` = "1.5"; then
   LTC_FLAGS="--tag=CC"
   LTCXX_FLAGS="--tag=CXX"
fi
AC_SUBST(LTC_FLAGS)
AC_SUBST(LTCXX_FLAGS)

For libtool 2.2, the result is 2.2 of course.

Well, it looks like I have to agree with that comment.
It's caused by the method they use to include nasm files.
Is there any sane way to include those files in a autotools project anyway ?
Comment 5 Hanno Böck gentoo-dev 2008-06-23 23:40:54 UTC
fixed
Comment 6 Chuck Wegrzyn 2008-06-24 11:22:21 UTC
Is this fixed and checked into the repository or what?
Comment 7 Hanno Böck gentoo-dev 2008-06-24 11:54:00 UTC
The gentoo ebuild contains now a patch, which also has been sent to the upstream developers (though they're slow on answering to patches).
Comment 8 Chuck Wegrzyn 2008-06-24 12:06:39 UTC
Thanks for the time and effort to fix this problem!