Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 227239

Summary: x11-misc/electricsheep-2.6.8-r1 libtool 2.2 issue
Product: Gentoo Linux Reporter: Billy DeVincentis <billydv1>
Component: Current packagesAssignee: Daniel Black (RETIRED) <dragonheart>
Severity: normal CC: aronparsons, bugs+gentoo, bugs, flameeyes, greg, jeanfrancis, joakim, kerick, lane, patrick, plaes
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 149804, 212763    

Description Billy DeVincentis 2008-06-15 15:59:30 UTC
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of x86_64-pc-linux-gnu-gcc... none
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking whether x86_64-pc-linux-gnu-gcc needs -traditional... no
./configure: line 4017: syntax error near unexpected token `build_libtool_libs,'
./configure: line 4017: `    _LT_DECL(build_libtool_libs, enable_shared, 0,'
configure: error: ./configure failed for mpeg2dec

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/x11-misc/electricsheep-2.6.8-r1/work/electricsheep-2.6.8/config.log
 * ERROR: x11-misc/electricsheep-2.6.8-r1 failed.
 * Call stack:
 *     , line   49:  Called src_compile
 *             environment, line 3732:  Called econf
 *     , line  526:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-misc/electricsheep-2.6.8-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-misc/electricsheep-2.6.8-r1/temp/environment'.

Reproducible: Always

emerge --info
Portage (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 x86_64)
System uname: 2.6.25-gentoo-r4 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Timestamp of tree: Sun, 15 Jun 2008 05:35:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
FEATURES="buildpkg distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/miscellaneous /usr/portage/local/desktop-effects"
USE="3dnow S3TC X a52 aac aalib accessibility acl acpi alsa amarok amd64 apm arts artworkextra audiofile automount avahi bash-completion berkdb bidi bittorrent bluetooth branding bzip2 cairo calendar cdda cdio cdparanoia cdr clamav cli cpudetection cracklib crypt css cups curl dbus deprecated devil dga directfb discouraged distribution divx doc dri dts dv dvb dvd dvdr dvdread eds elisp emacs emboss emerald encode esd etc-proposals evo examples exif extraicons fam fat fax fbcon fbcondecor fbsplash ffmpeg firefox flac flash foomaticdb fortran fuse gcj gd gdbm gedit gif gimp glitz gmedia gnome gnutls gphoto2 gpm gstreamer gtk gtkhtml hal hddtemp hfs html htmlhandbook httpd iconv idn ieee1394 imagemagick imlib inkjar ipv6 isdnlog jack java jfs joystick jpeg kde kdehiddenvisibility kerberos lcms ldap libcaca libnotify lirc live lm_sensors logrotate mad mail matroska mdnsresponder-compat midi mikmod mime mjpeg mmx mmxext mng mono mozilla mp3 mpeg mplayer mudflap multilib musicbrainz mysql nas nautilus ncurses networking new-login nforce2 nls nptl nptlonly nsplugin ntfs nvidia odbc offensive ogg opengl openmp pam parport pcre pdf perl pmu png postgres ppds pppd pulseaudio python qt3 qt3support qt4 quicktime rar rdesktop readline realmedia reflection regex reiser4 reiserfs samba scanner sdl seamonkey semantic-desktop servletapi session skins slang slp smp sndfile snmp sound sounds speex spell spl sqlite sse sse2 ssl startup-notification stream subversion svg swat symlink sysfs syslog tcpd tetex theora thesaurus threads thunderbird tidy tiff timidity tk truetype type1 unicode usb userlocales utempter utils v4l vcd vdr vlm voice vorbis vram weather wmf wmp wordperfect wxwindows xattr xcb xcomposite xforms xfs xine xml xorg xpm xprint xscreensaver xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Comment 1 Priit Laes (IRC: plaes) 2008-06-17 16:06:39 UTC
This seems to be more like a libtool-2.2 issue.
Comment 2 Billy DeVincentis 2008-06-17 18:19:59 UTC
Looking at the error message, I believe you are right.
Comment 3 Daniel Black (RETIRED) gentoo-dev 2008-06-20 14:33:28 UTC
patches/tips welcome :-)
Comment 4 Rafał Mużyło 2008-06-23 00:06:49 UTC
It's bit hard to tell without downloading source,
as in svn mpeg2dec got removed, but if I dug deep enough,
it seems it's calling AC_DISABLE_SHARED and AC_LIBTOOL_WIN32_DLL
but fails to call AC_PROG_LIBTOOL (later (before they dropped mpeg2dec in favor of ffmpeg) they removed those two and called only AC_PROG_RANLIB).
If that's not the case, see if removing libtool.m4 in mpeg2dec/autotools 
before eautoreconf helps.
Comment 5 Rob Mills 2008-07-11 16:14:24 UTC
I have found that the line that calls eautoreconf is absent in the earlier version (2.6.7). Commenting out that line allows it to compile, just as 2.6.7 did. I hope this helps towards a long-term fix.
Comment 6 Jean-Francis Roy 2008-11-22 03:38:43 UTC
Removing the eautoreconf line worked here.
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-11-24 14:09:59 UTC
*** Bug 248558 has been marked as a duplicate of this bug. ***
Comment 8 Rafał Mużyło 2009-04-18 12:42:45 UTC
*** Bug 266608 has been marked as a duplicate of this bug. ***
Comment 9 Patrick Lauer gentoo-dev 2009-04-18 14:15:25 UTC
(In reply to comment #6)
> Removing the eautoreconf line worked here.

That's not a fix :) 
Also, when I remove it I just hit the next error:

video_out_pgm.c: In function 'md5_draw_frame':
video_out_pgm.c:149: error: ignoring return value of 'system', declared with attribute warn_unused_result
make[3]: *** [video_out_pgm.o] Error 1
make[3]: *** Waiting for unfinished jobs....
cc1: warnings being treated as errors
video_out_x11.c: In function 'overlay_read_ppm':
video_out_x11.c:296: error: ignoring return value of 'fscanf', declared with attribute warn_unused_result
video_out_x11.c:303: error: ignoring return value of 'fscanf', declared with attribute warn_unused_result
video_out_x11.c:304: error: ignoring return value of 'fscanf', declared with attribute warn_unused_result
make[3]: *** [video_out_x11.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-misc/electricsheep-2.6.8-r1/work/electricsheep-2.6.8/mpeg2dec/libvo'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-misc/electricsheep-2.6.8-r1/work/electricsheep-2.6.8/mpeg2dec'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-misc/electricsheep-2.6.8-r1/work/electricsheep-2.6.8'
make: *** [all] Error 2
 * ERROR: x11-misc/electricsheep-2.6.8-r1 failed.
Comment 10 Patrick Lauer gentoo-dev 2009-04-27 11:42:57 UTC
+*electricsheep-2.6.8-r2 (27 Apr 2009)
+  27 Apr 2009; Patrick Lauer <>
+  +electricsheep-2.6.8-r2.ebuild:
+  Horrible compile fix to remove -Werror from CFLAGS (#264081) and avoid the
+  libtool issues (#227239).

Fix mostly avoids the issue instead of really fixing it. If anyone has a cleaner fix please speak up :)