Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 225443

Summary: version bump: sys-power/pm-utils-1.2.3
Product: Gentoo Linux Reporter: Yang Zhao <yang>
Component: New packagesAssignee: Saleem Abdulrasool (RETIRED) <compnerd>
Status: VERIFIED FIXED    
Severity: enhancement CC: abrouwers, darkside, pacho, rb6, strowi, themactep, tomka
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: updated ebuild
updated ebuild for pm-utils-1.2.3

Description Yang Zhao 2008-06-08 20:31:13 UTC
1.1.2.2 was apparently released a day after 1.1.2.1 with more minor fixes.
Comment 1 R Bar-On 2008-09-16 02:17:30 UTC
1.2.0 is out.

http://pm-utils.freedesktop.org/wiki/
Comment 2 Paul Philippov 2008-10-11 12:48:45 UTC
do we still have a maintainer for pm-utils? both 0.99.4 and ~1.1.2.1 are way too old. recent stable release is 1.2.2.1
Comment 3 Pacho Ramos gentoo-dev 2008-10-13 17:25:20 UTC
http://pm-utils.freedesktop.org/releases/pm-utils-1.2.2.1.tar.gz

Also, 1.2* are from stable branch

Thanks for bump
Comment 4 Roman v. Gemmeren 2008-11-08 15:59:11 UTC
Created attachment 171112 [details]
updated ebuild
Comment 5 Roman v. Gemmeren 2008-11-08 16:00:46 UTC
I created an updated ebuild. Though all i changed was the version string It seems to install into correct dirs, and seems to work. Even the radeon-card + lcd not turning off seems to work fine.
Comment 6 Pacho Ramos gentoo-dev 2008-11-17 18:27:56 UTC
Maybe other dev should take care of this, current version in tree is too old and doesn't work on some setups

Thanks
Comment 7 Carlos Cordoba 2008-11-27 09:24:38 UTC
Pacho is right. On my laptop suspend-to-ram was broken for a couple of months (black display after resume) until I noticed this week that the problem was with pm-utils. After the update to 1.2.2.1 everything is working fine again :)
Comment 8 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-12-10 15:18:26 UTC
*** Bug 250392 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-10 16:12:40 UTC
Someone post a 1.2.3 ebuild and I will review and put it in the tree. Thanks.
Comment 10 Roman v. Gemmeren 2008-12-10 17:34:21 UTC
Created attachment 174875 [details]
updated ebuild for pm-utils-1.2.3

as requested an updated ebuild. works here on x86.
Comment 11 Andrew Brouwers 2008-12-10 17:41:02 UTC
In 1.2.3, the alsa hook is no longer present upstream.  This can probably be removed from the installation.
Comment 12 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-10 17:45:34 UTC
(In reply to comment #11)
> In 1.2.3, the alsa hook is no longer present upstream.  This can probably be
> removed from the installation.
> 

Remove the alsa USE flag and "use alsa           || ignore="${ignore} 60alsa"" ?
Comment 13 Andrew Brouwers 2008-12-10 18:50:09 UTC
I believe so.  The thread that led up to this in the previous release was:

http://lists.freedesktop.org/archives/pm-utils/2008-November/001808.html

I'd say it's good to remove.
Comment 14 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-10 18:58:24 UTC
added 1.2.3, please open new bugs for additional issues. Thanks.
Comment 15 Yang Zhao 2008-12-12 17:43:28 UTC
Closing. Thanks.