Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 224967

Summary: Several instances of gnome-extra/nm-applet launched on login
Product: Gentoo Linux Reporter: Dmitrij D. Czarkoff <czarkoff>
Component: Current packagesAssignee: Steev Klimaszewski (RETIRED) <steev>
Severity: normal CC: pacho
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Dmitrij D. Czarkoff 2008-06-05 08:28:14 UTC
I use =gnome-extra/nm-applet-0.6.6 with gnome 2.22.2. When I log in, I have either 3 instances of nm-applet + 1 instance launched by gnome-session whilre restoring previous session. What can I do to have exactly one nm-applet launched?
Comment 1 Steev Klimaszewski (RETIRED) gentoo-dev 2008-11-19 21:23:59 UTC
This isn't really a bug - it would appear that somehow you've had some launched without --sm-disable - kill all instances of nm-applet, and log out and back in to gnome and it should just launch the one on its own that includes --sm-disable.
Comment 2 Dmitrij D. Czarkoff 2008-11-19 21:47:55 UTC
In fact it was persistant through reboots and logins/logouts and I didn't launch nm-applet at all - everything was done through gentoo default configs.
Comment 3 Pacho Ramos gentoo-dev 2009-07-12 13:19:12 UTC
I don't suffer this with 0.7.1-r3
Comment 4 Steev Klimaszewski (RETIRED) gentoo-dev 2010-04-04 13:56:45 UTC
Do you still get this Dmitrij?  Resolving the bug as NEEDINFO (mainly due to a response one way or the other - Pacho said that he didn't experience it with 0.7.1 - its now quite a ways past that, so I'd like to know if you still do :)
Comment 5 Dmitrij D. Czarkoff 2010-04-05 12:14:27 UTC
As far as I remember, I solved the problem by some tricks with hal. Anyway, didnĀ“t experience this bug since some update till switched to Arch.