Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 224483

Summary: sys-apps/coreutils-6.12 - touch uses unknown system call utimensat
Product: Gentoo Linux Reporter: Andrei Ivanov <andrei.ivanov>
Component: [OLD] Core systemAssignee: Gentoo's Team for Core System packages <base-system>
Status: RESOLVED FIXED    
Severity: critical CC: antonio.andriollo, arpad.kunszt, cov, craig, creideiki+gentoo-bugzilla, drobbins, ed, even.more.spam.for.me, farcaller, frares, gejzer, gentoo-bugs, gentoo, giles, info, jer, jkt, loki_val, mark-gentoo, matt, modelnine, nsp_gentoo_bugs, paulo, peter, polynomial-c, rdmurray, steeeeeveee, theli.ua
Priority: High    
Version: 2007.0   
Hardware: All   
OS: Linux   
URL: http://lists.gnu.org/archive/html/bug-coreutils/2008-06/msg00022.html
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 233280, 348640    
Attachments: coreutils-6.12-faeb3e6b2191565dc3197804cd9ff624f26a1004-revert.patch
sys-apps/coreutils/files/coreutils-6.12-utimens.patch
gnulib-utimens-update.patch
coreutils-6.12-utimenstouchcp.patch

Description Andrei Ivanov 2008-06-01 14:23:54 UTC
touch from sys-apps/coreutils-6.12 fails:

touch a
touch: setting times of `a': Function not implemented

open("a", O_WRONLY|O_CREAT|O_NOCTTY|O_NONBLOCK|O_LARGEFILE, 0666) = 3
dup2(3, 0)                              = 0
close(3)                                = 0
utimensat(0, NULL, NULL, 0)             = -1 ENOSYS (Function not implemented)
close(0)                                = 0
write(2, "touch: ", 7touch: )                  = 7
write(2, "setting times of `a\'", 20setting times of `a')   = 20
write(2, ": Function not implemented", 26: Function not implemented) = 26
write(2, "\n", 1
)                       = 1
close(1)                                = 0
close(2)                                = 0
exit_group(1)                           = ?


emerge --info
Portage 2.1.5.3 (default-linux/x86/2007.0, gcc-4.2.4, glibc-2.7-r2, 2.6.18-gentoo-r3 i686)
=================================================================
System uname: 2.6.18-gentoo-r3 i686 Pentium III (Coppermine)
Timestamp of tree: Sun, 01 Jun 2008 13:18:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r4, 2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.12
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r3
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openjms/config /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php4/ext-active/ /etc/php/cgi-php4/ext-active/ /etc/php/cli-php4/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="candy distlocks fixpackages parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://ftp.roedu.net/pub/mirrors/gentoo.org"
LDFLAGS=""
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl adns apache2 bzip2 caps cli cracklib crypt curl dri expat flash gd gmp gpm iconv idn imap innodb isdnlog javamail jpeg maildir memlimit midi mmx mudflap ncurses network-cron noauthcram nptl nptlonly offensive openmp pam pcre pg-hier pg-intdatetime pg-vacuumdelay pic pppd readline reflection samba session slang slp spl sse ssl tcpd tiff unicode urandom utf8 vim-syntax x86 xattr xml xml2 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1    emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m   maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt         mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage  siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware     voodoo"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


I tried to downgrade coreutils, but touch is required to work it seems :-(

touch: setting times of `/var/tmp/portage/sys-apps/coreutils-6.11/.unpacked': Function not implemented
 *
 * ERROR: sys-apps/coreutils-6.11 failed.
 * Call stack:
 *               ebuild.sh, line 1793:  Called dyn_unpack
 *               ebuild.sh, line  686:  Called die
 * The specific snippet of code:
 *      touch "${PORTAGE_BUILDDIR}/.unpacked" || die "IO Failure -- Failed 'touch .unpacked' in ${PORTAGE_BUILDDIR}"
 *  The die message:
 *   IO Failure -- Failed 'touch .unpacked' in /var/tmp/portage/sys-apps/coreutils-6.11
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
Comment 1 Jeroen Roovers gentoo-dev 2008-06-01 22:58:07 UTC
It appears your kernel is too old. But then the coreutils ebuild should perhaps check that.
Comment 2 Andrei Ivanov 2008-06-02 07:36:01 UTC
I saw that utimensat apeared in 2.6.22, but indeed, coreutils should check that.
The problem is that I might have an unusable system, and I don't know how to restore it... maybe just by upgrading the kernel.
Comment 3 Micha Glave 2008-06-02 10:57:17 UTC
I run into the same proplem... 
It's on a xen-vm (2.6.16.42) how can I work-around? The "xen-sources" froze 2.6.21 ...

ok, for the first step I will mask  ">=coreutils-6.12"

Any other way to solve this issue?
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2008-06-02 16:11:59 UTC
[1] in gnulib which is imported directly into coreutils is the commit that broke this. utimensat is defined by glibc in sys/stat.h -- nevertheless, it can still return ENOSYS on systems that don't support utimensat. As you can see, gnulib just uses it and expects that because it is declared, it is usable. Reverting the commit in coreutils should do the trick.

http://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=commitdiff;h=faeb3e6b2191565dc3197804cd9ff624f26a1004
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2008-06-02 16:46:54 UTC
Created attachment 155253 [details, diff]
coreutils-6.12-faeb3e6b2191565dc3197804cd9ff624f26a1004-revert.patch

The above suggestion in patchform
Comment 6 SpanKY gentoo-dev 2008-06-03 00:17:36 UTC
can someone affected please test this patch:
http://lists.gnu.org/archive/html/bug-coreutils/2008-06/msg00034.html
Comment 7 Andrei Ivanov 2008-06-03 07:46:12 UTC
As I said, I cannot install anything anymore because touch is required to work
Comment 8 Jeroen Roovers gentoo-dev 2008-06-03 07:53:55 UTC
(In reply to comment #7)
> As I said, I cannot install anything anymore because touch is required to work

You should be able to install a tbz2 package from tinderbox.dev.gentoo.org:

http://tinderbox.dev.gentoo.org/default-linux/x86/sys-apps/coreutils-6.10-r2.tbz2

and build a patched coreutils after that.
Comment 9 Andrei Ivanov 2008-06-03 11:48:34 UTC
(In reply to comment #6)
> can someone affected please test this patch:
> http://lists.gnu.org/archive/html/bug-coreutils/2008-06/msg00034.html
> 

The patch doesn't apply:

lib/utimens.c.rej
***************
*** 125,133 ****

      if (fd < 0)
        {
- #  if HAVE_FUTIMESAT
         return futimesat (AT_FDCWD, file, t);
- #  endif
        }
      else
        {
--- 135,143 ----

      if (fd < 0)
        {
+ # if HAVE_FUTIMESAT
         return futimesat (AT_FDCWD, file, t);
+ # endif
        }
      else
        {
***************
*** 141,161 ****
            worth optimizing, and who knows what other messed-up systems
            are out there?  So play it safe and fall back on the code
            below.  */
- #  if HAVE_FUTIMESAT
         if (futimesat (fd, NULL, t) == 0)
           return 0;
***************
*** 125,133 ****

      if (fd < 0)
        {
- #  if HAVE_FUTIMESAT
         return futimesat (AT_FDCWD, file, t);
- #  endif
        }
      else
        {
--- 135,143 ----

      if (fd < 0)
        {
+ # if HAVE_FUTIMESAT
         return futimesat (AT_FDCWD, file, t);
+ # endif
        }
      else
        {
***************
*** 141,161 ****
            worth optimizing, and who knows what other messed-up systems
            are out there?  So play it safe and fall back on the code
            below.  */
- #  if HAVE_FUTIMESAT
         if (futimesat (fd, NULL, t) == 0)
           return 0;
- #  elif HAVE_FUTIMES
         if (futimes (fd, t) == 0)
           return 0;
- #  endif
        }
- # endif /* HAVE_FUTIMESAT || HAVE_WORKING_UTIMES */

      if (!file)
        {
- # if ! (HAVE_FUTIMESAT || (HAVE_WORKING_UTIMES && HAVE_FUTIMES))
         errno = ENOSYS;
- # endif

         /* Prefer EBADF to ENOSYS if both error numbers apply.  */
         if (errno == ENOSYS)
--- 151,171 ----
            worth optimizing, and who knows what other messed-up systems
            are out there?  So play it safe and fall back on the code
            below.  */
+ # if HAVE_FUTIMESAT
         if (futimesat (fd, NULL, t) == 0)
           return 0;
+ # elif HAVE_FUTIMES
         if (futimes (fd, t) == 0)
           return 0;
+ # endif
        }
+ #endif /* HAVE_FUTIMESAT || HAVE_WORKING_UTIMES */

      if (!file)
        {
+ #if ! (HAVE_FUTIMESAT || (HAVE_WORKING_UTIMES && HAVE_FUTIMES))
         errno = ENOSYS;
+ #endif

         /* Prefer EBADF to ENOSYS if both error numbers apply.  */
         if (errno == ENOSYS)
Comment 10 steveb 2008-06-03 15:01:43 UTC
Created attachment 155373 [details, diff]
sys-apps/coreutils/files/coreutils-6.12-utimens.patch

(In reply to comment #6)
> can someone affected please test this patch:
> http://lists.gnu.org/archive/html/bug-coreutils/2008-06/msg00034.html
> 
Yes! The above mentioned patch (slightly modified to allow patching 6.12) fixes the issue.
Comment 11 Mark Glines 2008-06-04 12:22:54 UTC
(In reply to comment #10)
> Yes! The above mentioned patch (slightly modified to allow patching 6.12) fixes
> the issue.
> 

Note: the issue affects "cp -a" as well as touch.  So far it looks like your patch fixed both of them.  Thanks!

Mark
Comment 12 Paulo J. Matos 2008-06-05 11:23:57 UTC
patch worked here ~amd64.
Comment 13 Jan Kundrát (RETIRED) gentoo-dev 2008-06-05 17:46:39 UTC
Were the people affected by this change using sys-kernel/linux-headers newer than the kernel image they were running?
Comment 14 Peter Alfredsen (RETIRED) gentoo-dev 2008-06-05 18:37:59 UTC
(In reply to comment #13)
> Were the people affected by this change using sys-kernel/linux-headers newer
> than the kernel image they were running?

Bingo.

vapier: this is your baby. Why is this not masked yet?
Comment 15 SpanKY gentoo-dev 2008-06-07 15:38:47 UTC
Created attachment 155835 [details]
gnulib-utimens-update.patch

it really isnt a kernel header issue.  please refrain from masking requests when it isnt warranted.

someone test this patch
Comment 16 Christopher Covington 2008-06-07 23:36:01 UTC
(In reply to comment #15)
> someone test this patch

End of the emerge with the patch applied:
--- replaced obj /bin/cp
--- replaced obj /bin/chroot
--- replaced obj /bin/chown
--- replaced obj /bin/chmod
--- replaced obj /bin/chgrp
--- replaced obj /bin/cat
--- replaced obj /bin/basename
--- replaced dir /bin
touch: setting times of `/var/tmp/binpkgs/sys-apps/coreutils-6.12/temp/environment.success': Bad address
touch: setting times of `/var/tmp/binpkgs/sys-apps/coreutils-6.12/temp/environment.success': Bad address
>>> Original instance of package unmerged safely.
touch: setting times of `/var/tmp/portage/sys-apps/coreutils-6.12/temp/environment.success': Bad address
 * Make sure you run 'hash -r' in your active shells.
touch: setting times of `/var/tmp/portage/sys-apps/coreutils-6.12/temp/environment.success': Bad address
>>> sys-apps/coreutils-6.12 merged.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * Messages for package sys-apps/coreutils-6.12:

 * Make sure you run 'hash -r' in your active shells.

 * GNU info directory index is up-to-date.

Have not tried older patch yet.
Comment 17 Christopher Covington 2008-06-08 00:50:56 UTC
Alfredsen's patch works for me. I suppose I should be including my info.

Portage 2.1.5.4 (default-linux/x86/vserver, gcc-4.2.4, glibc-2.7-r2, 2.6.18-028stab053 i686)
=================================================================
System uname: 2.6.18-028stab053 i686 Intel(R) Core(TM)2 Duo CPU E4500 @ 2.20GHz
Timestamp of tree: Sat, 07 Jun 2008 13:04:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.4-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r3
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--nospinner"
FEATURES="distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LDFLAGS=""
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X berkdb bzip2 cgi cli cracklib crypt curl dri exif fam fastcgi flatfile ftp iconv ipv6 isdnlog jpeg memlimit midi ming mmx mudflap ncurses nptl nptlonly openmp pam pcre php png pppd psyco python readline recode reflection rrdtool session smp socks5 speex spell spl sse sse2 ssl tcpd threads tidy truetype unicode vhosts x86 xml xorg xsl zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 	emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m 	maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="none"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 18 Ed Catmur 2008-06-08 21:29:26 UTC
(In reply to comment #15)
> Created an attachment (id=155835) [edit]
> gnulib-utimens-update.patch
> 
> it really isnt a kernel header issue.  please refrain from masking requests
> when it isnt warranted.
> 
> someone test this patch
> 

Works here.

Portage 2.1.5.4 (default-linux/x86/vserver, gcc-4.2.3, glibc-2.7-r2, 2.6.18-ovz028stab039.1-smp i686)
=================================================================
System uname: 2.6.18-ovz028stab039.1-smp i686 Intel(R) Xeon(TM) CPU 2.80GHz
Timestamp of tree: Sun, 08 Jun 2008 02:01:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.1-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.62
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r3
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=i686 -Os -pipe --param ggc-min-expand=0 --param ggc-min-heapsize=8192"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=i686 -Os -pipe --param ggc-min-expand=0 --param ggc-min-heapsize=8192"
DISTDIR="/usr/portage/distfiles"
FEATURES="distcc distlocks parallel-fetch patchtree sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_GB.UTF-8"
LDFLAGS=""
LINGUAS="en_GB en en_US ja_JP de_DE es_ES fa_IR fr_FR it_IT ru_RU"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/srv/gentoo/trees/catmur.co.uk /srv/gentoo/trees/webapps-experimental"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X apache2 avahi bash-completion bcmath berkdb bzip2 cjk cli courier cracklib crypt cvsgraph dbus enscript extras fam ffmpeg gd gdbm geoip gif gnome graphviz gtk iconv imagemagick imap ipv6 isdnlog jpeg math midi mod_python mudflap ncurses netpbm nls nptl nptlonly openmp pam pcre pdf png pppd python readline reflection session spell spl ssl subversion svg tcpd tiff truetype unicode unzip vhosts x86 xml xpm zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 	emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m 	maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en en_US ja_JP de_DE es_ES fa_IR fr_FR it_IT ru_RU" USERLAND="GNU"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 19 Christopher Covington 2008-06-09 11:55:02 UTC
I've been getting "Bad address" errors the whole time, and actually have never gotten the "Function not implemented" error. Since Alfredsen's patch fixed my error too, I'm thinking I'm experiencing a slightly different symptom of the same problem but if it really is a different bug, please advise and I'll file a new report.
Comment 20 Andrei Ivanov 2008-06-10 07:26:42 UTC
I cannot test anymore, I've upgraded the kernel...
Comment 21 Stefan de Konink 2008-06-18 21:20:38 UTC
(In reply to comment #15)
> Created an attachment (id=155835) [edit]
> gnulib-utimens-update.patch
> 
> it really isnt a kernel header issue.  please refrain from masking requests
> when it isnt warranted.
> 
> someone test this patch

Tested on 2.6.21-xen... works. Thank for the patch. I hope you can put it in portage.
Comment 22 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-06-19 22:46:33 UTC
Started getting this on one of my older boxes too on the upgrade to 6.12

touch: setting times of `/var/tmp/portage/sys-apps/man-pages-3.00/.unpacked': Bad address


Portage 2.1.5.6 (default-linux/x86/2006.1/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.21-rc6-mm1 i686)
=================================================================
System uname: 2.6.21-rc6-mm1 i686 AMD Athlon(tm)
Timestamp of tree: Unknown
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.2-r1
dev-lang/python:     2.3.6-r2, 2.4.4-r4, 2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/confcache:  0.4.2-r1
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -Os -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon-xp -Os -pipe"
DISTDIR="/home/gentoo/distfiles"
FEATURES="assume-digests autoaddcvs buildpkg ccache collision-protect cvs digest distlocks lmirror mirror parallel-fetch sandbox sfperms splitdebug strict unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS=""
LINGUAS="en en_CA en_US en_GB en_ZA"
MAKEOPTS="-j2"
PKGDIR="/home/gentoo/packages/newton-int"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/code/gentoo/gentoo-cvs/gentoo-x86"
PORTDIR_OVERLAY="/usr/local/portage-layman/flameeyes-overlay-private /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acl acpi aio alsa amd ao apm ares async automount avahi avi berkdb bluetooth browserplugin bzip2 cairo calendar caps cdb cdda cdr cgi clamav clearpasswd cli cpdflib cracklib crypt cscope ctype cups curl curlwrappers daap dbus device-mapper divx4linux dmx doc dri dts dv dvd dvdr dvdread dynagraph emboss encode ethereal exif expat f77 fam fame fastcgi ffmpeg fftw firefox flac flash foomaticdb fortran fpx frxp gcj gd gdbm geoip gif glitz glx gmp gnokii gnults gnuplot gnutls gpm graphviz gs gstreamer gzip hal hpn ical iconv imap imlib innodb insecure-savers ipalias ipod ipv6 irda isdnlog jack jack-tmpfs java javadoc jbig joystick jpeg jpeg2k lcms ldap libnotify libsamplerate libwww linuxthreads-tls live logitech-mouse lzo mad maildir mbox mcal md5sum midi mikmod mjpeg mmx mmxext mod motif mozilla mozplugin mp3 mpeg mpm-prefork mudflap multicall musicbrainz mysql ncurses netjack network nptl nptlonly nsplugin numeric nvidia objc offensive ogg oggvorbis openexr opengl openmp osd pam pcap pcre pda pdf pdflib perl pg-intdatetime pic plotutils png pnp portaudio ppds pppd pulseaudio python qmail quicktime quotas rdesktop readline reflection rtc ruby samba scanner screen sdl session shout skins slang slp sms sndfile snmp socks5 speex spell spl sqlite sse ssl stream svg swat syslog t1lib tcltk tetex theora threads tiff truetype truetype-fonts type1 type1-fonts ungif unicode usb userlocales utf8 v4l v4l2 vcd vhosts vidix vim-syntax vlm vorbis win32codecs winbind wmf wxwindows x86 xanim xcb xchatdccserver xcomposite xinerama xml xml2 xorg xosd xrandr xscreensaver xv xvid xvmc yv12 zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 	emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m 	maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" FOO2ZJS_DEVICES="hp1020" INPUT_DEVICES="evdev keyboard mouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_CA en_US en_GB en_ZA" USERLAND="GNU" VIDEO_CARDS="dummy nv nvidia vga vesa none"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 23 George Shammas 2008-06-27 18:36:51 UTC
The most recent patch worked like a charm on my Xen 2.6.16.29 kernel. I too hope it ends up in portage.
Comment 24 Flo Gravo 2008-06-29 12:38:42 UTC
Did work for me, too.

# uname -a
Linux livecd 2.6.16-ps3 #1 SMP Thu Mar 15 19:06:46 UTC 2007 ppc64 Cell Broadband Engine, altivec supported PS3PF GNU/Linux

# emerge --info
WARNING: repository at /usr/local/portage is missing a repo_name entry
Portage 2.2_rc1 (default/linux/powerpc/ppc64/2008.0/32bit-userland/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.16-ps3 ppc64)
=================================================================
System uname: Linux-2.6.16-ps3-ppc64-Cell_Broadband_Engine,_altivec_supported-with-glibc2.0
Timestamp of tree: Sun, 29 Jun 2008 09:45:01 +0000
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.4.4-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.62
sys-devel/automake:  1.10.1-r1
sys-devel/binutils:  2.18-r2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="ppc ppc64 ~ppc ~ppc64"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-Os -pipe -mcpu=cell -mabi=altivec -fomit-frame-pointer"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/gentoo-release /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-Os -pipe -mcpu=cell -mabi=altivec -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://de-mirror.org/distro/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo/ http://mirror.ovh.net/gentoo-distfiles/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://mirror.muntinternet.net/pub/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=both -Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X alsa altivec berkdb bindist bluetooth bzip2 c++ cairo cdda cddb cdio cdr cli cracklib crypt cvs cxx dbus dri dts dvd dvdr dvdread eds emboss encode ffmpeg firefox flac fortran freetype ftp gcc64 gdbm gif git glib glibc-omitfp gpm grub gstreamer gtk hal iconv id3 id3tag ipv6 isdnlog java java6 javascript jpeg jpeg2k kerberos lame libnotify lzma lzo mad matroska mdnsresponder-compat metric midi mikmod mjpeg mng modplug mozilla mozsha1 mp2 mp3 mp4 mp4live mpeg mpeg2 mudflap musepack musicbrainz ncurses network nls nptl nptlonly nsplugin ntp ogg opengl openmp pam pcre pdf perl png ppc ppcsha1 ppds pppd ps3 pulseaudio python qt3support quicktime readline realmedia reflection sdl session spell spl ssl startup-notification subversion svg symlink tagwriting tcpd theora thunderbird tiff truetype twolame type1 unicode usb vcd vcdx vid vim-syntax vim-with-x vlm vorbis wifi wma wmf wmp x264 xml xorg xscreensaver xv zeroconf zip zlib" ALSA_CARDS="usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 25 Michael Arntzenius 2008-07-03 20:16:27 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > Were the people affected by this change using sys-kernel/linux-headers newer
> > than the kernel image they were running?
> 
> Bingo.
> 

I am not running linux-headers newer than my kernel image (I run 2.6.21-suspend2-r7, with linux-headers-2.6.17-r2), and I still had this problem. The patch works for me.

emerge --info output:

Portage 2.2_rc1 (default-linux/amd64/2006.1/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.21-suspend2-r7 x86_64)
=================================================================
System uname: Linux-2.6.21-suspend2-r7-x86_64-Intel-R-_Core-TM-2_CPU_T5600_@_1.83GHz-with-glibc2.2.5
Timestamp of tree: Tue, 01 Jul 2008 14:33:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r5
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.17-r2
ABI="amd64"
ACCEPT_KEYWORDS="amd64 ~amd64"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x 	ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 	trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol"
ANT_HOME="/usr/share/ant-core"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ARCH="amd64"
ASFLAGS_x86="--32"
AUTOCLEAN="yes"
CACA_FONT="5x7"
CACA_GEOMETRY="256x114"
CBUILD="x86_64-pc-linux-gnu"
CCACHE_DIR="/var/tmp/ccache/"
CCACHE_SIZE="2G"
CDEFINE_amd64="__x86_64__"
CDEFINE_x86="__i386__"
CFLAGS="-O3 -fomit-frame-pointer -march=nocona -pipe"
CFLAGS_x86="-m32 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
COLORFGBG="15;0"
COLORTERM="rxvt"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CVS_RSH="ssh"
CXXFLAGS="-O3 -fomit-frame-pointer -march=nocona -pipe"
DEFAULT_ABI="amd64"
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_WARNING_DELAY="10"
FEATURES="ccache distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
GCC_SPECS=""
GDK_USE_XFT="1"
GENERATION="2"
GENTOO_MIRRORS="http://lug.mtu.edu/gentoo/ http://gentoo.binarycompass.org/ http://gentoo.osuosl.org/"
GIT_EDITOR="emacsclient"
GPG_AGENT_INFO="/tmp/gpg-sPBhSk/S.gpg-agent:2623:1"
HG="/usr/bin/hg"
HGEDITOR="emacsclient"
HOME="/home/daedalus"
HUSHLOGIN="FALSE"
INFODIR="/usr/GNUstep/System/Library/Documentation/info:/usr/GNUstep/Local/Library/Documentation/info"
INFOPATH="/usr/share/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.18/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.1/info:/usr/share/info/emacs-23:/usr/GNUstep/System/Library/Documentation/info:/usr/GNUstep/Local/Library/Documentation/info"
INPUT_DEVICES="keyboard mouse"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LDFLAGS=""
LDFLAGS_x86="-m elf_i386 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBDIR_amd64="lib64"
LIBDIR_x86="lib32"
LIBGL_DRIVERS_PATH="/usr/lib64/dri:/usr/lib32/dri"
LOGNAME="root"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:"
MAIL="/var/mail/daedalus"
MAKEOPTS="-j3"
MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.18/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.1/man:/opt/blackdown-jdk-1.4.2.03/man:/etc/java-config/system-vm/man/:/usr/GNUstep/System/Library/Documentation/man:/usr/GNUstep/Local/Library/Documentation/man"
MC_MODE=""
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib /usr/lib /usr/kde/*/lib /usr/qt/*/lib /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage)"
NOCOLOR="true"
OLDPWD="/home/daedalus"
OPENGL_PROFILE="xorg-x11"
PATH="/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/opt/bin:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_NICENESS="5"
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/rntz"
PORT_LOGDIR="/var/log/portage/"
PWD="/home/daedalus"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.3.1:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin"
RPMDIR="/usr/portage/rpm"
RUBYOPT="-rauto_gem"
SBCL_HOME="/usr/lib64/sbcl"
SBCL_SOURCE_ROOT="/usr/lib64/sbcl/src"
SHELL="/bin/zsh"
SHLVL="4"
SSH_AGENT_PID="2597"
SSH_AUTH_SOCK="/tmp/ssh-mTVWpG2596/agent.2596"
STAGE1_USE="nptl nptlonly unicode"
STY="20191.pts-8.elysium"
SUDO_COMMAND="/usr/bin/emerge -v --info"
SUDO_GID="1000"
SUDO_UID="1000"
SUDO_USER="daedalus"
SYMLINK_LIB="yes"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
TERM="screen"
TEXINPUTS="/usr/lib64/ocaml/ocamldoc:"
USE="X a52 aac acpi aim alsa amd64 ao apm bash-completion berkdb bluetooth bzip2 cairo caps cdda cddb cdparanoia cdr cli cracklib crypt css cups curl dbus dri dvd dvdr emacs emboss encode exif fam ffmpeg fftw firefox flac fortran ftp fuse gdbm gif gmp gnutls gpm gstreamer gtk gtk2 gtkhtml hal hardened iconv imap imlib ipod ipv6 isdnlog jabber java jpeg latex ldap libedit mad matroska midi mikmod mime mmap mp3 mpeg mplayer mudflap mule musepack ncurses nls nptl nptlonly nsplugin objc objc-gc ogg openmp pam pcmcia pcre pdf png ppds pppd python quicktime readline reflection sasl sdl session sharedmem smp sockets spell spl sqlite sqlite3 ssl startup-notification svg tcpd theora threads tidy tiff truetype unicode usb vorbis wifi x264 xattr xft xml xorg xpm xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x 	ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 	trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon"
USER="root"
USERLAND="GNU"
USERNAME="root"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS APACHE2_MODULES APACHE2_MPMS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="radeon"
VMHANDLE="blackdown-jdk-1.4.2"
WINDOW="0"
WINDOWID="14835056"
WINDOWPATH="8"
WMII_9MENU="wmii9menu -font -*-architect-medium-r-normal-*-11-* -nf #eeeeee -nb #000000 -sf #ff5500 -sb #151515 -br unusedn"
WMII_ADDRESS="unix!/tmp/ns.daedalus.:0/wmii"
WMII_CONFPATH="/home/daedalus/.wmii-3.5:/usr/local/etc/wmii-3.5"
WMII_FOCUSCOLORS="#ffa000 #080840 #404099"
WMII_FONT="-*-architect-medium-r-normal-*-11-*"
WMII_MENU="dmenu -b -fn -*-architect-medium-r-normal-*-11-* -nf #eeeeee -nb #000000 -sf #ff5500 -sb #151515"
WMII_NORMCOLORS="#dddddd #000000 #666666"
WMII_NS_DIR="/tmp/ns.daedalus.:0"
WMII_TERM="urxvtc -e screen zsh"
XAUTHORITY="/home/daedalus/.Xauthority"
XDG_SESSION_COOKIE="2e7840e1f12c9be864bb120045be8a70-1214829248.144610-1811810501"
_="/usr/bin/sudo"
Comment 26 Steffen Voigt 2008-07-12 11:19:01 UTC
hi

i'm suffering from the same problem... how do i apply the patch from post #15 to my system ?

thanks
Comment 27 Samuli Suominen gentoo-dev 2008-07-27 12:23:12 UTC
*** Bug 233018 has been marked as a duplicate of this bug. ***
Comment 28 Daniel Robbins 2008-07-27 18:14:20 UTC
Let's get this fixed - it tends to cause Gentoo installed in OpenVZ virtual containers to fail as then there is no connection between kernel version (typically 2.6.18) and linux-headers version inside the virtual environment.
Comment 29 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-27 19:39:25 UTC
+*coreutils-6.12-r1 (27 Jul 2008)
+
+  27 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+  +files/gnulib-utimens-update.patch, -coreutils-6.12.ebuild,
+  +coreutils-6.12-r1.ebuild:
+  Fix for bug #224483. People with old kernels can use this once more.
+
Comment 30 Doug Goldstein gentoo-dev 2008-07-29 16:46:09 UTC
*** Bug 233280 has been marked as a duplicate of this bug. ***
Comment 31 Christopher Covington 2008-07-29 20:17:18 UTC
Please reopen. The applied patch [1] does not fix the Bad Address errors. Note that Peter Alfredsen's original patch [2] did. See my comments #16, #17 and #19 as well as bug #233280.

1. https://bugs.gentoo.org/attachment.cgi?id=155835
2. https://bugs.gentoo.org/attachment.cgi?id=155253
Comment 32 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-29 21:26:34 UTC
Created attachment 161662 [details, diff]
coreutils-6.12-utimenstouchcp.patch

This patch should fix your problem. Test please?
Comment 33 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-29 21:27:07 UTC
Reopening, waiting for test results.
Comment 34 Christopher Covington 2008-07-30 13:03:26 UTC
(In reply to comment #32)
> Created an attachment (id=161662) [edit]
> coreutils-6.12-utimenstouchcp.patch
> 
> This patch should fix your problem. Test please?
> 

Does not seem to do it. I modified the patched version in my local repo to use patch #161662 and:

# emerge -1 coreutils
...
--- replaced obj /bin/chmod
--- replaced obj /bin/chgrp
--- replaced obj /bin/cat
--- replaced obj /bin/basename
--- replaced dir /bin
touch: setting times of `/var/tmp/binpkgs/sys-apps/coreutils-6.12-r1/temp/environment.success': Bad address
...
Comment 35 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-30 15:32:14 UTC
Then I'm afraid this is probably a OpenVZ kernel issue. I'll be reopening the DUPLICATED bug so we can track this.
Comment 36 H.-Peter Pfeufer 2008-08-10 20:12:01 UTC
I have this Problem on every emerge, also if I try to emerge portage

touch: Setzen der Zeiten für »/home/tempdir/tmp/portage/sys-apps/portage-2.2_rc7/.unpacked«: Die angeforderte Funktion ist nicht implementiert

(This line in english: touch: settung times of **** function not implemented)

 *
 * ERROR: sys-apps/portage-2.2_rc7 failed.
 * Call stack:
 *               ebuild.sh, line 1784:  Called dyn_unpack
 *               ebuild.sh, line  677:  Called die
 * The specific snippet of code:
 *      touch "${PORTAGE_BUILDDIR}/.unpacked" || die "IO Failure -- Failed 'touch .unpacked' in ${PORTAGE_BUILDDIR}"
 *  The die message:
 *   IO Failure -- Failed 'touch .unpacked' in /home/tempdir/tmp/portage/sys-apps/portage-2.2_rc7


So my Problem is, I cant do any emerge.

dev-con etc # emerge --info
Portage 2.2_rc1 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r0, 2.6.21-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.21-gentoo-r2-x86_64-AMD_Turion-tm-_64_Mobile_Technology_ML-37-with-glibc2.2.5
Timestamp of tree: Sun, 10 Aug 2008 19:34:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ ftp://pandemonium.tiscali.de/pub/gentoo/ ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.gentoo.org/gentoo-distfiles/"
LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="de de-DE"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/science /usr/local/portage/layman/gentoo-de /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/vmware"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 arts berkdb bzip2 cli cracklib crypt cups dri fortran gdbm gpm hal iconv ipv6 isdnlog java kde midi mmx mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre perl pppd python qt3 qt4 readline reflection samba session spl sse sse2 ssl sysfs tcpd unicode xine xinerama xorg xscreensaver zlib" ALSA_CARDS="intel8x0 intel8x0m via82xx via82xx-modem" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias include" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de de-DE" LIRC_DEVICES="audio audio_alsa dsp" USERLAND="GNU" VIDEO_CARDS="fbdev nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 37 Mikael Magnusson 2008-08-13 00:05:53 UTC
My friend couldn't install -r1 since touch didn't work, which is needed for emerge to work internally. We came up with this temporary workaround to allow the merge to complete. (warning, ugly hack ahead :)

mv /bin/touch /bin/oldtouch
echo '#!/bin/sh' > /bin/touch
echo 'echo -n >> "$1"' >> /bin/touch
chmod +x /bin/touch

maybe it helps someone else.
Comment 38 Daniel Robbins 2008-08-13 01:53:09 UTC
A good solution could be to mask 6.12 and use 6.10 which doesn't have this problem (right?) until we have a good patch. That would allow this bug to be closed and we wait for upstream to resolve.
Comment 39 Daniel Robbins 2008-08-13 01:59:14 UTC
And this bug needs to be reopened as the 6.12-r1 ebuild does not fix the issue.
Comment 40 SpanKY gentoo-dev 2008-10-26 04:18:04 UTC
*** Bug 241142 has been marked as a duplicate of this bug. ***
Comment 41 Jeroen Roovers gentoo-dev 2009-04-30 10:46:50 UTC
*** Bug 267963 has been marked as a duplicate of this bug. ***
Comment 42 Peter Hultqvist 2009-04-30 10:55:40 UTC
I had this problem today when upgrading coreutils from 6.10-r2 to 7.1

Comment 43 R. David Murray 2009-05-06 20:26:11 UTC
I just upgraded an OpenVZ container.  coreutils went from 6.10-r2 to 7.1, and this problem showed up.  For the record:

touch: setting times of XXXX: Bad Address

Now I have to figure out how to get out of this mess.
Comment 44 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-06 20:41:50 UTC
(In reply to comment #43)
> I just upgraded an OpenVZ container.  coreutils went from 6.10-r2 to 7.1, and
> this problem showed up.  For the record:
> 
> touch: setting times of XXXX: Bad Address
> 
> Now I have to figure out how to get out of this mess.

See bug 233280, comment 15
Comment 45 Matthew Daubenspeck 2010-12-14 14:03:11 UTC
*** Bug 348714 has been marked as a duplicate of this bug. ***
Comment 46 GM 2010-12-28 06:17:49 UTC
(In reply to comment #37)
> My friend couldn't install -r1 since touch didn't work, which is needed for
> emerge to work internally. We came up with this temporary workaround to allow
> the merge to complete. (warning, ugly hack ahead :)
> 
> mv /bin/touch /bin/oldtouch
> echo '#!/bin/sh' > /bin/touch
> echo 'echo -n >> "$1"' >> /bin/touch
> chmod +x /bin/touch
> 
> maybe it helps someone else.
> 

Thanks , this hack works for my VM 

# uname -a
Linux serpico 2.6.18-xen-r12 #1 SMP Thu Oct 1 17:11:58 UTC 2009 x86_64 Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz GenuineIntel GNU/Linux



Comment 47 the_mgt 2011-01-03 02:00:00 UTC
resolved fixed, of course...

NOTHING is fixed here, you just assume that people do not use these old kernels anymore. This bug properly describes the problems and even offers solutions and I am not the only person hitting this bug now.

I ran into this just prior to moving a VM from XEN to KVM, just wanted to do one last emerge world -DNuva in order to get the latest kernel source and build a new kernel for this xen-VMs next life as a kvm guest. Everything runs fine until the coreutils upgrade...

* sys-kernel/xen-sources
     Available versions:  
        (2.6.18-r12)    2.6.18-r12!b!s
        (2.6.34-r3)     ~2.6.34-r3!b!s
        (2.6.34-r4)     ~2.6.34-r4!b!s

There is only one stable xen-source version. Yes, it is old and yes thats the reason why I migrate to kvm. But please dont punish users for their usage of stable in-tree software like this!

The only condition under which this bug might be called "resolved fixed" is when no more packages are in tree which could cause portage/emerge to fail because of a broken "touch" command. And it's not as if you havent been warned:
I just read http://bugs.gentoo.org/show_bug.cgi?id=348640 which has was filed by a gentoo dev running into this half a month ago... XEN is mentioned in that report, it is mentioned in this report several times, you could have at least put a check in the ebuild to prevent those (and other older kernel users, since it seems to have been known that kernels before 2.6.22 would fail) users from being frustrated.

And to be helpfull a little bit, the bug only happens in sandbox:
1. It happens on the unpack phase while using "emerge"
2. It happens with "ebuild ..." in the "install" phase when the ".keep" files are created with touch (but not on "unpack" or other phases)
3. "touch" behaves completely normal outside of sandbox.

Please, use cases like this to learn something and establish some kind of emergency policy for bugs that reappear and threaten the functions of portage/emerge seriously. You could have included a halt-procedure or re-mask the package if something like this hits the tree.
Comment 48 SpanKY gentoo-dev 2011-01-03 03:07:16 UTC
you need to search better.  the bug you're talking about has nothing to do with this one and is already reported/fixed elsewhere.
Comment 49 Silas De Munck 2011-01-10 10:54:23 UTC
Just hit this when upgrading from 8.5 to 8.7 ?

Also running the 2.6.18 xen kernel.

Re-open?
Comment 50 Motosauro 2011-01-11 09:08:40 UTC
Same issue for me:
Everything worked until coreutils was upgraded to 8.7 (last package being merged)
The hacked /bin/touch solves the specific portage related issue, but it doesn't seem like a real solution, just a handy hack

Needs to be reopened 

Linux somehost.some.tld 2.6.18-194.8.1.el5xen #1 SMP Thu Jul 1 19:41:05 EDT 2010 x86_64 Intel(R) Xeon(R) CPU E5420 @ 2.50GHz GenuineIntel GNU/Linux


Portage 2.1.9.25 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.11.2-r3, 2.6.18-194.8.1.el5xen x86_64)
=================================================================
System uname: Linux-2.6.18-194.8.1.el5xen-x86_64-Intel-R-_Xeon-R-_CPU_E5420_@_2.50GHz-with-gentoo-1.12.14
Timestamp of tree: Tue, 11 Jan 2011 01:30:01 +0000
app-shells/bash:     4.1_p7
dev-lang/python:     2.6.4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.65-r1
sys-devel/automake:  1.10.2, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-mno-tls-direct-seg-refs -O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/eselect/postgresql /etc/gconf /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl aio apache2 berkdb bzip2 cjk cli cracklib crypt cups curl cxx dovecot-sasl dri exif fortran ftp gd gdbm gpm iconv imap ipv6 mbox modules mudflap mysql mysqli mysqlnd ncurses nls nptl nptlonly openmp pam pcre pdo perl postgres pppd python readline sasl session snmp soap sockets sqlite sqlite3 ssl sysfs tcpd threads truetype unicode vda x86 xml xmlreader xmlrpc xmlwriter xorg xpm xsl zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Comment 51 dragon 2011-01-12 15:33:46 UTC
Same problem too with 2.6.18-xen kernel and coreutils 8.7
Comment 52 Daniel Robbins 2011-01-12 18:29:51 UTC
Documentation on changes to upstream lib/utimens.c file:

Version        Changes vs. Previous Version

8.5            N/A
8.6            Yes
8.7            No
8.8            No
8.9            Yes

Based on this information, it may be useful to test coreutils-8.9 and see if it resolves the issue. If so, that may be the best solution. If not, then a patch for 8.6+ will likely be required.

Please test coreutils-8.9 and see if it resolves the issue.
Comment 53 dragon 2011-01-13 09:43:17 UTC
8.9 is still wrong :(