Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 223265

Summary: [patch] Allow dev-python/gnome-python-extras to build with xulrunner-1.9
Product: Gentoo Linux Reporter: Peter Sääf <peter.saaf>
Component: New packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED DUPLICATE    
Severity: normal CC: andrey.melentyev, andriy155, jeff.kowalczyk, radhermit, tom.gl
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
URL: http://bugzilla.gnome.org/show_bug.cgi?id=532856
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 213296    
Attachments: xulrunner-1.9 patch
Edited ebuild
libtool-2 patch
Works with xulrunner-1.9 and libtool-2 patch
if non of firefox, xulrunner, seamonkey in USE?

Description Peter Sääf 2008-05-22 21:14:17 UTC
gnome-python-extras fails to build against > xulrunner-1.8.
The attached patch is from upstream bugzilla.
http://bugzilla.gnome.org/show_bug.cgi?id=532856

I'm not sure this is worth while considering the, imminent? split of the python bindings. I'll add this bug as a blocker for bug 108479 since the patch is needed for the split ebuilds as well.

Reproducible: Always

Steps to Reproduce:
Comment 1 Peter Sääf 2008-05-22 21:14:55 UTC
Created attachment 153991 [details, diff]
xulrunner-1.9 patch

patch from http://bugzilla.gnome.org/show_bug.cgi?id=532856
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-05-22 21:29:50 UTC
adding to the tracker
Comment 3 catkfr 2008-06-18 10:33:58 UTC
This should be integrated into portage now that firefox 3.0 is ~arch. I forced the upgrade on my machine and now have this error:

!!! Multiple versions within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

www-client/mozilla-firefox:0

  ('ebuild', '/', 'www-client/mozilla-firefox-2.0.0.14', 'merge') pulled in by
    ('installed', '/', 'dev-python/gnome-python-extras-2.19.1-r1', 'nomerge')
    @world

  ('installed', '/', 'www-client/mozilla-firefox-3.0', 'nomerge') pulled in by
    @world
Comment 4 Mart Raudsepp gentoo-dev 2008-06-19 21:30:05 UTC
Please use system-wide USE=xulrunner to avoid this non-slotted multi-version conflict from USE=firefox until we manage to fix all these in the testing tree.
Comment 5 Pascal Lim 2008-06-20 02:17:00 UTC
I used the patch here and it failed to compile.  I think it's a libtool-2.2.4 related bug.

***** aclocal *****
***** aclocal

configure.ac:203: error: m4_require: circular dependency of AC_LANG_COMPILER(C++)
../../lib/autoconf/lang.m4:271: AC_LANG_COMPILER_REQUIRE is expanded from...
../../lib/autoconf/general.m4:2517: AC_LINK_IFELSE is expanded from...
/usr/share/aclocal/libtool.m4:1018: _LT_SYS_MODULE_PATH_AIX is expanded from...
/usr/share/aclocal/libtool.m4:5318: _LT_LANG_CXX_CONFIG is expanded from...
/usr/share/aclocal/libtool.m4:785: _LT_LANG is expanded from...
/usr/share/aclocal/libtool.m4:768: LT_LANG is expanded from...
../../lib/autoconf/c.m4:769: AC_LANG_COMPILER(C++) is expanded from...
../../lib/autoconf/lang.m4:271: AC_LANG_COMPILER_REQUIRE is expanded from...
../../lib/autoconf/general.m4:2461: AC_COMPILE_IFELSE is expanded from...
configure.ac:203: the top level
autom4te-2.62: /usr/bin/m4 failed with exit status: 1
aclocal-1.10: autom4te failed with exit status: 1

>>> Emerging (1 of 1) dev-python/gnome-python-extras-2.19.1-r1 to /
 * gnome-python-extras-2.19.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...     [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking gnome-python-extras-2.19.1.tar.bz2 ;-) ...                    [ ok ]
>>> Unpacking source...
>>> Unpacking gnome-python-extras-2.19.1.tar.bz2 to /var/tmp/portage/dev-python/gnome-python-extras-2.19.1-r1/work
 * Fixing OMF Makefiles ...                                               [ ok ]
 * Running elibtoolize in: gnome-python-extras-2.19.1
 *   Applying install-sh-1.5.4.patch ...
 *   Applying portage-1.5.10.patch ...
 *   Applying max_cmd_len-1.5.20.patch ...
 *   Applying sed-1.5.6.patch ...
 * Applying gnome-python-extras-xulrunner-1.9.patch ...                   [ ok ]
 * Running eautoreconf in '/var/tmp/portage/dev-python/gnome-python-extras-2.19.1-r1/work/gnome-python-extras-2.19.1' ...
 * Running aclocal ...                                                    [ !! ]

 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/dev-python/gnome-python-extras-2.19.1-r1/temp/aclocal-20613.out

 * 
 * ERROR: dev-python/gnome-python-extras-2.19.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 3074:  Called eautoreconf
 *             environment, line  980:  Called eaclocal
 *             environment, line  919:  Called autotools_run_tool 'aclocal'
 *             environment, line  470:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  The die message:
 *   Failed Running aclocal !


Comment 6 Pascal Lim 2008-06-20 02:26:01 UTC
Created attachment 157699 [details]
Edited ebuild

Actually, I forgot to edit the firefox dependency. Uploaded edited ebuild
Comment 7 Pascal Lim 2008-06-20 02:28:06 UTC
Comment on attachment 157699 [details]
Edited ebuild

><HTML><HEAD/><BODY><PRE># Copyright 1999-2008 Gentoo Foundation
># Distributed under the terms of the GNU General Public License v2
># $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild,v 1.13 2008/06/02 21:06:04 eva Exp $
>
>inherit eutils gnome2 python virtualx autotools
>
>DESCRIPTION="GNOME 2 Bindings for Python"
>HOMEPAGE="http://www.pygtk.org"
>
>LICENSE="LGPL-2"
>SLOT="0"
>KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
>IUSE="doc firefox seamonkey xulrunner"
>
>RDEPEND="&gt;=x11-libs/gtk+-2.4
>	&gt;=dev-libs/glib-2.6
>	&gt;=dev-python/gnome-python-2.10
>	&gt;=dev-python/pygtk-2.4
>	=gnome-extra/gtkhtml-2*
>	xulrunner? ( &gt;=net-libs/xulrunner-1.9* )
>	!xulrunner? ( firefox? ( =www-client/mozilla-firefox-3* ) )
>	!xulrunner? ( !firefox? ( seamonkey? ( =www-client/seamonkey-1* ) ) )
>	&gt;=app-text/gtkspell-2"
>	# =gnome-extra/libgda-3*
>	# This used to be wrongly libgda-1*, but as configure is automagic,
>	# it just didn't build libgda bindings before as libgda-3 is p.masked.
>	# Leaving it automagic and dep lacking as there are no notable users of
>	# these bindings as testified by the lack of bug reports for this
>	# breakage. Should be fixed after libgda-3 gets unmasked or this ebuild
>	# is split into many per bug 108479
>
>DEPEND="${RDEPEND}
>	dev-util/pkgconfig"
>
>DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
>
># Tests are broken and not that useful anyway, see bug #209846
>RESTRICT="test"
>
>pkg_setup() {
>	# only controls linking, can't disable w/o a patch :)
>	if use xulrunner; then
>		G2CONF="${G2CONF} --with-gtkmozembed=xulrunner"
>	elif use firefox; then
>		G2CONF="${G2CONF} --with-gtkmozembed=firefox"
>	elif use seamonkey; then
>		G2CONF="${G2CONF} --with-gtkmozembed=seamonkey"
>	fi
>}
>
>src_unpack() {
>	gnome2_src_unpack
>
>       # Build against xulrunner-1.9 
>	epatch "${FILESDIR}"/${PN}-xulrunner-1.9.patch
>
>	# change mozilla to seamonkey
>	sed -i -e 's:1.2b):1.0.0):;s:mozilla):seamonkey):' configure.ac
>
>	# disable pyc compiling
>	mv py-compile py-compile.orig
>	ln -s $(type -P true) py-compile
>
>	eautoreconf
>}
>
>src_test() {
>	Xemake check || die "tests failed"
>}
>
>src_install() {
>	gnome2_src_install
>
>	if use doc; then
>		insinto /usr/share/doc/${PF}
>		doins -r examples
>	fi
>}
>
>pkg_postinst() {
>	python_version
>	python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
>}
>
>pkg_postrm() {
>	python_version
>	python_mod_cleanup "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
>}
></PRE></BODY></HTML>
Comment 8 Pascal Lim 2008-06-20 02:29:48 UTC
Sorry for making a mess, not used to bugzilla yet.. :$
Comment 9 W. Elschner 2008-07-01 12:34:17 UTC
(In reply to comment #5)
> I used the patch here and it failed to compile.  I think it's a libtool-2.2.4
> related bug.

Yes,and it is quite trivial to solve this problem. In configure.ac you have to add a line AC_PROG_CXX. I just attached a patch for this (has to be save in  local directory dev-python/gnome-python-extras/files) and an ebuild that works for me.
Comment 10 W. Elschner 2008-07-01 12:35:39 UTC
Created attachment 159117 [details, diff]
libtool-2 patch 

Patch for libtool 2.2
Comment 11 W. Elschner 2008-07-01 12:36:43 UTC
Created attachment 159119 [details]
Works with xulrunner-1.9 and libtool-2 patch
Comment 12 Andrés Becerra Sandoval 2008-07-16 16:09:41 UTC
(In reply to comment #11)
> Created an attachment (id=159119) [edit]
> Works with xulrunner-1.9 and libtool-2 patch
> 

It works for me too.
Comment 13 Giuseppe Marco Randazzo <zeld> 2008-10-03 10:21:14 UTC
i give this error  on amd 64 :S


mv -f ".libs/gtkmozembed.expT" ".libs/gtkmozembed.exp"
x86_64-pc-linux-gnu-g++ -shared -nostdlib /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.1/../../../../lib64/crti.o /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.1/crtbeginS.o  .libs/gtkmozembedmodule.o .libs/gtkmozembed.o  -L/usr/lib64/xulrunner-1.9/lib /usr/lib64/libgtk-x11-2.0.so /usr/lib64/libgdk-x11-2.0.so /usr/lib64/libatk-1.0.so -L/usr/lib64 /usr/lib64/libgdk_pixbuf-2.0.so /usr/lib64/libpangocairo-1.0.so /usr/lib64/libpango-1.0.so /usr/lib64/libcairo.so /usr/lib64/libgobject-2.0.so /usr/lib64/libgmodule-2.0.so -ldl /usr/lib64/libglib-2.0.so -lxpcomglue -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.1 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.1/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.1/../../../../x86_64-pc-linux-gnu/lib -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.1/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.1/crtendS.o /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.1/../../../../lib64/crtn.o  -march=k8 -msse3 -Wl,-O1 -Wl,-soname -Wl,gtkmozembed.so -Wl,-retain-symbols-file -Wl,.libs/gtkmozembed.exp -o .libs/gtkmozembed.so
.libs/gtkmozembed.o: In function `_wrap_gtk_moz_embed_push_startup':
gtkmozembed.c:(.text+0x6): undefined reference to `gtk_moz_embed_push_startup'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.1/../../../../x86_64-pc-linux-gnu/bin/ld: .libs/gtkmozembed.o: relocation R_X86_64_PC32 against `gtk_moz_embed_push_startup' can not be used when making a shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.1/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
make[2]: *** [gtkmozembed.la] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-python/gnome-python-extras-2.19.1-r3/work/gnome-python-extras-2.19.1/gtkmozembed'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-python/gnome-python-extras-2.19.1-r3/work/gnome-python-extras-2.19.1'
make: *** [all] Error 2
 * 
 * ERROR: dev-python/gnome-python-extras-2.19.1-r3 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3111:  Called gnome2_src_compile
 *             environment, line 2326:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-python/gnome-python-extras-2.19.1-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/gnome-python-extras-2.19.1-r3/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/'
 * 

 * Messages for package dev-python/gnome-python-extras-2.19.1-r3:

 * 
 * ERROR: dev-python/gnome-python-extras-2.19.1-r3 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3111:  Called gnome2_src_compile
 *             environment, line 2326:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-python/gnome-python-extras-2.19.1-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/gnome-python-extras-2.19.1-r3/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/'

Comment 14 Dmitri Bogomolov 2008-10-27 16:13:18 UTC
Created attachment 170010 [details]
if non of firefox, xulrunner, seamonkey in USE?
Comment 15 Gilles Dartiguelongue gentoo-dev 2008-11-29 23:46:30 UTC
we won't patch the monolithic package/ebuild at this point, please check gtkmozembed-python.

*** This bug has been marked as a duplicate of bug 247098 ***
Comment 16 Gilles Dartiguelongue gentoo-dev 2008-11-29 23:53:37 UTC
*** Bug 232354 has been marked as a duplicate of this bug. ***