Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 221275

Summary: net-ftp/proftpd-1.3.1 fails to build because of libtool-2.2
Product: Gentoo Linux Reporter: Konstantin Sobolev <konstantin.sobolev>
Component: Current packagesAssignee: Luca Longinotti (RETIRED) <chtekk>
Status: RESOLVED FIXED    
Severity: normal CC: alexxy, andrei.ivanov, creideiki+gentoo-bugzilla, m.debruijne, michael, modelnine, net-ftp, patrizio.bassi, pqGungnir, telefrancisco
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 212763    
Attachments: build log
Recreation of ac*.m4 for newer libtool-versions
proftpd-1.3.1_ebuild.patch

Description Konstantin Sobolev 2008-05-10 21:29:25 UTC
./libtool: line 454: CDPATH: command not found
./libtool: line 1146: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
Comment 1 Konstantin Sobolev 2008-05-10 21:30:01 UTC
Created attachment 152777 [details]
build log
Comment 2 Konstantin Sobolev 2008-05-10 21:30:40 UTC
Portage 2.1.5_rc7 (default-linux/amd64/2007.0, gcc-4.2.3, glibc-2.7-r2, 2.6.24-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.24-gentoo-r3 x86_64 Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
Timestamp of tree: Wed, 07 May 2008 22:00:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r11, 2.5.2-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.KOI8-R"
LC_ALL=""
LDFLAGS=""
LINGUAS="en ru"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/ion-overlay /usr/portage/local/kos-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X a52 aac aalib acl acpi alsa amd64 amr amrnb amrwb bash-completion berkdb bittorrent bl bsf bzip2 cairo cdda cddb cdio cdparanoia cli cracklib crypt cscope css cups curl db dbus deprecated dga discouraged djvu dri dts dv dvd dvdr dvdread enca encode exif expat extensions extrafiles extras fam fame fbcon ffmeg ffmpeg firefox flac fontconfig fortran ftp fuse gd gdbm gif gimp glib glitz gnutls gphoto2 gpm graphvis graphviz gs gtk guile hal hddtemp hdri iconv imagemagick imlib inkjar isdnlog java javascript jbig jpeg jpeg2k kde kipi lame latex lcms libcaca libnotify libsamplerate live logitech-mouse lua lzo mad mbox midi mikmod mjpeg mmap mmx mmxext mng mnt mouse mozdevelop mp2 mp3 mpeg mudflap multiuser musepack ncurses nemesi network networking nls nntp nptl nptlonly nsplugin ogg openal opengl openmp pam pango pcre pdf perl png pnm pppd pulseaudio pvr python qt3 qt3support qt4 quicktime rar rdesktop readline reflection rtc rtsp ruby samba sbcl scenarios sdl search-screen session sidebar slang slp smime smp sndfile speex spell spl sqlite srt sse sse2 sse3 ssl ssse3 stream svg tcpd tga theora threads tiff timidity tivo truetype twolame unicode usb utf8 vcd vcdx vim-pager vim-syntax vim-with-x vncviewer vorbis wavpack wmf wxwindows x264 xanim xcomposite xinetd xml xorg xpm xv xvid xvmc xvnc zlib zlo zoran" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x      ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3     trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa vga s3"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Rafał Mużyło 2008-05-10 22:04:15 UTC
The problem is aclocal.m4.
It's not autogenerated and most of it is (old) libtool.m4, only macros above 
# libtool.m4 - Configure libtool for the host system. -*-Autoconf-*-
line are custom (the PR_*)
It has to be fixed upstream.
For the time being, something like this could be done:
cat the lines up to # libtool.m4 into acinclude.m4
rm aclocal.m4
before running eautoreconf.
Comment 4 Michael Brakemeier 2008-06-15 14:36:24 UTC
Suggested solution from comment #3 works fine here.
Attached changed ebuild.

Portage 2.1.5.5 (default/linux/x86/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 i686)
=================================================================
System uname: 2.6.25-gentoo-r4 i686 Intel(R) Pentium(R) M processor 1.86GHz
Timestamp of tree: Sun, 15 Jun 2008 12:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -mtune=pentium-m -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium-m -mtune=pentium-m -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://192.168.0.43/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://mirror.qubenet.net/mirror/gentoo/ http://mirror.uni-c.dk/pub/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LDFLAGS=""
[...]
Comment 5 Michael Brakemeier 2008-06-15 14:38:39 UTC
Created attachment 156921 [details]
Recreation of ac*.m4 for newer libtool-versions
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-16 13:44:04 UTC
*** Bug 227421 has been marked as a duplicate of this bug. ***
Comment 7 Alexey Shvetsov gentoo-dev 2008-07-10 14:23:43 UTC
(In reply to comment #5)
> Created an attachment (id=156921) [edit]
> Recreation of ac*.m4 for newer libtool-versions
> 

This ebuild works for me =)
Comment 8 Steven Wallace 2008-07-11 15:18:35 UTC
Created attachment 160122 [details, diff]
proftpd-1.3.1_ebuild.patch

This is mostly the same bug as  #213805.  The solution there is also applicable.  I attached a patch which fixes it.
Comment 9 Patrizio Bassi 2008-07-30 21:46:52 UTC
can you apply to portage?
Comment 10 David Voge 2008-08-08 22:37:17 UTC
(In reply to comment #5)
> Created an attachment (id=156921) [edit]
> Recreation of ac*.m4 for newer libtool-versions
> 

works ;) can this added in portage?
Comment 11 rafnov 2008-09-28 14:41:31 UTC
Aparently it CAN'T, cause we've been waiting more than 2 months and it still isn't fixed for now.

=> making cap_names.c from <linux/capability.h>
xgettext: błąd w czasie otwierania "../modules/module_glue.c" do czytania: Nie ma takiego pliku ani katalogu
msginit: unrecognized option '--sort-by-file'
Polecenie `msginit --help' poda więcej informacji.
msgfmt: błąd w czasie otwierania "en_US.po" do czytania: Nie ma takiego pliku ani katalogu
./libtool: line 454: CDPATH: command not found
./libtool: line 1146: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.6, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6
libtool: and run autoconf again.
make: *** [proftpd] Błąd 63
Comment 12 David Bařina 2008-10-03 21:12:15 UTC
(In reply to comment #5)
> Created an attachment (id=156921) [edit]
> Recreation of ac*.m4 for newer libtool-versions
> 

works fine also here
Comment 13 Benjamin Hodgetts 2008-10-04 09:02:11 UTC
This is incredibly annoying not being able to install proftpd without patching an ebuild or other files first. Is there any reason why this hasn't been fixed in portage yet?
Comment 14 crucify 2008-10-21 13:13:35 UTC
this patch work cool.
why not fix portage?
patch uploaded 3 month ago.
Comment 15 crucify 2008-10-21 13:35:42 UTC
I wish portage committer.
I promise missing keyword commit only.
please, give me permission.
I commit this proftpd ebuild to -r1 missing.
and parprouted ebuild too.
Comment 16 Francisco José Cañizares Santofimia 2008-11-02 18:23:50 UTC
(In reply to comment #15)
> I wish portage committer.
> I promise missing keyword commit only.
> please, give me permission.
> I commit this proftpd ebuild to -r1 missing.
> and parprouted ebuild too.
> 

No need to -r1 as this fixes a ebuild that does not compile for some people (-r1 will be only required if you want everybody to rebuild their programs for some reason -for example a secuirty threat-). 

However, the new ebuild allows me to compile proftpd fine, too :)
Comment 17 Christian Hoffmann (RETIRED) gentoo-dev 2008-11-10 20:39:14 UTC
Fixes should be in =proftpd-1.3.1-r1 and =proftpd-1.3.2_rc2-r2. The first should be marked stable really soon for security reasons.
I chose to use another fix, btw.