Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 21709

Summary: gtk and gtk2 flags (xchat specific)
Product: Gentoo Linux Reporter: André Lemos <tux>
Component: New packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: VERIFIED INVALID    
Severity: normal CC: andrewresch, chrishornbaker
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description André Lemos 2003-05-26 09:17:54 UTC
The x-chat ebuild has the gtk has use flag, and it should have gtk2.

I had already noticed this, but someone from the dev team, said that the gtk2
wasn't a "official" use flag.

So now I ask.. Why does vim has gtk/gtk2? Or xscreensaver?

Is this really in fact a mistaque with xchat2's ebuild, or is there any other
policy that I'm not familiar with?

Please enlighten me on this issue.

Thanks
Comment 1 Alastair Tse (RETIRED) gentoo-dev 2003-05-26 16:44:22 UTC
if you read the descriptions of the gtk and gtk2 flags (in /usr/portage/profiles/use.desc), you'll understand why. it interesting that "someone from the dev team" said it wasn't an official use flag .. i wonder why because it is clearly in /usr/portage/profiles/use.desc.

i'll leave it as an exercise for you to figure out why we use gtk instead of gtk2 :)
Comment 2 André Lemos 2003-05-26 19:54:14 UTC
Ok, I got it, thanks for pointing out to the right direction.

But tell me something. If you have the gtk AND gtk2 use flags, will the ebuild chose gtk2?
Comment 3 Alastair Tse (RETIRED) gentoo-dev 2003-05-27 04:58:11 UTC
if you have the gtk flag, it will build the gui. there is only the gtk2 gui with xchat-2.x.
Comment 4 André Lemos 2003-05-27 09:03:26 UTC
That's not what I meant.

Lets say...

USE="gtk gtk2" emerge xscreensaver

What would happen? Would it only emerge the gtk2 version? Both? (???) or the gtk version?
Comment 5 Alastair Tse (RETIRED) gentoo-dev 2003-05-27 09:27:47 UTC
you should try it then .. 

each package is different so i can't answer your question for all packages. again, if there is a gtk2 version it will choose that over the gtk1 version, that is what the useflag description says. if there is only one version, having "gtk2" will not affect anything.
Comment 6 André Lemos 2003-05-27 11:14:43 UTC
OK, thanks! That's what I wanted to know
Comment 7 Alastair Tse (RETIRED) gentoo-dev 2003-06-01 06:36:26 UTC
*** Bug 22019 has been marked as a duplicate of this bug. ***
Comment 8 Alastair Tse (RETIRED) gentoo-dev 2003-06-12 13:09:07 UTC
*** Bug 22681 has been marked as a duplicate of this bug. ***