Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 215667

Summary: Ebuild-Request for CrossOver Games
Product: Gentoo Linux Reporter: Dennis Winter <d.w.79>
Component: New packagesAssignee: Wine Maintainers <wine>
Severity: enhancement CC: Ejdesgaard, hjcaton, josh.caltagirone.holzli, kuch3n, m.debruijne, mailingdotlist, marshall.mcmullen, pacho, ryao, stupendoussteve
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on: 463420    
Bug Blocks:    
Attachments: crossover-games-7.0.0.ebuild
Manifest for crossove-games-bin-7.1.2
Ebuild for CrossOver Games Linux 9.1.0
Ebuild for CrossOver Games Linux 9.2.1
Ebuild for CrossOver Games Linux 10.1.0
Ebuild for CrossOver Games Linux 10.1.0

Description Dennis Winter 2008-04-01 06:21:58 UTC
Other than CX Office some programs need CX Games to run.

Here an example:

Reproducible: Always
Comment 1 SpanKY gentoo-dev 2008-04-19 22:22:34 UTC
Created attachment 150333 [details]
Comment 2 stupendoussteve 2008-10-28 21:08:50 UTC
Created attachment 170158 [details]

Builds full version of crossover-games-7.1.2

Requires in /usr/portage/distfiles

ebuild is based on crossover-office-pro-bin
Comment 3 stupendoussteve 2008-10-28 21:09:25 UTC
Created attachment 170159 [details]
Manifest for crossove-games-bin-7.1.2
Comment 4 Sergey Belyashov 2008-11-01 08:06:19 UTC
Created attachment 170439 [details]

added creating of desktop entry for cxsetup
Comment 5 james 2010-09-02 10:30:54 UTC
any chance we can get the newest CXgames? it's now 9.1.0
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2010-10-17 23:48:06 UTC
*** Bug 341145 has been marked as a duplicate of this bug. ***
Comment 7 Aniruddha 2010-10-18 10:02:03 UTC
Created attachment 251111 [details]
Ebuild for CrossOver Games Linux 9.1.0
Comment 8 Joshua 2011-01-05 22:48:33 UTC
Created attachment 258986 [details]
Ebuild for CrossOver Games Linux 9.2.1
Comment 9 Marshall McMullen 2011-02-01 16:01:52 UTC
Now 10.0 is out. They now provide a *.bin instead of a *.sh. Simply copying the build from 9.2.1 to 10.0.0 does not work. The ebuild fails on the "unpack_makeself" as it's not a makeself file anymore. I tried running it by hand, but it complains that the prior install was not created by the GUI installer and that I should remove it first...

If anyone makes any headway on this, please advise...
Comment 10 Joshua 2011-04-11 00:35:12 UTC
I am still trying to work on this.  To install the binary, it works by hand, but as for getting portage to do it, I have been unsuccessful...  I will post if I ever get it working.
Comment 11 Joshua 2011-04-11 01:59:04 UTC
Created attachment 269435 [details]
Ebuild for CrossOver Games Linux 10.1.0

This ebuild uses the rpm file... I cannot get an ebuild to work using the .bin file...
Comment 12 Marshall McMullen 2011-04-11 02:09:43 UTC

I don't think it matters if it uses the bin or rpm... at least we have an option now!

Thanks for your work Joshua!
Comment 13 Joshua 2011-04-11 02:14:43 UTC
Created attachment 269437 [details]
Ebuild for CrossOver Games Linux 10.1.0

Fixes the cxgames.conf files not being created.
Comment 14 Richard Yao (RETIRED) gentoo-dev 2012-02-27 22:07:58 UTC
Created attachment 303545 [details]

I posted an ebuild for app-emulation/crossover-office-pro-bin-10.2.0 to bug #400897, so I thought it might be a good idea to post a corresponding one to this bug too.

As I said in the other bug, I tried using the scripts that are supposed to generate the menus, but they do not work inside the sandbox. The menus themselves probably should be copied from ${FILESDIR}, but I put them in the ebuild itself to avoid attaching a bunch of files.

Also, the "User Documentation" menu option is not accessible. The make_desktop_entry function from eutils.eclass does not appear to be able to handle arguments to the command. I have some ideas for ways of extending the eutils.eclass to fix the menu issues, but it is easier to post an ebuild now and extend the eclass at some point in the future.
Comment 15 Richard Yao (RETIRED) gentoo-dev 2013-03-27 18:24:27 UTC
Crossover Games was discontinued in the name of product consolidation. What was once Crossover Standard, Crossover Office Professional and Crossover games is now simply Crossover as of version 11.

I have committed app-emulation/crossover-bin-12.1.2 to the tree to reflect the consolidated product line. That should take care of this bug, unless someone really wants the older Crossover Games.