Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 215179

Summary: www-servers/tomcat-6.0.16 - /usr/share/tomcat-6/lib/tomcat-dbcp.jar missing
Product: Gentoo Linux Reporter: James A Shepherd <spam123>
Component: [OLD] ServerAssignee: William L. Thomson Jr. (RETIRED) <wltjr>
Status: RESOLVED DUPLICATE    
Severity: normal CC: java
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description James A Shepherd 2008-03-28 13:10:21 UTC
/usr/share/tomcat-6/lib/tomcat-dbcp.jar missing from www-servers/tomcat-6.0.16

It is present in the apache distribution and is necessary for connecting to a datasource - for example a database.

In particular the class org.apache.tomcat.dbcp.dbcp.BasicDataSourceFactory is needed.

Reproducible: Always

Steps to Reproduce:
1. Start tomcat
2. look in /var/log/tomcat-6/catalina.out for the error

28-Mar-2008 12:09:45 org.apache.catalina.core.NamingContextListener addResource
WARNING: Failed to register in JMX: javax.naming.NamingException: Could not create resource factory instance [Root exception is java.lang.ClassNotFoundException: org.apache.tomcat.dbcp.dbcp.BasicDataSourceFactory]


Actual Results:  
Downloading the vanilla tomcat from apache.org and symlinking in the jar solves the problem


Note I believe that that above jar is NOT the same as commons-dbcp.jar, that is the class mentioned above is not therein. Tomcat repackages the classes (literaly :-) they have different package names.
Comment 1 William L. Thomson Jr. (RETIRED) gentoo-dev 2008-03-28 14:11:17 UTC
(In reply to comment #0)
>
> Note I believe that that above jar is NOT the same as commons-dbcp.jar, that is
> the class mentioned above is not therein. Tomcat repackages the classes
> (literaly :-) they have different package names.

Look at the sources it is, they do some minor tweaks including renaming the package. It's quite stupid, and has been commented on by upstream. This is a known long time bug. Also mentioned on the Tomcat Guide, both 5.5 and 6.
 



*** This bug has been marked as a duplicate of bug 144276 ***