Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 21438

Summary: baselayout boot message: xargs environment too large for exec
Product: Gentoo Linux Reporter: tuXXer <>
Component: [OLD] Core systemAssignee: Martin Schlemmer (RETIRED) <azarah>
Severity: normal CC: andrewbevitt, bsolar17,, cretin, dao.steven, jrmalaq, ltskinol, mark, mholzer, moixa, narada.sage, pcmoore, pfeifer
Priority: High    
Version: 1.4_rc4   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on: 23569, 31794    
Bug Blocks:    
Attachments: One of many numerous patches

Description tuXXer 2003-05-21 14:55:09 UTC
Well, the network devices works now, but on boot process I get now the message xargs 
environment too large for exec when trying cleaning of /var/run and /var/lock. It seems 
that the result is too large for xargs to handle with.
Comment 1 Jonathan Heaney 2003-05-22 11:11:25 UTC
Same happens here.  At least the network works now. Sticking with for now.
Comment 2 merwan kashouty 2003-05-22 20:38:01 UTC
i am getting this too the error is,
*Cleaning /var/lock, /var/run....
xargs: environment is too large for exec

i also have bootsplash and get this

*Caching service dependancies....
*Services 'bootsplash' and 'local' have circular
*dependancy of a type 'iafter'; continuing.....

Comment 3 Rodney Brown 2003-05-25 10:41:57 UTC
Getting same error here, just install 1.4_rc4 from stage 1.  No problems with 
networking though, just the xargs error... 
Comment 4 Martin Schlemmer (RETIRED) gentoo-dev 2003-05-26 15:56:32 UTC
Already fixed in cvs a few days back:

Index: init.d/bootmisc
RCS file: /home/cvsroot/gentoo-src/rc-scripts/init.d/bootmisc,v
retrieving revision 1.29
retrieving revision 1.30
diff -u -r1.29 -r1.30
--- init.d/bootmisc	12 May 2003 21:23:05 -0000	1.29
+++ init.d/bootmisc	21 May 2003 18:55:58 -0000	1.30
@@ -1,7 +1,7 @@
 # Copyright 1999-2003 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /home/cvsroot/gentoo-src/rc-scripts/init.d/bootmisc,v 1.29 2003/05/12 21:23:05 azarah Exp $
+# $Header: /home/cvsroot/gentoo-src/rc-scripts/init.d/bootmisc,v 1.30 2003/05/21 18:55:58 azarah Exp $
 depend() {
@@ -27,7 +27,7 @@
 			eend 0
-		if [ -x /sbin/ ]
+		if [ -x /sbin/ ]
 			ebegin "Updating environment"
 			/sbin/ >/dev/null
Comment 5 Norberto Bensa 2003-05-28 00:22:57 UTC
It's not fixed. I just patched bootmisc, and I get the same message: 
*Cleaning /var/lock, /var/run.... 
xargs: environment is too large for exec 
Comment 6 Narada Sage 2003-06-04 06:53:29 UTC
The xargs issue is still present on both my machines.  It exists at bug 21827 and is assigned to kernel team which puzzles me as I thought it was a baselayout issue.  Anyway, the following forum post discusses the problem very briefly.
Comment 7 Alberto Ornaghi 2003-06-20 13:31:40 UTC
the line 

 ebegin "Cleaning /var/lock, /var/run"
      ( find /var/lock -type f -print0 | xargs -0 rm -f -- 1>&2 )

can be changed to:

 ebegin "Cleaning /var/lock, /var/run"
      ( find /var/lock -type f -exec rm -f {} \; )

so xargs is to involved and the warning is not displayed.
can this patch be acceptable for you ?

Comment 8 tuXXer 2003-06-20 17:45:12 UTC
Well, when the whole functionality keeps available, it should be good. I didn't try it, yet 
(because of lack of time). 
Comment 9 Martin Schlemmer (RETIRED) gentoo-dev 2003-06-22 12:42:58 UTC
Bleh, ok, I had it fixed local, sorry.
Comment 10 Martin Schlemmer (RETIRED) gentoo-dev 2003-06-22 15:09:34 UTC
*** Bug 23268 has been marked as a duplicate of this bug. ***
Comment 11 Martin Schlemmer (RETIRED) gentoo-dev 2003-06-23 13:14:07 UTC
*** Bug 22637 has been marked as a duplicate of this bug. ***
Comment 12 Tobias Sager 2003-06-24 08:53:45 UTC
This is still not fixed in (in the meantime stable-marked) baselayout-!
Comment 13 Tom Collins 2003-06-26 20:52:01 UTC
Not fixed for me either with 2.4.20-r5 kernel.  I suggest reopening it,
and applying this patch to create a 4.1.7-r5 version of findutils:
Comment 14 Jay Pfeifer (RETIRED) gentoo-dev 2003-06-27 14:25:39 UTC
*** Bug 21827 has been marked as a duplicate of this bug. ***
Comment 15 pasi.valminen 2003-06-30 23:03:13 UTC
It's definitely not fixed. Installed rc4 from stage1 yesterday and it's still there.
Comment 16 Toralf Förster gentoo-dev 2003-07-08 01:52:33 UTC
the command 
$>find /var/lock -type f -exec rm -f -- {} \; 1>&2  
will also delete files like ".keep", here is an example: 
$>find /var/lock -type f 
Comment 17 Tobias Sager 2003-07-08 02:01:20 UTC
find /tmp -type f -not -name .keep -exec rm -f {} \;

would solve this.
Comment 18 Donnie Berkholz (RETIRED) gentoo-dev 2003-07-09 09:07:47 UTC
This may provide a solution that allows us to keep using xargs, posted recently to the gentoo-user ML.

On Tuesday 08 July 2003 21:37, James H. Cloos Jr. wrote:
> >>>>> "Rex" == Rex Walters <> writes:
> Rex> This definitely fixes the error but I'm curious why the first
> Rex> version doesn't work?  Seems like a bug in gnu find or xargs to
> Rex> me -- the fix is really more of a workaround.
> In xargs.  One of the notes on that tree of bugzilla ids references
> an email sent to one of the gnu mail lists.  The bug is that xargs'
> test for the size of the env comes before the args are parsed; the
> arg -s allows the env to be elarged, but xargs fails to take that
> into consideration before bailing out.
> The error only shows up at boot because the rc process must be
> creating an env larger than 20k.  Once booted your shell has a
> much smaller env.  (Mine is just under 3k.)
> -JimC
> --
> mailing list
Comment 19 Carter 2003-07-25 01:02:46 UTC
Created attachment 14987 [details, diff]
One of many numerous patches

I added bug 24993 which accidently was a duplicate of this bug, but it contains
an easir fix than some of the ones described here.  For that reason patch was
checked.  Can someone please explain why this 20k limit is even needed on
modern era pcs?

Email with an answer... I'm curious
Comment 20 Andreas Schwarz 2003-08-03 05:39:45 UTC
The bug does still exist, why is this closed?
Comment 21 Narada Sage 2003-08-03 13:25:37 UTC
Baselayout was updated recently to  This was intended as a bugfix release I'm told and took care of many bugs including the xargs error.  Please update, replace /etc/init.d/bootmisc using etc-update and test again.  It worked for me.
Comment 22 Martin Holzer (RETIRED) gentoo-dev 2003-08-20 08:19:33 UTC
closed, see bug #23569 for more details
Comment 23 Brandy Westcott (RETIRED) gentoo-dev 2003-09-11 08:46:20 UTC
*** Bug 28425 has been marked as a duplicate of this bug. ***
Comment 24 Georgi Georgiev 2003-09-17 20:28:16 UTC
A diff between revisions 1.29 and 1.33 of bootmisc reveals:

-               ( find /var/lock -type f -print0 | xargs -0 rm -f -- 1>&2 )
+               ( find /var/lock -type f -exec rm -f -- {} \; )

What happened to the comment about .keep?

I decided to through my suggestion in here as well (I know it's fixed already, but I like the xargs pipe).

-               ( find /var/lock -type f -print0 | xargs -0 rm -f -- 1>&2 )
+               ( find /var/lock -type f -print0 | env - xargs -0 rm -f -- 1>&2 )