Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 213296 (xul-1.9)

Summary: [TRACKER] net-libs/xulrunner-1.9
Product: Gentoo Linux Reporter: Raúl Porcel (RETIRED) <armin76>
Component: [OLD] DevelopmentAssignee: Mozilla Gentoo Team <mozilla>
Status: RESOLVED FIXED    
Severity: normal CC: enyawix, gentoo, kevin.bowling, leio, marlon122, mpagano, n-roeser, nirbheek, pacho, sebastian, theli.ua
Priority: High Keywords: Tracker
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 204632, 213344, 213361, 213365, 213372, 213375, 213379, 213461, 213463, 213467, 223265, 228285, 228417, 228717, 230900, 247098    
Bug Blocks:    

Description Raúl Porcel (RETIRED) gentoo-dev 2008-03-13 18:40:40 UTC
Stuff that needs to be fixed for xul-1.9 to enter the tree.

All packages depending on net-libs/xulrunner should depend on =net-libs/xulrunner:1.8(EAPI-1), and if you are interested, port it to use xul-1.9, as it won't work at all with it.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-03-13 22:48:34 UTC
Erm, once again - how about we leave this thing package.masked until it grows some compatibility w/ other stuff, as opposed to yet another pointless slotting of a package that's not designed to be slotted at all...
Comment 2 Nirbheek Chauhan (RETIRED) gentoo-dev 2008-03-14 07:32:23 UTC
(In reply to comment #1)
> Erm, once again - how about we leave this thing package.masked until it grows
> some compatibility w/ other stuff, as opposed to yet another pointless slotting
> of a package that's not designed to be slotted at all...
> 

As per discussion on IRC, we don't know when all the apps that are broken with xul-1.9 will be fixed, and people will be clamouring for ff3 as soon as it is released (when is something which we also don't know). Plus, newer apps that use/will use xulrunner will probably not be compatible with xul-1.8 if and when they start using xul-1.9

So adding xulrunner-1.9 to tree is inevitable, and keeping xulrunner-1.8 around for a (long?) while is inevitable as well.

Hence, slotting and tracking.
Comment 3 Mart Raudsepp gentoo-dev 2008-03-14 11:51:46 UTC
Raúl, did you figure out what needs to be done regarding the pkgconfig .pc file conflict? Do we need to patch configure.in to check for a versioned .pc file for 1.9 too, or what?
Comment 4 Raúl Porcel (RETIRED) gentoo-dev 2008-03-14 15:12:34 UTC
(In reply to comment #3)
> Raúl, did you figure out what needs to be done regarding the pkgconfig .pc
> file conflict? Do we need to patch configure.in to check for a versioned .pc
> file for 1.9 too, or what?
> 

Yes, atm the pkgconfig files are set as xulrunner-1.9-$thing, and 1.8 is xulrunner-$thing.

But before that is done, all the working ebuilds need to be set at =net-libs/xulrunner-1.8*, and stuff depending on firefox should be set as =www-client/mozilla-firefox-2*
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2008-03-15 11:07:50 UTC
(In reply to comment #2)

Seriously; 4 out of 9 apps tracked here ATM already have patches or releases available for xulrunner-1.9 compatibility. Please give the thing some time before jumping on completely wrong bandwagon.
Comment 6 Nirbheek Chauhan (RETIRED) gentoo-dev 2008-03-21 18:26:43 UTC
Roight, so the current state of affairs is that xulrunner-1.9 is already slotted by upstream, and we were the ones renaming the pkgconfig files and unslotting it. OTOH, the new xulrunner-1.9 has renamed the pkgconfig files from xulrunner-* to mozilla-*, so there is no extra work to be done for slotting.

Any applications that claim to work with 1.9 must use the new pkgconfig files, and any apps that already work with 1.9 will fix their configure eventually for 1.9 compat (or their configure should be fixed and pushed upstream).

So, xul-1.8 is slotted now, and so is 1.9 (as upstream intended).

If your app works with 1.9, make sure it works with >=xulrunner-1.9_beta4-r2 from the mozilla overlay. (configure problems might need to be patched)

If your app doesn't work with 1.9, make it dep on =xulrunner-1.8* or xulrunner:1.8 (eapi=1) till a 1.9-compatible release is released.
Comment 7 Kevin Bowling 2008-03-27 01:49:41 UTC
As usual, the Fedora crew is blazing trails and keeping things moving the right direction in Linux land.  I really miss Gentoo leading the pack :-(.

http://fedoraproject.org/wiki/Features/XULRunner
Comment 8 Raúl Porcel (RETIRED) gentoo-dev 2008-03-27 12:32:23 UTC
(In reply to comment #7)
> As usual, the Fedora crew is blazing trails and keeping things moving the right
> direction in Linux land.  I really miss Gentoo leading the pack :-(.
> 
> http://fedoraproject.org/wiki/Features/XULRunner
> 

If you want to take care of Mozilla stuff in Gentoo, please do so. I just do this stuff because nobody else wants to, and no, i don't like to do it.
Comment 9 wayne 2009-02-23 01:52:49 UTC
(In reply to comment #8)

I also miss gentoo leading the pack. If some one was to make a place to work on ebuilds without being controlled be the admins I would volunteer to help. A bleeding edge "use at your own risk!" overlay would be nice. http://bugs.gentoo.org must have hundreds of ebuilds with out a home.

> (In reply to comment #7)
> > As usual, the Fedora crew is blazing trails and keeping things moving the right
> > direction in Linux land.  I really miss Gentoo leading the pack :-(.
> > 
> > http://fedoraproject.org/wiki/Features/XULRunner
> > 
> 
> If you want to take care of Mozilla stuff in Gentoo, please do so. I just do
> this stuff because nobody else wants to, and no, i don't like to do it.
> 

Comment 10 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-02-23 17:49:31 UTC
(In reply to comment #9)
> (In reply to comment #8)
> 
> I also miss gentoo leading the pack. If some one was to make a place to work on
> ebuilds without being controlled be the admins I would volunteer to help. A
> bleeding edge "use at your own risk!" overlay would be nice.
> http://bugs.gentoo.org must have hundreds of ebuilds with out a home.
> 

You should have a go at http://www.gentoo.org/proj/en/sunrise/
Comment 11 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-07-07 15:21:26 UTC
1.9 is in-tree, and already stable...