Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 212864

Summary: app-text/evince-2.20.2 don't emerge with sys-devel/libtool-2.2
Product: Gentoo Linux Reporter: Oleksandr Pilipenko <opilipenko>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal CC: aballier
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 212763    
Attachments: The full log.

Description Oleksandr Pilipenko 2008-03-09 20:32:16 UTC
then mv -f ".deps/libephyzoom_la-ephy-zoom-action.Tpo" ".deps/libephyzoom_la-ephy-zoom-action.Plo"; else rm -f ".deps/libephyzoom_la-ephy-zoom-action.Tpo"; exit 1; fi
../../libtool: line 462: CDPATH: command not found
../../libtool: line 1265: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2
libtомилка 1


Reproducible: Always

Steps to Reproduce:
1.emerge =sys-devel/libtool-2.2
2.emerge evince





owlsnest ~ # emerge --info
Portage 2.1.4.4 (default-linux/x86/2007.0, gcc-4.2.3, glibc-2.7-r1, 2.6.23-gentoo-r8-filin i686)
=================================================================
System uname: 2.6.23-gentoo-r8-filin i686 AMD Duron(tm) processor
Timestamp of tree: Sat, 08 Mar 2008 20:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.5
dev-lang/python:     2.5.1-r5
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mcpu=athlon-tbird -mtune=athlon-tbird -march=athlon-tbird -pipe -mno-sse -mmmx -m3dnow -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=athlon-tbird -mtune=athlon-tbird -march=athlon-tbird -pipe -mno-sse -mmmx -m3dnow -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mneisen.org/ ftp://213.186.33.37/gentoo-distfiles/ ftp://194.117.143.70/sites/gentoo ftp://194.117.143.71/sites/gentoo ftp://ftp.mneisen.org/gentoo"
LANG="uk_UA.utf8"
LC_ALL=""
LINGUAS="uk ru"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/voip /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac alsa bash-completion berkdb bluetooth bzip2 cli cracklib crypt cups dbus dri dvd dvdr dvdread encode exif ffmpeg firefox flac fortran gdbm gif glitz gnome gpm gtk hal iconv isdnlog java jingle jpeg lm_sensors logrotate mad mailwrapper midi mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png pppd python readline reflection session spell spl ssl startup-notification svg tcpd theora tiff truetype unicode usb vim-syntax vorbis win32codecs x86 xorg xulrunner xv zlib" ALSA_CARDS="via82xx emu10k1 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="uk ru" USERLAND="GNU" VIDEO_CARDS="nv vesa nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Oleksandr Pilipenko 2008-03-09 20:35:21 UTC
Created attachment 145690 [details]
The full log.
Comment 2 Rafał Mużyło 2008-03-15 17:47:43 UTC
OK, it's just the annoying me again.
This bug is sort of, kind of invalid.
Namely, it's neither a libtool bug nor autotools.eclass bug.
This is an ebuild bug.
evince-2.20.2 does `cp aclocal.m4 old_macros.m4`
and only after that it does eutoreconf.
This results in including old AC_PROG_LIBTOOL definition into new aclocal.m4 and as ltmain.sh gets updated things break.
When the offending line gets removed everything works for me.
However, a warning - though I don't have whole GNOME installed (as I hate it), I do have many of its packages installed, so it probably 'just works for me' cause gnome-base/gnome-common is installed.
Comment 3 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-03-22 03:25:21 UTC
Typically, this is to avoid a gtk-doc dep, which causes rabid responses in a huge number of people (several of them gentoo devs).
Comment 4 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-03-22 03:25:38 UTC
Oh, and this is fixed in 2.22...
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-06-29 20:19:20 UTC
closing per comment #4.