Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 209803

Summary: app-text/ghostscript-gpl-8.61-r1 does not respect LDFLAGS
Product: Gentoo Linux Reporter: Diego Elio Pettenò (RETIRED) <flameeyes>
Component: New packagesAssignee: Printing Team <printing>
Status: RESOLVED FIXED    
Severity: normal CC: arfrever, pva
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 331933    

Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-02-12 09:33:14 UTC
These files have a .hash section even when my LDFLAGS tell the linker not to generate it:

app-text/ghostscript-gpl-8.61-r1 (/usr/bin/gsc)
Comment 1 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-02-12 17:26:48 UTC
*** Bug 181787 has been marked as a duplicate of this bug. ***
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-02-14 14:51:22 UTC
Also

app-text/ghostscript-gpl (/usr/lib64/ghostscript/8.61/X11.so)
Comment 3 Timo Gurr (RETIRED) gentoo-dev 2009-01-16 20:58:31 UTC
(In reply to comment #2)
> Also
> 
> app-text/ghostscript-gpl (/usr/lib64/ghostscript/8.61/X11.so)

Fixed in ghostscript-gpl-8.63-r1 thanks to the patch Kevin Pyle provided at bug #215913. Would be great if someone could come up with a patch to fix /usr/bin/gsc, too.
Comment 4 Peter Volkov (RETIRED) gentoo-dev 2009-03-19 20:26:12 UTC
Thank you for report Diego. This should be fixed in ghostscript-gpl-8.64-r2.