Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 209764

Summary: media-video/usb-pwc-re removal request
Product: Gentoo Linux Reporter: Jose Marino <braket>
Component: Current packagesAssignee: Patrick Kursawe (RETIRED) <phosphan>
Status: VERIFIED WONTFIX    
Severity: normal CC: jakub, media-video
Priority: High    
Version: 2006.1   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: usb-pwc-re-20061023.042702-r1.ebuild.patch
remove_hardware_field.patch
usb-pwc-re-20061023.042702-r1.ebuild.patch

Description Jose Marino 2008-02-12 01:35:53 UTC
Some changes to the structure "struct video_device" in the new kernel 2.6.24 make usb-pwc-re fail during compilation.

Reproducible: Always

Steps to Reproduce:
1. emerge usb-pwc-re
2.
3.

Actual Results:  
usb-pwc-re fails during compilation


From the changelog for kernel 2.6.24:

commit 22c4a4e98ece0eaff13b3d0ac73c5283013eb6b1
Author: Mauro Carvalho Chehab <mchehab@infradead.org>
Date:   Mon Oct 15 12:09:17 2007 -0300

    V4L/DVB (6320): v4l core: remove the unused .hardware V4L1 field
    
    struct video_device used to define a .hardware field. While
    initialized on severl drivers, this field is never used inside V4L.
    However, drivers using it need to include the old V4L1 header.
    
    This seems to cause compilation troubles with some random configs.
    Better just to remove it from all drivers.
    
    Signed-off-by: Mauro Carvalho Chehab <mchehab@infradead.org>


I attach a patch against the old ebuild usb-pwc-re-20061023.042702-r1.ebuild and another patch against the pwc-re sources that fix this issue.
Comment 1 Jose Marino 2008-02-12 01:39:55 UTC
Created attachment 143262 [details, diff]
usb-pwc-re-20061023.042702-r1.ebuild.patch

Patch against: usb-pwc-re-20061023.042702-r1.ebuild
Comment 2 Jose Marino 2008-02-12 01:40:55 UTC
Created attachment 143263 [details, diff]
remove_hardware_field.patch

Patch against usb-pwc-re-20061023.042702 sources.
Comment 3 Patrick Kursawe (RETIRED) gentoo-dev 2008-02-12 09:39:53 UTC
Since you seem to know how to modify ebuilds, could you please check why the original ebuild does not die on your system telling you "In kernel 2.6.24 this module is deprecated by the builtin driver." as it should? Thank you!
Comment 4 Jose Marino 2008-02-12 15:11:48 UTC
Created attachment 143314 [details, diff]
usb-pwc-re-20061023.042702-r1.ebuild.patch

Ah, I didn't notice that.

It seems the old ebuild has two pkg_setup functions defined. Here's a patch against the old ebuild.

Now the ebuild dies telling me to use the builtin kernel module.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2008-02-12 20:59:40 UTC
2.4 kernel drivers have no place in the tree, please nuke this.
Comment 6 Patrick Kursawe (RETIRED) gentoo-dev 2008-02-13 09:34:45 UTC
(In reply to comment #5)
> 2.4 kernel drivers have no place in the tree, please nuke this.
> 

Please note that this is no 2.4 kernel driver at all, how do you get this idea?

Even if it were - why should it have to be nuked while we still have vanilla-sources 2.4 in the tree? Did I miss some announcement?

Just fixed the double pkg_setup issue, I think we could keep this in the tree until 2.6.18 is gone.
Comment 7 Patrick Kursawe (RETIRED) gentoo-dev 2008-02-13 09:46:58 UTC
Changed my mind, going to nuke it.