Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 209235

Summary: e1000e doesn't strip crc properly on some chips
Product: Gentoo Linux Reporter: Johan Ymerson <johan>
Component: [OLD] Core systemAssignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers <kernel>
Status: RESOLVED FIXED    
Severity: normal Keywords: InVCS
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://bugzilla.kernel.org/show_bug.cgi?id=9940
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Temporary fix for e1000e crc problem.

Description Johan Ymerson 2008-02-07 13:19:26 UTC
The e1000e driver in kernel 2.6.24 doesn't strip crc properly from ethernet frames on some chips. This makes it impossible to use these nics in bridges, as the bridge depends on the crc to be stripped.

Upstream is working on this problem, but it will probably take a while since it isn't clear why some chips (in my case 82566DM-2) behave like this.

I suggest applying the attached patch to revert to an old working behavior of this driver. (i.e. reverting commit 140a74802894e9db57e5cd77ccff77e590ece5f3.)



Reproducible: Always

Steps to Reproduce:
1. Use tcpdump to see the ethernet frame size or include the e1000e nic in a bridge.
2.
3.

Actual Results:  
Driver doesn't strip crc from ethernet frame.

Expected Results:  
Driver should strip crc from ethernet frame.
Comment 1 Johan Ymerson 2008-02-07 13:20:32 UTC
Created attachment 142884 [details, diff]
Temporary fix for e1000e crc problem.
Comment 2 Daniel Drake (RETIRED) gentoo-dev 2008-02-07 15:48:49 UTC
Gentoo ship e1000e in 2.6.23 too. Are we affected there as well?
Comment 3 Johan Ymerson 2008-02-07 17:06:14 UTC
(In reply to comment #2)
> Gentoo ship e1000e in 2.6.23 too. Are we affected there as well?
> 

Yes, at least sys-kernel/gentoo-sources-2.6.23-r6.
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2008-02-12 13:44:18 UTC
sent a mail upstream
Comment 5 Daniel Drake (RETIRED) gentoo-dev 2008-02-12 14:01:48 UTC
will track the upstream bug, thanks
Comment 6 Daniel Drake (RETIRED) gentoo-dev 2008-02-15 19:24:10 UTC
upstream patch queued for next releases
Comment 7 Daniel Drake (RETIRED) gentoo-dev 2008-02-26 17:12:12 UTC
Fixed in genpatches-2.6.23-10 (gentoo-sources-2.6.23-r9) and genpatches-2.6.24-4 (gentoo-sources-2.6.24-r3), thanks for your help with this bug