Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 207805

Summary: multiple dev-libs/icu-3.6-r1 versions within a single package slot have been pulled into the dependency graph
Product: Gentoo Linux Reporter: Alex J. Ivasyuv <siegerstein>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal CC: portage, rose, zeekec
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Alex J. Ivasyuv 2008-01-27 23:43:30 UTC
# emerge -uDva world
 * Overlay eclass overrides eclass from PORTDIR:
 *
 *   '/usr/portage/local/layman/kde/eclass/subversion.eclass'
 *
 * It is best to avoid overridding eclasses from PORTDIR because it will
 * trigger invalidation of cached ebuild metadata that is distributed with
 * the portage tree. If you must override eclasses from PORTDIR then you
 * are advised to run `emerge --regen` after each time that you run `emerge
 * --sync`. Set PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if you
 * would like to disable this warning.

These are the packages that would be merged, in order:

Calculating world dependencies /
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

dev-libs/icu:0

  ('ebuild', '/', 'dev-libs/icu-3.6-r1', 'merge') pulled in by
    ('ebuild', '/', 'dev-libs/xerces-c-2.8.0', 'merge')

  ('installed', '/', 'dev-libs/icu-3.8.1', 'nomerge') pulled in by
    ('installed', '/', 'dev-libs/boost-1.34.1-r2', 'nomerge')


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

!!! Depgraph creation failed.
#


Reproducible: Always

Steps to Reproduce:




emerge --info
 * Overlay eclass overrides eclass from PORTDIR:
 *
 *   '/usr/portage/local/layman/kde/eclass/subversion.eclass'
 *
 * It is best to avoid overridding eclasses from PORTDIR because it will
 * trigger invalidation of cached ebuild metadata that is distributed with
 * the portage tree. If you must override eclasses from PORTDIR then you
 * are advised to run `emerge --regen` after each time that you run `emerge
 * --sync`. Set PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if you
 * would like to disable this warning.
Portage 2.1.4 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.7-r1, 2.6.24-rc7-oss i686)
=================================================================
System uname: 2.6.24-rc7-oss i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Timestamp of tree: Sun, 27 Jan 2008 23:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.3
dev-lang/python:     2.4.3-r4, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -mtune=prescott -pipe -O2 -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -mtune=prescott -pipe -O2 -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://src.gentoo.pl"
LANG="ru_RU.UTF-8"
LC_ALL=""
LINGUAS="ru"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/d /usr/portage/local/layman/kde"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X X509 Xaw3d a52 aac aalib accessibility acl acpi activefilter administrator aften akode alsa amarok ao apache2 aqua_theme audacious audiofile bash-completion berkdb bitmap-fonts blender-game bzip2 cairo carbone_theme cdio cdparanoia cjk cli cpudetection cracklib crypt css cups cvs cvsgraph d dbus debug dga divx djvu dmx dri dts dv dvb dvd dvdr dvdread dvi emacs emoticon emovix encode examples expat extensions fame fat ffmpeg fftw firefox flac fltk fontconfig foomaticdb fortran ftp fuse gdbm ggi gif gimp gimpprint glitz gpm gs gsm gstreamer gtk hal hfs iconv icu id3 id3tag ieee1394 image imagemagick imlib ipv6 isdnlog jabber jack jack-tmpfs java javascript jfs jpeg jpeg2k kde kdepim kqemu ladspa lame ldap ldap-sasl libcaca libsamplerate libsexy libvisual libwww lirc logitech-mouse logrotate lua mad matroska matrox md5sum midi mikmod mixer mjpeg mmap mmx mmxext mng motif moznopango mp2 mp3 mp3rtp mp4 mp4live mpegmpeg2 mplayer mppe-mppc mudflap multiuser musepack musicbrainz mysql nas ncurses neXt nethack netjack network nfs nls nptl nptlonly nss ntfs nut ogg openalopenexr opengl openmp openssh openssl opensslcrypt optimisememory oss pam pcre pdf perl png pnm portaudio posix postgres ppds pppd print pulseaudio pvr pyste python qt3 qt3support qt4 radio rar rdesktop readline reflection reiser4 reiserfs rtc ruby samba scanner schedule sdl seamonkey server session skins slang smp sms sndfile sound sox speex spell spl sql sqlite sse sse2 ssl startup-notification subversion svg svga swat symlink syslog tcl tcpd teletext tga themes theora threads thunderbird tiff timidity tk tools tordns transcode trayicon truetype truetype-fonts type1-fonts unicode unzip urandom usb v4l v4l2 vcd verse vidix vim vim-pager vim-syntax vim-with-x vlm vnc vorbis vorbis-psy wav wavpack win32codecs wma wxwindows x264 x86 xcomposite xfs xhtml xine xinerama xmlxorg xosd xpm xv xvid zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache envexpires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" LIRC_DEVICES="audio audio_alsa avermedia" USERLAND="GNU" VIDEO_CARDS="vesa vga fglrx radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-01-28 00:02:40 UTC
dev-libs/xerces-c-2.8.0 doesn't work w/ icu-3.8.1, you'll have to package.mask dev-libs/icu-3.8.1 as the message told you.


*** This bug has been marked as a duplicate of bug 1343 ***
Comment 2 Alex J. Ivasyuv 2008-01-28 14:07:45 UTC
(In reply to comment #1)
> dev-libs/xerces-c-2.8.0 doesn't work w/ icu-3.8.1, you'll have to package.mask
> dev-libs/icu-3.8.1 as the message told you.

Thanks, work!

Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-02-04 20:52:14 UTC
*** Bug 208862 has been marked as a duplicate of this bug. ***
Comment 4 Erik Zeek 2008-02-04 21:01:11 UTC
Note: app-office/openoffice-2.3.1-r1 depends on >=dev-libs/icu-3.8
Comment 5 Daniel Santos 2008-06-13 08:13:03 UTC
I think that the core issue here is that the latest dev-libs/xerces-c and openoffice cannot be installed on the same machine at current.  Simply masking >=dev-libs/icu-3.8.1 does not solve the problem when attempting to use openoffice (unless you want to use their binaries).  I'm thinking a new bug should be created for this.