Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 207385

Summary: dev-libs/boost-1.34.1-r2 build fails
Product: Gentoo Linux Reporter: Randy Johnson <theraptor2005>
Component: [OLD] LibraryAssignee: Tiziano Müller (RETIRED) <dev-zero>
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: emerge --info
replacement patch

Description Randy Johnson 2008-01-25 13:48:22 UTC
Boost fails to build, with the following two errors:

...failed gcc.compile.c++ bin.v2/libs/regex/build/gcc-4.1/release/debug-symbols-none/link-static/optimization-none/runtime-link-static/cregex.o...
./boost/regex/v4/basic_regex_parser.hpp: In member function 'bool boost::re_detail::basic_regex_parser<charT, traits>::parse_repeat(size_t, size_t)':
./boost/regex/v4/basic_regex_parser.hpp:787: error: case label 'boost::re_detail::syntax_element_backstep' not within a switch statement

Multiple USE flag combinations were tried, to no avail.

Reproducible: Always

Steps to Reproduce:
1. emerge dev-libs/boost-1.34.1-r2
2. Wait for it...

Actual Results:  
Emerge fails with compile errors
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-01-25 13:51:26 UTC
emerge --info please.
Comment 2 Randy Johnson 2008-01-25 14:22:35 UTC
Created attachment 141768 [details]
emerge --info

Sorry about that. emerge --info attached.
Comment 3 Tiziano Müller (RETIRED) gentoo-dev 2008-01-25 23:44:20 UTC
Any package specific USE flags?
Comment 4 Randy Johnson 2008-01-26 00:52:17 UTC
It fails in all combinations of USE flags I tried, including none selected. Noteably, I tried various combinations of icu, tools, and pyste. (I don't actually need any enabled)
Comment 5 Randy Johnson 2008-01-26 03:52:14 UTC
It appears that the patch 07_all_1.34.1-CVE-2008-0171_and_0172.patch07_all_1.34.1-CVE-2008-0171_and_0172.patch07_all_1.34.1-CVE-2008-0171_and_0172.patch applies incorrectly. When I manually apply the patch to a fresh untar, I get:

patching file boost/regex/v4/basic_regex_parser.hpp
Hunk #1 succeeded at 785 with fuzz 2.
Hunk #2 succeeded at 1871 with fuzz 2.
Hunk #3 succeeded at 1880 with fuzz 2.
patching file libs/regex/test/regress/test_perl_ex.cpp
Hunk #1 succeeded at 122 with fuzz 2.

Looking at the appropriate lines shows code in obviously wrong places (such as a case outside of a switch.
When I can get to it, I'll attempt to manually "patch" the files by hand, and post a modified patch if it works
Comment 6 Randy Johnson 2008-01-26 04:59:55 UTC
Created attachment 141804 [details, diff]
replacement patch

The attached replacement patch applies cleanly, and boost emerges correctly with it.
Comment 7 Tiziano Müller (RETIRED) gentoo-dev 2008-01-26 07:10:38 UTC
Hmm, can you please give me the output of this: 'grep ^PATCHSET_VERSION /usr/portage/dev-libs/boost/boost-1.34.1-r2.ebuild' ? Thanks.
Comment 8 Randy Johnson 2008-01-26 15:26:44 UTC
My fault. Grep output shows PATCHSET_VERSION="${PV}-2", where the latest ebuild has PATCHSET_VERSION="${PV}-3". This compiles properly.
Sorry for wasting time.
Comment fixes this

*** This bug has been marked as a duplicate of bug 205955 ***