|Summary:||dev-java/batik < 1.5.1 Squiggle Vulnerable scripting engine (CVE-2005-0508)|
|Product:||Gentoo Security||Reporter:||Petteri Räty (RETIRED) <betelgeuse>|
|Component:||Vulnerabilities||Assignee:||Gentoo Security <security>|
|Package list:||Runtime testing required:||---|
Description Petteri Räty (RETIRED) 2008-01-19 16:17:22 UTC
From http://xmlgraphics.apache.org/batik/ Security warning This is a warning that a script security issue was reported in the Batik Squiggle browser. Squiggle uses the Rhino scripting engine and some features of that engine can be leveraged by malicious scripts to gain access to otherwise protected resources (like the file system). This issue was fixed in the 1.5.1 release of Batik. If you are using a version of Batik older than 1.5.1, you should upgrade.
Comment 1 Robert Buchholz (RETIRED) 2008-01-19 22:59:08 UTC
So our latest stable 1.6-r3 is not vulnerable to this, but since it and the 1.5 branch are slotted, people might still use the old version. Do packages depend on this specific slot, or can we just drop it from the tree?
Comment 2 Petteri Räty (RETIRED) 2008-01-19 23:20:50 UTC
(In reply to comment #1) > > Do packages depend on this specific slot, or can we just drop it from the tree? > Probably not doable at this point in time but I will version bump 1.5 when get to it.
Comment 3 Vlastimil Babka (Caster) (RETIRED) 2008-01-20 22:32:48 UTC
Turned out that nothing depended on 1.5 anymore, so I removed it. We even had 1.5.1 in the tree but own slot, was removed earlier. So to GLSA or not to GLSA? :) We were installing launcher for the svg browser...
Comment 4 Sune Kloppenborg Jeppesen 2008-01-21 07:59:43 UTC
I tend to vote YES.
Comment 5 Robert Buchholz (RETIRED) 2008-02-11 21:28:41 UTC
1.5.1 hit the tree about 2004, stable 2005. I vote NO for reasons of obsoletion.