Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 206150

Summary: dev-libs/g-wrap-1.9.9 fails to build (autotools issue)
Product: Gentoo Linux Reporter: Evil Compile Person <bugs>
Component: EclassesAssignee: Scheme Project <scheme>
Severity: normal CC: base-system, chuck.wegrzyn, gentoo, jisakiel, mjinks, paul, roma1390, ryan, syscon780, tetromino
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 226305    
Attachments: patch for autotools.eclass
g-wrap ebuild

Description Evil Compile Person 2008-01-16 19:59:01 UTC
* Running aclocal -I /var/tmp/portage/dev-libs/g-wrap-1.9.9/work/g-wrap-1.9.9/m4 ...
  [ ok ]
 * Running autoconf ...
  [ !! ]

 * Failed Running autoconf !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/dev-libs/g-wrap-1.9.9/temp/autoconf-31483.out

 * ERROR: dev-libs/g-wrap-1.9.9 failed.

***** autoconf ***** error: possibly undefined macro: AC_MSG_NOTICE
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

Portage 2.1.4 (default-linux/amd64/2007.0, gcc-4.2.2, glibc-2.7-r1, 2.6.23-gentoo-r1 x86_64)
System uname: 2.6.23-gentoo-r1 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Timestamp of tree: Tue, 15 Jan 2008 06:00:01 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.1-r5
sys-apps/baselayout: 1.12.11
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
FEATURES="buildpkg distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="X acl amd64 berkdb bitmap-fonts cli cracklib crypt cups dri fortran gcj gdbm gpm iconv ipv6 isdnlog midi mmx mudflap ncurses nls nptl nptlonly objc openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl tcpd truetype-fonts type1-fonts unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vga"
Comment 1 Chuck Wegrzyn 2008-05-07 14:12:32 UTC
I get it to fail in aclocal.

* Failed Running aclocal !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/dev-libs/g-wrap-1.9.9/temp/aclocal-17781.out

Here is aclocal-17781.out

ideshow temp # more aclocal-17781.out
***** aclocal *****
***** aclocal -I .. -I ../config -I /var/tmp/portage/dev-libs/g-wrap-1.9.9/work/

aclocal-1.10: couldn't open directory `../config': No such file or directory
sideshow temp #
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-05-07 21:29:56 UTC
vapier: this bug is due your change to eaclocal in autotools.eclass, CVS commit 1.74 (and due to the fact that g-wrap makefiles are a mess).

As a result, *all* versions of g-wrap in the tree currently fail to compile.

You might want to look out whether other packages in portage are similarly affected.
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-05-07 22:02:06 UTC
***Devs: please change the bug component to "Eclasses and Profiles"!

The -I ../config error is trivial to fix.

The hard problem is that g-wrap uses the following construct in its


where ACLOCAL_FLAGS is set by configure. The new behaviour for eaclocal is to automatically scan for ACLOCAL_AMFLAGS in and, so this is a major problem; the obvious workarounds are either ugly (shuffling's and's in and out of backup directories) or far too much work (rewriting the g-wrap build system).

IMHO, the solution is to patch autotools.eclass so that the list of files that eaclocal scans for ACLOCAL_AMFLAGS would be a variable. So the ebuild could call something like

AT_AMFLAGS_FILES="" AT_M4DIR="${S}/m4" eautoreconf
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-05-07 23:13:41 UTC
Created attachment 152399 [details, diff]
patch for autotools.eclass

Patch to make the list of files that eaclocal scans for ACLOCAL_AMFLAGS be editable via the AT_AMFLAGS_FILES variable (i.e. setting AT_AMFLAGS_FILES="" would make eaclocal behave like it did before April 22 2008)
Comment 5 SpanKY gentoo-dev 2008-05-10 09:21:14 UTC
i cant see how it works properly regardless of autotools.eclass ... in fact, a quick test over here shows that it indeed doesnt work at all:
$ autoreconf
aclocal-1.10: unrecognized option `@ACLOCAL_FLAGS@'
aclocal-1.10: Try `/usr/bin/aclocal-1.10 --help' for more information.
autoreconf-2.61: aclocal failed with exit status: 1

fix the makefiles in question
Comment 6 roma1390 2008-05-14 07:27:08 UTC
Still doesn't build for me. (this means I can reproduce it too)
Comment 7 Christian Schmidt 2008-05-24 06:09:53 UTC
cd ${S}
ln -s m4 config
find . -name -o -name -exec sed -i s/@ACLOCAL_FLAGS@//g {} \;

"works for me" (TM)
Comment 8 Billy DeVincentis 2008-06-11 23:54:49 UTC
The above patch didn't work for me either. Can someone please provide a fixed ebuild that will actually emerge successfully? Or even better provide a folder ready to put in an overlay?
Comment 9 Pedro Ferreira 2008-06-20 00:32:47 UTC
Christian Schmidt's patch worked OK for me, but it would be cool if someone could fix the ebuild in portage.
Comment 10 A Sotirov 2008-07-06 19:37:27 UTC
Created attachment 159720 [details]
g-wrap ebuild
Comment 11 Tuomas Jäntti 2008-08-11 15:44:37 UTC
(In reply to comment #10)
> Created an attachment (id=159720) [edit]
> g-wrap ebuild


Worked for me.

I used the script to build g-wrap-1.9.6-r3 without error messages. I changed only the KEYWORDS to match version 1.9.6-r3.
Comment 12 FENG Chang 2008-09-15 22:49:26 UTC
(In reply to comment #10)
> Created an attachment (id=159720) [edit]
> g-wrap ebuild

v1.9.9 ebuild worked for me.
Thank you!
Comment 13 Marijn Schouten (RETIRED) gentoo-dev 2008-10-31 14:34:40 UTC
does this problem occur for 1.9.11?
Comment 14 Ivan Iraci 2008-11-29 13:33:50 UTC
(In reply to comment #12)
> (In reply to comment #10)
> > Created an attachment (id=159720) [edit]
> > g-wrap ebuild
> v1.9.9 ebuild worked for me.
> Thank you!

And for me.

Thanks a lot!

Comment 15 Paul Jewell 2009-01-24 08:10:30 UTC
I can also report success using the ebuild with g-wrap-1.9.6-r3, having changed the KEYWORDS line.

Thanks very much!
Comment 16 Joseph 2009-04-06 01:49:58 UTC
What KEYWORDS are you folks referring to?
the version: g-wrap-1.9.6-r3.ebuild has:
KEYWORDS="alpha amd64 ppc sparc x86"

version: g-wrap-1.9.9.ebuild (posted here has:)
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"

I'm having problem as well after upgrading to gcc-4.3.2-r3

* Running eautoreconf in '/var/tmp/portage/dev-libs/g-wrap-1.9.6-r3/work/g-wrap-1.9.6/libffi' ...
 * Running aclocal -I .. -I ../config -I /var/tmp/portage/dev-libs/g-wrap-1.9.6-r3/work/g-wrap-1.9.6/m4 ...                                                    [ !! ]

 * Failed Running aclocal !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/dev-libs/g-wrap-1.9.6-r3/temp/aclocal-18741.out

 * ERROR: dev-libs/g-wrap-1.9.6-r3 failed.
 * Call stack:
 *     , line   49:  Called src_unpack
 *             environment, line 2667:  Called eautoreconf
 *             environment, line  867:  Called eautoreconf
 *             environment, line  875:  Called eaclocal
 *             environment, line  814:  Called autotools_run_tool 'aclocal' '-I' '..' '-I' '../config' '-I' '/var/tmp/portage/dev-libs/g-wrap-1.9.6-r3/work/g-wrap-1.9.6/m4'
 *             environment, line  365:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  The die message:
 *   Failed Running aclocal !

I've tried g-wrap 1.9.9 from portage, the same problem
Comment 17 Marijn Schouten (RETIRED) gentoo-dev 2009-10-29 14:31:14 UTC
This version removed.