Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 204436

Summary: dev-libs/libcdio-0.79 GCC 4.3 patch
Product: Gentoo Linux Reporter: Ryan Hill (RETIRED) <rhill>
Component: [OLD] GCC PortingAssignee: Diego Elio Pettenò (RETIRED) <flameeyes>
Status: RESOLVED FIXED    
Severity: normal CC: devurandom, esqualante, media-video, milan
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 198121    
Attachments: libcdio-0.79-gcc-4.3-include.patch

Description Ryan Hill (RETIRED) gentoo-dev 2008-01-05 15:34:52 UTC
Hey Diego.  Looks like libcdio-0.79 is broken with GCC 4.3 again.

 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../.. -I../../include/ -O3 -g -march=native -fomit-frame-pointer -pipe -c iso9660.cpp  -fPIC -DPIC -o .libs/iso9660.o
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../.. -I../../include/ -O3 -g -march=native -fomit-frame-pointer -pipe -c cdio.cpp -o cdio.o >/dev/null 2>&1
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../.. -I../../include/ -O3 -g -march=native -fomit-frame-pointer -pipe -c devices.cpp -o devices.o >/dev/null 2>&1
/bin/sh ../../libtool --tag=CXX   --mode=link x86_64-pc-linux-gnu-g++  -O3 -g -march=native -fomit-frame-pointer -pipe  -Wl,-O1,--hash-style=gnu -o libcdio++.la -rpath /usr/lib64 cdio.lo devices.lo  -lm
In file included from iso9660.cpp:26:
../../include/cdio++/iso9660.hpp: In copy constructor 'ISO9660::Stat::Stat(const ISO9660::Stat&)':
../../include/cdio++/iso9660.hpp:129: error: 'free' was not declared in this scope
../../include/cdio++/iso9660.hpp:132: error: 'calloc' was not declared in this scope
../../include/cdio++/iso9660.hpp: In member function 'const ISO9660::Stat& ISO9660::Stat::operator=(const ISO9660::Stat&)':
../../include/cdio++/iso9660.hpp:138: error: 'free' was not declared in this scope
../../include/cdio++/iso9660.hpp: In destructor 'ISO9660::Stat::~Stat()':
../../include/cdio++/iso9660.hpp:144: error: 'free' was not declared in this scope
make[3]: *** [iso9660.lo] Error 1
make[3]: *** Waiting for unfinished jobs....


Just missing an include in iso9660.hpp
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2008-01-05 15:35:27 UTC
Created attachment 140187 [details, diff]
libcdio-0.79-gcc-4.3-include.patch
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-01-05 15:44:50 UTC
Will fix in a bit, I'm from the laptop now. Can you take a look at the current CVS? So at least when I'll release 0.80 it will work out of the box :P
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2008-01-19 03:33:06 UTC
CVS works fine.  actually it looks like cstdlib is included twice now ;).

http://cvs.savannah.gnu.org/viewvc/libcdio/include/cdio%2B%2B/iso9660.hpp?root=libcdio&r1=1.10&r2=1.11
Comment 4 milan hodoscek 2008-01-25 08:54:43 UTC
*** Bug 207347 has been marked as a duplicate of this bug. ***
Comment 5 Benjamin Lannoy 2008-04-19 14:21:43 UTC
(In reply to comment #1)
> Created an attachment (id=140187) [edit]
> libcdio-0.79-gcc-4.3-include.patch
> 

It works nice for me on ~amd64.
Thank you.
Comment 6 Ryan Hill (RETIRED) gentoo-dev 2008-04-20 22:35:40 UTC
Applied.