Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 20226

Summary: wv-0.7.5 - needs to add a configure option to compile with abiword
Product: Gentoo Linux Reporter: Kfir Ozer <ufk2k>
Component: New packagesAssignee: foser (RETIRED) <foser>
Severity: normal CC: mholzer
Priority: High    
Version: 1.4_rc2   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Kfir Ozer 2003-04-30 13:30:44 UTC
--with-exporter needs to be added to the configure flags. abiwords needs that
to compile.

Reproducible: Always
Steps to Reproduce:
Comment 1 foser (RETIRED) gentoo-dev 2003-04-30 14:29:47 UTC
which abiword are we talking about exactly ? abi2 series i suppose, it really doesn't need that to my knowledge.

Does your build break ? if so, what ouput ?
Comment 2 Kfir Ozer 2003-05-01 19:09:22 UTC
abiword 1.9.0 ebuild needs wvexporter.h 
now if you use the system's wv instead of compiling it with the wv package that comes with abiword you need that file. and you can get that only by adding what i wrote before.
Comment 3 foser (RETIRED) gentoo-dev 2003-05-01 19:10:50 UTC
nah that should be installed by default
Comment 4 Nuno Araujo 2003-05-01 20:32:45 UTC
While emerging app-office/anjuta-1.9.0-ebuild here is the error messages appeared during the econf operation: 

checking for size_t... yes
checking whether byte ordering is bigendian... no
checking for xml2-config... /usr/bin/xml2-config
checking for wv-libconfig... /usr/bin/wv-libconfig
checking for wvInitParser in -lwv... yes
checking wv.h usability... no
checking wv.h presence... yes
configure: WARNING: wv.h: present but cannot be compiled
configure: WARNING: wv.h: check for missing prerequisite headers?
configure: WARNING: wv.h: proceeding with the preprocessor's result
checking for wv.h... yes
checking wvexporter.h usability... no
checking wvexporter.h presence... no
checking for wvexporter.h... no
configure: error: * * * Sorry, unable to find wvexporter.h * * *
!!! ERROR: app-office/abiword-1.9.0 failed.
!!! Function econf, Line 273, Exitcode 1
!!! econf failed
I also tried to change the app-text/wv-0.7.5.ebuild by adding --with-exporter to the econf line in the src_compile section and the same errors hapened while compiling abiword again

Hope this helps
Comment 5 foser (RETIRED) gentoo-dev 2003-05-02 07:21:08 UTC
the question is does wvexporter.h exist on the system. If not, well there might be a problem with abiword detecting it, but then again it is a development version and in that case i'm not going to fix it.

So is /usr/include/wvexporter.h installed ?
Comment 6 Kfir Ozer 2003-05-02 12:53:41 UTC
let me clear things for everyone. if you add --with-exporter to the configure line
it installs wvexporter.h. now.. you should check config.log.
after compiling with --with-exporter it does install wvexporter.h but gives you the same error about wvexporter. if you'll read config.log you'll see that the problem is actaully that it can't find glibconfig.h. it doesn't include the neceserry directory. it's a bug that i've informed the abiword programmers in their irc channel and they're working on it. just if you add the glib-2.0 include path it works fine. 

still.. --with-exporter needs to be added by default
Comment 7 foser (RETIRED) gentoo-dev 2003-05-02 13:26:15 UTC
i don't need to add anything to have it install wvexporter.h (?) And what do you exactly mean with you have to add glib-2 include path, the problem is that an include of wv needs the glib-1.2 path and the abiword team is well aware of this problem, i have my contacts there.

Anyway, i actually cannot be bothered looking into this mess with new versions due shortly. If it was really a problem the way it currently is i would have dozens bugreports like this by now and i don't, so i assume it is a local problem.

Commentor in #4, my question in #5 still stands.
Comment 8 foser (RETIRED) gentoo-dev 2003-05-16 12:18:43 UTC
needinfo, please provide the requested info
Comment 9 Martin Holzer (RETIRED) gentoo-dev 2003-09-30 12:14:54 UTC
no responce