Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 198242

Summary: mail-client/mutt-1.5.18 version bump
Product: Gentoo Linux Reporter: Marco Squarcina <lavish>
Component: New packagesAssignee: Fernando J. Pereda (RETIRED) <ferdy>
Status: RESOLVED FIXED    
Severity: enhancement CC: alexander, amigadave, bensberg, bugs.gentoo.org, cgibreak, clmason, dberkholz, emilbeinroth, greg, grobian, hanno, kenyon, manyac, mimosinnet, net-mail, radhermit, ryoichiro.suzuki, scy-bugs-gentoo, spatz, swimmer, sylvain.bertrand, thelinuxfr, wschlich, zephyrus.271
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: diff of mutt-1.5.16.ebuild and mutt-1.5.17.ebuild
new version of compressed patch, taken from http://www.spinnaker.de/mutt/compressed/
new version of nntp patch, taken from http://mutt.org.ua/download/mutt-1.5.17/
Fix GPGME S/MIME micalg generation
Prefix-less ebuild for mutt-1.5.18 taken from the alt overlay
Files for the mutt-1.5.18 ebuild

Description Marco Squarcina 2007-11-06 07:56:21 UTC
From www.mutt.org: "Mutt 1.5.17 was released on November 1, 2007. This is a collection of bugfixes since the last release, as we stabilize the code for a 1.6 release."

Reproducible: Always

Steps to Reproduce:
Comment 1 Michal Terepeta 2008-02-02 12:21:36 UTC
Created attachment 142474 [details, diff]
diff of mutt-1.5.16.ebuild and mutt-1.5.17.ebuild 

The only necessary changes are: updating the sidebar patch, updating mutt-1.5.17-gentoo-patches-r1.tar.bz2 with new versions of "02-compressed.patch" and "06-nntp.patch" (both are attached) and simply renaming the parallel-make patch for 1.5.17 version.
Comment 2 Michal Terepeta 2008-02-02 12:22:56 UTC
Created attachment 142476 [details, diff]
new version of compressed patch, taken from http://www.spinnaker.de/mutt/compressed/
Comment 3 Michal Terepeta 2008-02-02 12:25:34 UTC
Created attachment 142478 [details, diff]
new version of nntp patch, taken from http://mutt.org.ua/download/mutt-1.5.17/
Comment 4 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-03-20 01:19:48 UTC
ferdy: Why is sidebar applied exclusively from the rest of the Mutt patches?
They apply almost perfectly - just the NNTP patch needs a tiny bit of manual rediff. If you can point me to your git repo of the mutt patchset, i'll spin you a set that will apply on top of the sidebar.
Comment 5 Wolfram Schlich (RETIRED) gentoo-dev 2008-04-16 12:07:03 UTC
1.5.17 FTW! \0/
Comment 6 Greg Fitzgerald 2008-05-20 15:32:13 UTC
Mutt 1.5.18 was released on May 17, 2008.
Comment 7 Fernando J. Pereda (RETIRED) gentoo-dev 2008-06-15 13:09:14 UTC
(In reply to comment #4)
> ferdy: Why is sidebar applied exclusively from the rest of the Mutt patches?
> They apply almost perfectly - just the NNTP patch needs a tiny bit of manual
> rediff. If you can point me to your git repo of the mutt patchset, i'll spin
> you a set that will apply on top of the sidebar.
> 

Upstream only wants it to be applied on top of vanilla. I don't recall which, but I released a patchset that applied the sidebar patch on top of the rest.

Turns out, the sidebar patch causes a lot of troubles (even when disabled) for people with big mailboxes. Tried getting it sorted upstream without luck. I'm not going to spend a second on that patch because it is crappy and messy.

I only use a git repo for convenience, but what I usually do is just import new versions of the patches into a stgit stack on a fresh repo for each release. So my repo doesn't have any magic that would help anybody :)

I don't have the time to maintain a proper patchset for mutt. I think I'll drop the patchset all together in the next couple of versions and let others maintain it if they want to.

- ferdy
Comment 8 Fabian Groffen gentoo-dev 2008-06-15 15:25:31 UTC
http://www.mutt.org.ua/download/mutt-1.5.18/patch-1.5.18.rr.compressed.gz works fine in place of 02-compressed.patch

http://www.mutt.org.ua/download/mutt-1.5.18/patch-1.5.18.vvv.nntp.gz in place of 06-nntp.patch

http://www.lunar-linux.org/~tchan/mutt/patch-1.5.18.sidebar.20080611.txt applies fine

http://overlays.gentoo.org/proj/alt/browser/trunk/prefix-overlay/mail-client/mutt/files/mutt-1.5.18-mbox_hook.patch works fine in place of 04-mbox_hook.patch

the rest still applies, except for the parallel-make.patch, which I didn't care enough about.
Comment 9 Fabian Groffen gentoo-dev 2008-06-15 15:34:33 UTC
I should have added that the nntp patch from the url I posted kills compilation of mixmaster (it removes the definition of HDR_MIX for some reason) so I took that as an incompatibility of the two and added $(use_with !nntp mixmaster) in the ebuild instead.
Comment 10 Raimar Sandner 2008-07-27 13:03:21 UTC
Created attachment 161467 [details, diff]
Fix GPGME S/MIME micalg generation

This patch applies to mutt-1.5.18 and fixes wrong micalg bug which prevents thunderbird (and possibly other clients) from checking a S/MIME signature. See http://dev.mutt.org/trac/ticket/2994
Comment 11 mimosinnet 2008-08-06 12:15:47 UTC
I would like to try to install mutt 1.5.18 from my local overlay. As far as I understood, the ebuild does not need any modifications and the trick is creating the mutt-1.5.18-gentoo-patches-r1.tar.bz2.

Is it reasonable, to test the package, to to download the patches into /usr/local/portage/mail-client/mutt/files and substitute the section src_unpack() by:

src_unpack() { 
    unpack ${A} && cd "${S}" || die "unpack failed" 
    for p in "${FILESDIR}"/*.patch ; do 
       epatch "${p}" 
    done 
 
    AT_M4DIR="m4" eautoreconf 
 }

Also, I have had a look at mutt-1.5.18 ebuild from dberkholz's overlay, and the line applying the parallel-make.patch is commented. Is this patch necessary?
# epatch "${FILESDIR}"/${P}-parallel-make.patch 

Comment 12 Markus Dittrich (RETIRED) gentoo-dev 2008-08-07 17:55:04 UTC
After removing the prefix specific bits, the mutt-1.5.18.ebuild from http://overlays.gentoo.org/proj/alt works perfectly (thanks much for
the work!). Any chance we can move this into the main tree?

Thanks,
Markus
Comment 13 Greg Fitzgerald 2008-08-30 23:24:49 UTC
(In reply to comment #12)
> After removing the prefix specific bits, the mutt-1.5.18.ebuild from
> http://overlays.gentoo.org/proj/alt works perfectly (thanks much for
> the work!). Any chance we can move this into the main tree?
> 
> Thanks,
> Markus
> 

This is working good for me as well.
Comment 14 Frederic LIETART 2008-10-13 07:47:49 UTC
Commit please
Fix: 211968,211673,209760,194762
Comment 15 Gautam Iyer 2008-11-06 22:09:36 UTC
Created attachment 170946 [details]
Prefix-less ebuild for mutt-1.5.18 taken from the alt overlay

Hi Guys,

The current ebuild in the alt overlay used prefix, which isn't supported by the stable version of portage on my system. I attach a prefix-less version of that ebuild.

I also added the fantastic X-Label patch by David Champion, so if you don't like it comment the appropriate line out.

GI
Comment 16 Gautam Iyer 2008-11-06 22:11:16 UTC
Created attachment 170947 [details]
Files for the mutt-1.5.18 ebuild
Comment 17 coran.fisher@gmail.com 2008-11-06 22:21:11 UTC
I installed your ebuild Gautam and it seems to work well.  Thank you. 
Comment 18 Fabian Groffen gentoo-dev 2009-01-11 11:27:36 UTC
I just bumped to 1.5.19.  Still masked for as long as we don't have a working sidebar patch.  Patchset has grown a bit.