Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 193737

Summary: media-gfx/imagemagick-6.3.5.9 breaks external apps - libgomp.so.1: shared object cannot be dlopen()ed
Product: Gentoo Linux Reporter: Sergiy Borodych <Sergiy.Borodych>
Component: Current packagesAssignee: Gentoo Graphics Project <graphics+disabled>
Status: RESOLVED FIXED    
Severity: major CC: esigra, gentoo
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://studio.imagemagick.org/pipermail/magick-users/2007-September/020174.html
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 186030    

Description Sergiy Borodych 2007-09-25 11:59:51 UTC
After update to media-gfx/imagemagick-6.3.5.9
my perl scripts die with message

Can't load '/usr/lib/perl5/site_perl/5.8.8/i686-linux-thread-multi/auto/Image/Magick/Magick.so' for module Image::Magick: libgomp.so.1: shared object cannot be dlopen()ed at /usr/lib/perl5/5.8.8/i686-linux-thread-multi/DynaLoader.pm line 230

Found similar problem describe at
http://studio.imagemagick.org/pipermail/magick-users/2007-September/020174.html
http://studio.imagemagick.org/pipermail/magick-users/2007-September/020175.html

quote
---
Did you upgrade from source?  That may help.  If so, try adding 
--disable-openmp on your configure script command line.

We fixed the display program pan icon problem you reported in ImageMagick
6.3.5-10 Beta available sometime tommorrow.
---

and as I see at http://imagemagick.org/script/download.php
"The latest release of ImageMagick is ImageMagick 6.3.5-10."

so please bump ebuild for fix this error
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-09-26 14:12:44 UTC
*** Bug 193872 has been marked as a duplicate of this bug. ***
Comment 2 Hans de Graaff gentoo-dev 2007-09-27 06:56:34 UTC
I've just added imagemagick-6.3.5.10 to CVS. According to the ChangeLog it should fix your problem, but it would be great to get some confirmation on that.
Comment 3 Cheba 2007-09-27 11:01:27 UTC
It fixed RMagick.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-09-27 11:53:54 UTC
Fixed the issue here as well.
Comment 5 Sergiy Borodych 2007-09-27 12:01:27 UTC
Yesperl module load ok too