Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 191923

Summary: kde-base/kcontrol-3.5.7-r1 fails to build - cannot find -ldns_sd
Product: Gentoo Linux Reporter: Matthew Stickney <fiendishlinux>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build log
full error message

Description Matthew Stickney 2007-09-10 00:16:49 UTC
After an emerge --sync, kcontrol-3.5.7-r1 fails to build during emerge -uND world

Reproducible: Always

Steps to Reproduce:
1.emerge --sync
2.emerge -uND world kcontrol
3.

Actual Results:  
produced the following errors:

!!! ERROR: kde-base/kcontrol-3.5.7-r1 failed.
Call stack:
  ebuild.sh, line 1638:   Called dyn_compile
  ebuild.sh, line 985:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  kcontrol-3.5.7-r1.ebuild, line 55:   Called kde-meta_src_compile
  kde-meta.eclass, line 380:   Called kde_src_compile
  kde.eclass, line 170:   Called kde_src_compile 'all'
  kde.eclass, line 340:   Called kde_src_compile 'myconf' 'configure' 'make'
  kde.eclass, line 336:   Called die

!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/kde-base/kcontrol-3.5.7-r1/temp/build.log'.



emerge --info:

Portage 2.1.2.12 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.22-gentoo-r5 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System release 1.12.9
Timestamp of tree: Sun, 09 Sep 2007 23:20:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=k8"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=k8"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://mirrors.acm.cs.rpi.edu/gentoo/ http://gentoo.osuosl.org/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="3dnow X aac aalib acl aiglx alsa amd64 avahi berkdb bitmap-fonts cairo cdparanoia cdr cli cracklib crypt cups dbus dri dts dvdnav fbcon fortran gdbm glitz gnome gpm gtk hal iconv ipv6 isdnlog kde libcaca matroska midi mmx mudflap ncurses nls nptl nptlonly nsplugin offensive oggvorbis opengl openmp pam pcre pdf perl png pppd python qt3 qt4 readline reflection sdl session spl sse sse2 ssl svg symlink tcpd theora truetype-fonts type1-fonts unicode xanim xcb xcomposite xorg xscreensaver xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-09-10 01:11:57 UTC
Please attach the full error messages and attach the contents of /var/tmp/portage/kde-base/kcontrol-3.5.7-r1/temp/build.log.
Comment 2 Matthew Stickney 2007-09-10 01:20:46 UTC
Created attachment 130452 [details]
build log
Comment 3 Matthew Stickney 2007-09-10 01:45:05 UTC
Created attachment 130453 [details]
full error message

this should include the full error message that was returned (I started a little above, just in case)
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-09-10 03:21:27 UTC
Did you emerge kdelibs with --nodeps?
Please emerge kdnssd-avahi and try again.
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-09-10 03:23:52 UTC
If my previous comment doesn't help, please confirm if you have bug #188787
Comment 6 Matthew Stickney 2007-09-10 04:16:12 UTC
I can't re-emerge kdnssd-avahi at the moment, due to a circular block between avahi and mdnsresponder. I'll post back after I get that all sorted out.
Comment 7 Matthew Stickney 2007-09-10 16:03:48 UTC
emerging kdemisc/kdnssd-avahi and resolving the conflict with net-misc/mDNSResponder seems to have fixed the problem. thanks for your help.