Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 189374

Summary: x11-wm/{emerald,heliodor} don't compile w/ >=x11-libs/libwnck-2.20
Product: Gentoo Linux Reporter: Forrest <voights>
Component: Current packagesAssignee: Joshua Jackson (RETIRED) <tsunam>
Status: RESOLVED WONTFIX    
Severity: normal CC: daemon, gnome, jakub, m+gentoo-bugs, petr.nosek, ulm
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Patch for emerald
Patch for heliodor
heliodor-0.2.1.ebuild
Correct format for emerald patch.
Patch for emerald-0.2.1.ebuild to apply libwnck patch
Patch for heliodor-0.2.1.ebuild to apply libwnck patch

Description Forrest 2007-08-18 16:21:06 UTC
New libwnck doesn't define WNCK_WINDOW_MODAL_DIALOG, so compile fails.

Reproducible: Always

Steps to Reproduce:
1. Use ~arch in ACCEPT_KEYWORDS
2. emerge -u libwnck
3. emerge emerald

Actual Results:  
Compile failed with http://pastebin.com/f391a736a

Expected Results:  
Compile would work

Patch for emerald available at http://pastebin.com/f7c12257
Patch for heliodor available at http://pastebin.com/f7140d262

---

Portage 2.1.3.6 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-rc3-g28e8351a-dirty i686)
=================================================================
System uname: 2.6.23-rc3-g28e8351a-dirty i686 Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Sat, 18 Aug 2007 00:50:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=nocona -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=nocona -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://open-systems.ufl.edu/mirrors/gentoo"
LANG="C"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gnome-experimental /usr/portage/local/local"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acl acpi aiglx alsa avahi berkdb bitmap-fonts bluetooth bzip2 cddb cdr cli cracklib crypt cups dbus deprecated dri dvd dvdr ffmpeg firefox flac fortran gdbm gif glitz gnome gpm gtk guile hal iconv ipv6 isdnlog isight ithreads jpeg ldap macbook mad midi mikmod mmx mmxext mozdevelop mpeg mudflap ncurses networkmanager nls nptl nptlonly nsplugin ogg old-daemons opengl openmp pam pcre perl png ppds pppd python readline reflection savepwd session spl sse sse2 ssl ssse3 tcpd theora threads tiff tk truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vorbis wifi win32codecs x86 xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Forrest 2007-08-18 16:22:51 UTC
Created attachment 128486 [details, diff]
Patch for emerald
Comment 2 Forrest 2007-08-18 16:23:37 UTC
Created attachment 128487 [details, diff]
Patch for heliodor
Comment 3 Gilles Dartiguelongue gentoo-dev 2007-08-18 16:53:46 UTC
send the patchs upstream so we can bump this later when gnome-2.20 will hit the tree.
Comment 4 Forrest 2007-08-18 17:01:34 UTC
What do you mean? How do I send them upstream?
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-10-19 08:51:47 UTC
*** Bug 195208 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-10-19 08:52:17 UTC
(In reply to comment #3)
> when gnome-2.20 will hit the tree.

Reopen, it's already in.

Comment 7 Balint Dobai-Pataky 2007-10-20 20:35:03 UTC
Created attachment 133984 [details]
heliodor-0.2.1.ebuild

heliodor.diff works, thanks

i modified the original heliodor ebuild - for the lazy people, like me, until this enters the portage-tree
save the heliodor diff as files/wnck.patch
and save this ebuild into your overlay.
Comment 8 Martin Wegner 2007-10-21 13:49:55 UTC
Created attachment 134026 [details, diff]
Correct format for emerald patch.

Patch for emerald did not work here, corrected format.
Comment 9 Martin Wegner 2007-10-21 13:50:49 UTC
Created attachment 134028 [details, diff]
Patch for emerald-0.2.1.ebuild to apply libwnck patch
Comment 10 Martin Wegner 2007-10-21 13:51:40 UTC
Created attachment 134029 [details, diff]
Patch for heliodor-0.2.1.ebuild to apply libwnck patch
Comment 11 Martin Wegner 2007-10-21 13:53:29 UTC
Both patched ebuilds work here with patches renamed to emerald-libwnck-2.20.patch and  heliodor-libwnck-2.20.patch respectively.

$ emerge --info
Portage 2.1.3.15 (default-linux/amd64/2007.0, gcc-4.2.2, glibc-2.6.1-r0, 2.6.23-gentoo-mw x86_64)
=================================================================
System uname: 2.6.23-gentoo-mw x86_64 Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz
Timestamp of tree: Sun, 21 Oct 2007 02:50:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.2-r1
dev-lang/python:     2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo        http://mirror.isp.net.au/ftp/pub/gentoo/        ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.gentoo.org/gentoo-distfiles/   ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
LANG="C"
MAKEOPTS="-j2 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://ares/gentoo-portage"
USE="X Xaw3d a52 aac aalib accessibility acpi alsa amd64 bash-completion berkdb bitmap-fonts branding bzip2 cairo cdparanoia cdr cli cracklib crypt css cups curl d dbus dedicated dga dia directfb divx dri dvb dvd dvdnav dvdr dvi editor emerald encode escreen expat fam fbcon ffmpeg firefox flac ftp gd gdbm gif gimpprint glut gnome gnome-print gnutls gtk gtkhtml hal hddtemp iconv icq idn imagemagick imap jabber jpeg jpeg2k lame libcaca libnotify lm_sensors logrotate mad mbox midi mmx mng mozdevelop mozilla mp3 mplayer mudflap nautilus ncurses nfs nls nptl nptlonly nsplugin nvidia offensive ogg openal opengl openmp openssl oscar pam pcre pdf perl png pop postfix ppds python quicktime readline realmedia rtc ruby samba sdl server session skins spl sqlite srt sse sse2 ssl startup-notification svg tcpd tetex theora thunderbird tiff tools truetype truetype-fonts type1-fonts unicode usb userlocales vim vim-with-x visualization vorbis wmf wmp wxwindows x264 xanim xine xinerama xml xorg xpm xprint xsl xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="hauppauge" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 12 Sumit Khanna 2007-10-25 03:11:47 UTC
I used the patch for emerald and it worked. I noticed from my last emerge that emerald 0.5 is now in the tree and works so the emerald problem should be fixed. If Heliodor has been updated as well, should this bug be marked as resolved?
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2007-10-25 05:16:03 UTC
(In reply to comment #12)
> I noticed from my last emerge that emerald 0.5 is now in the tree and works so 
> the emerald problem should be fixed.

emerald-0.5 depends on compiz, which is a completely useless dependency for people using beryl.
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2007-11-05 09:28:18 UTC
*** Bug 198145 has been marked as a duplicate of this bug. ***
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2007-11-12 08:32:32 UTC
Fixed in x11-wm/emerald-0.5.x, beryl is gone, nothing to fix here.

# Hanno Boeck <hanno@gentoo.org (11 Nov 2007)
# Remaining beryl-related packages, beryl has been removed
x11-wm/heliodor
x11-wm/aquamarine