Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 188805

Summary: XML::Parser not found in x11-misc/shared-mime-info-0.21-r1
Product: Gentoo Linux Reporter: David <panadero_pizza>
Component: New packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description David 2007-08-14 11:32:10 UTC
XML::Parser not found in x11-misc/shared-mime-info-0.21-r1, however it is present on the system:

linux ~ # emerge --update --deep --ask world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild     U ] x11-misc/shared-mime-info-0.21-r1 [0.20] 
[ebuild     U ] dev-perl/XML-Parser-2.34-r1 [2.34] 
[ebuild     U ] net-misc/curl-7.16.4 [7.15.5-r1] USE="-nss%" 

...


Reproducible: Didn't try

Steps to Reproduce:
1.emerge --sync
2.emerge --update --deep --ask world
3.

Actual Results:  
>>> Emerging (1 of 20) x11-misc/shared-mime-info-0.21-r1 to /
 * shared-mime-info-0.21.tar.bz2 RMD160 ;-) ...                                                                                                                     [ ok ]
 * shared-mime-info-0.21.tar.bz2 SHA1 ;-) ...                                                                                                                       [ ok ]
 * shared-mime-info-0.21.tar.bz2 SHA256 ;-) ...                                                                                                                     [ ok ]
 * shared-mime-info-0.21.tar.bz2 size ;-) ...                                                                                                                       [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                               [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                              [ ok ]
 * checking shared-mime-info-0.21.tar.bz2 ;-) ...                                                                                                                   [ ok ]
>>> Unpacking source...
>>> Unpacking shared-mime-info-0.21.tar.bz2 to /var/tmp/portage/x11-misc/shared-mime-info-0.21-r1/work
 * Applying shared-mime-info-0.21-pkgconfig.patch ...                                                                                                               [ ok ]
 * Running automake --add-missing --copy --foreign ...                                                                                                              [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/x11-misc/shared-mime-info-0.21-r1/work/shared-mime-info-0.21 ...
 * econf: updating shared-mime-info-0.21/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating shared-mime-info-0.21/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-update-mimedb --build=i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i686-pc-linux-gnu-gcc accepts -g... yes
checking for i686-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of i686-pc-linux-gnu-gcc... gcc3
checking for an ANSI C-conforming const... yes
checking for intltool >= 0.35.0... 0.35.0 found
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool


!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/x11-misc/shared-mime-info-0.21-r1/work/shared-mime-info-0.21/config.log

!!! ERROR: x11-misc/shared-mime-info-0.21-r1 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_compile
  ebuild.sh, line 983:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  shared-mime-info-0.21-r1.ebuild, line 31:   Called econf '--disable-update-mimedb'
  ebuild.sh, line 586:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/x11-misc/shared-mime-info-0.21-r1/temp/build.log'.

linux ~ #
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-08-14 11:34:04 UTC

*** This bug has been marked as a duplicate of bug 41124 ***