Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 188510

Summary: app-emulation/qemu-softmmu-0.9.0 won't compile
Product: Gentoo Linux Reporter: Dave <dliana>
Component: Current packagesAssignee: Gentoo Developers for the x86 Architecture <x86>
Severity: normal CC: bugs, lu_zero
Priority: High    
Version: 2007.0   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: build.log
emerge --info
emerge --info

Description Dave 2007-08-11 21:17:43 UTC
See attachments
Comment 1 Dave 2007-08-11 21:18:14 UTC
Created attachment 127783 [details]
Comment 2 Dave 2007-08-11 21:18:45 UTC
Created attachment 127784 [details]
emerge --info
Comment 3 Luca Barbato gentoo-dev 2007-08-12 08:30:34 UTC
your cflags looks wrong in many ways...

the issue seems that you have a register depletion, not sure if I could reproduce it (no x86 around here)
Comment 4 Dave 2007-08-12 12:22:37 UTC
Yeah, I was playing around with CFLAGS, but I've filtered everything out and still get the same error
Comment 5 Dave 2007-08-12 19:40:10 UTC
Looks like it compiles cleanly with 3.3.6
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-08-15 06:17:15 UTC
-mmmx -msse -msse2: implied by -march, redundant
-falign-functions: implied by -O2, redundant
-mfpmath=sse,387: unsupported, marked as experimental even with gcc-4.2
-fforce-addr: probably what's giving you trouble here, remove it and try again.

Please, sanitize your C[XX]FLAGS before reporting bugs.
Comment 7 Greg Watson (linuxkrn) 2007-08-20 03:38:52 UTC
I get this error too, and have safe cflags.

Attaching both emerge info and build.log.
Comment 8 Greg Watson (linuxkrn) 2007-08-20 03:39:30 UTC
Created attachment 128634 [details]
emerge --info
Comment 9 Greg Watson (linuxkrn) 2007-08-20 03:40:27 UTC
Created attachment 128636 [details]
Comment 10 Per Wigren 2007-08-21 17:29:58 UTC
I had similar problems and found that it works if I build gcc3 with USE=nopie.
Add this to your /etc/portage/packages.use:
=sys-devel/gcc-3* nopie

(personally I have "nopie nocxx -gtk" set for gcc-3 because qemu is the only thing I need it for and it doesn't use c++)
Comment 11 Frank Szczerba 2007-08-22 16:33:53 UTC
Compile fails with i686-pc-linux-gnu-3.4.6 even if gcc is built with nopie USE flag.

Compile succeeds with i686-pc-linux-gnu-3.3.6 built with nopie.
Comment 12 Christian Faulhammer (RETIRED) gentoo-dev 2007-09-06 06:04:14 UTC
I haven't tested 0.9.0 with a 3 GCC, but maybe it is appropriate to change the notification in pkg_setup to a GCC 3.3*
Comment 13 Markus Meier gentoo-dev 2007-09-24 20:39:53 UTC
can't reproduce it with sys-devel/gcc-3.4.6-r2. this looks like a regression in <gcc-4*, see - so we have to wait until qemu builds with gcc-4.