Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 188495

Summary: thunar-volman fails to compile
Product: Gentoo Linux Reporter: Dave O'Connor <doc+gentoo-bugs>
Component: [OLD] UnspecifiedAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: major    
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: log file requested

Description Dave O'Connor 2007-08-11 18:55:31 UTC
Trying to emerge -Dup world but the following happens:

checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/xfce-extra/thunar-volman-0.1.3_pre20070523/work/thunar-volman-0.1.3_pre20070523/config.log


Looks like a missing dependency.

Reproducible: Always

Steps to Reproduce:
1.emerge -Dup world
2.watch it fail
3.profit

Actual Results:  
didn't compile

Expected Results:  
compiled

Portage 2.1.2.11 (default-linux/amd64/2006.0, gcc-4.1.2, glibc-2.5-r4, 2.6.19-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.19-gentoo-r5 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 11 Aug 2007 11:50:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk ftp://mirrors.blueyonder.co.uk/mirrors/gentoo http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/ "
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://trumpetti.atm.tut.fi/gentoo-portage"
USE="X a52 aac acpi alsa amd64 apache2 audiofile bacula-clientonly bash-completion bitmap-fonts bzip2 cdparanoia cdr cli cracklib crypt ctype cups curl curlwrapper dbus dri dts dvb dvd dvdr dvdread eds eeprom emboss encode exif fam ffmpeg flac flash foomaticdb fortran ftp gcj gd gif gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal iconv icq imap imlib innodb ipv6 isdnlog jabber java javascript jikes jpeg jpeg2k junit libnotify lirc lm_sensors lzw lzw-tiff mad mbox mcal midi mmie mng motif mozilla mp3 mpeg mudflap mysql ncurses netboot nls nptl nptlonly nsplugin offensive ogg openal opengl openmp pam pcre pdf perl php png posix postgres pppd python quicktime readline reflection rt61pci ruby samba sdl session sharedmem shorten simplexml soap sockets speex spell spl ssl svg tcpd theora tiff truetype truetype-fonts type1-fonts unicode usb vhosts videos vorbis wxwindows xine xml xml2 xmlrpc xorg xosd xpm xsl xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="kbd mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="hauppauge" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Dave O'Connor 2007-08-11 18:56:58 UTC
Created attachment 127775 [details]
log file requested
Comment 2 Samuli Suominen gentoo-dev 2007-08-11 18:58:44 UTC

*** This bug has been marked as a duplicate of bug 41124 ***