Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 188396

Summary: x11-libs/vte-0.16.6-r1 missing XML::Parser
Product: Gentoo Linux Reporter: gentoo
Component: New packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: 2007.0   
Hardware: PPC   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description gentoo 2007-08-10 19:38:38 UTC
I appear to have dev-perl/XML-Parser installed but the latest evince ebuild fails when testing for the Perl module:

checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/x11-libs/vte-0.16.6-r1/work/vte-0.16.6/config.log

!!! ERROR: x11-libs/vte-0.16.6-r1 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_compile
  ebuild.sh, line 983:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  ebuild.sh, line 1322:   Called gnome2_src_compile
  gnome2.eclass, line 70:   Called gnome2_src_configure
  gnome2.eclass, line 66:   Called econf '--disable-debug' '--enable-python' '--with-glX' '--with-xft2' '--with-pangox' '--disable-gtk-doc'
  ebuild.sh, line 586:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/x11-libs/vte-0.16.6-r1/temp/build.log'.
$

OK, so let's check:

$ eix dev-perl/XML-Parser
[I] dev-perl/XML-Parser
     Available versions:  2.34
     Installed versions:  2.34)12:23:25 05/22/07((
     Homepage:            http://search.cpan.org/~msergeant/
     Description:         A Perl extension interface to James Clark's XML parser, expat


Hmm... appears to be installed? Here's the usual emerge info:

Portage 2.1.2.11 (default-linux/ppc/ppc32/2007.0/G3, gcc-4.1.2, glibc-2.5-r4, 2.6.20-gentoo-r5 ppc)
=================================================================
System uname: 2.6.20-gentoo-r5 ppc 740/750
Gentoo Base System release 1.12.9
Timestamp of tree: Fri, 10 Aug 2007 11:50:01 +0000
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O3 -pipe -mcpu=G3 -fno-strict-aliasing"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O3 -pipe -mcpu=G3 -fno-strict-aliasing"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://gentoo.mirrors.pair.com/ http://mirrors.acm.cs.rpi.edu/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"PORTAGE_TMPDIR="/var/tmp"PORTDIR="/usr/portage"PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"USE="X acl alsa berkdb bitmap-fonts cli cracklib crypt cups dbus dri gdbm gpm gtk hal iconv ipv6 isdnlog ithreads libnotify midi mudflap ncurses nls nptl nptlonly opengl openmp pcre perl ppc pppd python readline reflection session spl ssl tcpd threads truetype-fonts type1-fonts unicode xorg zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="chips dummy fbdev glint imstt mach64 mga nv r128 radeon s3 s3virge savage sisusb tdfx trident v4l voodoo"Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-08-10 19:39:59 UTC

*** This bug has been marked as a duplicate of bug 41124 ***