Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 18798

Summary: New ebuild for advance mame 0.66
Product: Gentoo Linux Reporter: Andrea Cerrito <is>
Component: New packagesAssignee: Ryan Phillips (RETIRED) <rphillips>
Status: RESOLVED FIXED    
Severity: enhancement CC: azarah, magnade
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Andrea Cerrito 2003-04-05 07:37:08 UTC
I've made a really simple diff against ebuild 0.63 for advancemame to build 0.66
release, plus digest.

Reproducible: Always
Steps to Reproduce:





*** advancemame-0.63.0.ebuild   2003-03-01 00:50:50.000000000 +0100
--- advancemame-0.66.0.ebuild   2003-04-05 13:51:13.000000000 +0200
***************
*** 8,14 ****
  # difficult to get it working with fb or svgalib support.  Anyway,
  # it do not look as good ;-)
  
! ADVMNU_VER="2.2.3"
  
  MY_PV="$(echo ${PV} | cut -d. -f1,2)"
  S="${WORKDIR}/advmame"
--- 8,14 ----
  # difficult to get it working with fb or svgalib support.  Anyway,
  # it do not look as good ;-)
  
! ADVMNU_VER="2.2.4"
  
  MY_PV="$(echo ${PV} | cut -d. -f1,2)"
  S="${WORKDIR}/advmame"
***************
*** 40,46 ****
  
        cd ${S}
        # Unpack mame and advacemame
!       unzip -qaa ${WORKDIR}/MAME${MY_PV/\.}.ZIP || die
        cp -adf ${WORKDIR}/${P}/* .
        cp -adf ${WORKDIR}/advancemenu-${ADVMNU_VER}/* .
  
--- 40,46 ----
  
        cd ${S}
        # Unpack mame and advacemame
!       unzip -qaa ${WORKDIR}/MAME.ZIP || die
        cp -adf ${WORKDIR}/${P}/* .
        cp -adf ${WORKDIR}/advancemenu-${ADVMNU_VER}/* .

Digest.
MD5 36fa4bd74e7379625ccfb78350af6906 advancemame-0.66.0.tar.gz 1062853
MD5 243d47b15e0a944c2e09972be7816484 advancemenu-2.2.4.tar.gz 1049057
MD5 51d5aaac8485a177f9b1b09a640b74ae mame066s.zip 6779300
Comment 1 Bret Towe 2003-04-14 15:33:26 UTC
advancemame 0.67.0 is out
i copied over the .63 ebuild and only had to
edit the version part of the unziping of the mame file
and updated advancemenu to ver 2.2.5

also the comment says that it is built mainly for sdl
there is some autoconf changes of late that might make framebuffer workable now
Comment 2 Andrea Cerrito 2003-04-15 14:32:26 UTC
How is it possible? There is a ADVMNU_VER var!
Anywat, what is the problem for sdl?
I'll have a look about fb. Thanks for hints!
Comment 3 Bret Towe 2003-04-15 14:41:53 UTC
sdl is fine i just like ebuilds that allow for all options :)
Comment 4 Bret Towe 2003-06-24 22:45:17 UTC
advancemame 0.70 (advancemenu 2.2.7) is out

i havent tested yet to busy at this time
Comment 5 Per Wigren 2003-06-25 02:33:25 UTC
I think AdvanceMAME, AdvanceMESS and AdvanceMENU should be separate ebuilds!
AdvanceMENU can be used with a lot of emulators, not just AdvanceMAME...
Comment 6 Martin Schlemmer (RETIRED) gentoo-dev 2003-07-13 07:12:26 UTC
Added 0.70.0.