Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 184732

Summary: >=webalizer 2.01.10-r14 is unable to parse old .current files
Product: Gentoo Linux Reporter: Philippe Chaintreuil <gentoo_bugs_peep>
Component: New packagesAssignee: Jonathan Smith (RETIRED) <smithj>
Severity: normal CC: stolz, web-apps
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Philippe Chaintreuil 2007-07-09 14:43:19 UTC
I just upgraded to webalizer 2.01.10-r15 and now, each of my domains gets the following error:

Error: Unable to restore run data (13)

Reproducible: Always

There's a thread on Stone Step's branch of webalizer that refers to a bug that sounds the same, but I don't know if it is or not:
Comment 1 Philippe Chaintreuil 2007-07-09 14:46:03 UTC
My emerge info:

Portage (default-linux/x86/2006.1/server, gcc-4.1.2, glibc-2.5-r4, 2.6.17-gentoo-r8 i686)
System uname: 2.6.17-gentoo-r8 i686 Genuine Intel(R) CPU T2400 @ 1.83GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Mon, 09 Jul 2007 12:50:01 +0000
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=pentium-m -msse3 -pipe -fomit-frame-pointer"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache2-php4/ext-active/ /etc/php/cgi-php4/ext-active/ /etc/php/cli-php4/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium-m -msse3 -pipe -fomit-frame-pointer"
FEATURES="distlocks fixpackages metadata-transfer sandbox sfperms strict userfetch userpriv usersandbox"
GENTOO_MIRRORS="          http://open-systems.ufl.edt/mirrors/gentoo         "
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="acpi apache2 authdaemond bash-completion berkdb bitmap-fonts bzip2 clearpasswd cli cracklib crypt dcc doc dri gd gpm iconv imap isdnlog javascript libg++ logrotate maildir mailwrapper midi mime mmx mudflap mysql ncurses nfs nptl nptlonly openmp pam pcre pear perl perlsuid php pni postfix ppds pppd python pyzor pyzord razor readline reflection sasl session spf spl sse sse2 sse3 ssl tcpd tools truetype truetype-fonts type1-fonts vda vhosts x86 xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Comment 2 Philippe Chaintreuil 2007-07-09 14:47:39 UTC
My use flags for app-admin/webalizer:

USE="apache2 geoip search xtended -nls -vhosts"

(NOTE: I think "search" was removed in -r15.)
Comment 3 Philippe Chaintreuil 2007-07-09 15:03:10 UTC
This also happens in -r14.

-r13 works correctly.

-r12 no longer builds:

i686-pc-linux-gnu-gcc -L/usr/lib -Ldb-4.2  -o webalizer webalizer.o hashtab.o linklist.o preserve.o parser.o output.o dns_resolv.o graphs.o -lGeoIP -lgd -lpng -lz -lm -lnsl -ldb 
dns_resolv.o: In function `open_cache':
dns_resolv.c:(.text+0x100): undefined reference to `__db185_open_4002'
dns_resolv.o: In function `dns_resolver':
dns_resolv.c:(.text+0x64d): undefined reference to `__db185_open_4002'
collect2: ld returned 1 exit status
make: *** [webalizer] Error 1

!!! ERROR: app-admin/webalizer-2.01.10-r12 failed.
Call stack:, line 1621:   Called dyn_compile, line 973:   Called qa_call 'src_compile', line 44:   Called src_compile
  webalizer-2.01.10-r12.ebuild, line 97:   Called die

!!! make failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-07-09 18:36:32 UTC
(In reply to comment #3)
> dns_resolv.c:(.text+0x100): undefined reference to `__db185_open_4002'

Unrelated issue; run revdep-rebuild.
Comment 5 Philippe Chaintreuil 2007-07-17 18:27:00 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > dns_resolv.c:(.text+0x100): undefined reference to `__db185_open_4002'
> Unrelated issue; run revdep-rebuild.

   Okay, I think you're right on that -r12 issue, but that's kind of an aside that doesn't really relate to issue about how -r14 & -r15 both are unable to read the .current files.

Comment 6 Benedikt Böhm (RETIRED) gentoo-dev 2008-02-23 16:55:17 UTC
the only thing that changed between r14 and r15 was the extended patch, which shouldn't even be activated because in <-r16 it conflicts with the geoip patch ...  

please re-open if this is still an issue with 2.01.10-r16
Comment 7 Philippe Chaintreuil 2008-04-12 11:17:24 UTC
It's been a while, but I just tried upgrading to r16 and I still get this "Unable to restore run data" issue.
Comment 8 Philippe Chaintreuil 2009-06-08 14:32:54 UTC
> the only thing that changed between r14 and r15 was the extended patch, 
> which shouldn't even be activated because in <-r16 it conflicts with
> the geoip patch
> ...  
> please re-open if this is still an issue with 2.01.10-r16

Oh man, Benedikt...

I just noticed a note when reinstalling my stashed away quickpkg version of 2.01.10-r13 that made your comments make all sorts of sense.  It told me to check out for more information.  Right at the top of that it warns:


a. Whenever you install Webalizer Xtended for the first time or upgrade the 
   original Webalizer software, you need to make sure that your system no longer 
   has older versions of the following files:
   - webalizer.current
   - webalizer.hist
   Keeping one or both of these files on your system can cause corruption of the 
   internally stored Webalizer data or can result in unreliable statistical 
   output. If you see problems about processing the logfile, chances are good 
   you have one or more old files someplace.

So my problem is that I'm enabling the xtender patch, I bet.  If someone will check in #231859, I'll upgrade and see if I'm just seeing the xtender issue.
Comment 9 Philippe Chaintreuil 2009-06-09 13:23:41 UTC
Okay, I turned off the xtended use flag and webalizer-2.01.10-r15 runs fine.  Considering how long -r13 has been out of the tree, I don't see any reason this bug needs to stay open.  It's historical existence should be enough for anyone who has my problem in the future.