Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 183626

Summary: media-libs/mesa-7.0.1 version bump
Product: Gentoo Linux Reporter: GNUtoo
Component: New packagesAssignee: Gentoo X packagers <x11>
Status: RESOLVED FIXED    
Severity: enhancement CC: alexxy, andrey.melentyev, betelgeuse, jlp.bugs, n1ghtmare, nelchael, roberto.castagnola, russ, ssuominen, teidakankan, wbrana
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://www.mesa3d.org/
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: an ebuild for mesa 7.0 that honours -dri builds

Description GNUtoo 2007-06-29 09:01:43 UTC
mesa 7.0 is out

Reproducible: Always
Comment 1 Samuli Suominen gentoo-dev 2007-06-29 11:15:03 UTC
Regression in 7.0, http://bugs.freedesktop.org/show_bug.cgi?id=7459 , Comment #10

Bump it to package.mask, instead of ~ ?
Comment 2 Russell Harmon 2007-07-01 11:13:30 UTC
I'm running it now... no obvious problems. I installed it using the mesa-6.5.3 ebuild, and it works, with a few qa errors. Here's the log

QA: setup
QA Notice: USE Flag 'amd64-fbsd' not in IUSE for media-libs/mesa-7.0
QA Notice: USE Flag 'kernel_FreeBSD' not in IUSE for media-libs/mesa-7.0

INFO: unpack
Applying mesa-7.0-pthread.patch ...
Removing DO_DEBUG defs in dri drivers...

INFO: install
Moving libGL and friends for dynamic switching ...

QA: other
QA Notice: The following files contain executable stacks
 Files with executable stacks will not work properly (or at all!)
 on some architectures/operating systems.  A bug should be filed
 at http://bugs.gentoo.org/ to make sure the file is fixed.
 For more information, see http://hardened.gentoo.org/gnu-stack.xml
 Please include this file in your report:
 /var/tmp/portage/media-libs/mesa-7.0/temp/scanelf-execstack.log
--- --- RWX usr/lib/opengl/xorg-x11/lib/libGL.so.1.2
Comment 3 Russell Harmon 2007-07-01 23:35:08 UTC
scratch that, the new version breaks compiles that link against libGL
Comment 4 GNUtoo 2007-07-07 15:09:32 UTC
(In reply to comment #2)
> I'm running it now... no obvious problems. I installed it using the mesa-6.5.3
> ebuild, and it works, with a few qa errors. Here's the log
> 
> QA: setup
> QA Notice: USE Flag 'amd64-fbsd' not in IUSE for media-libs/mesa-7.0
> QA Notice: USE Flag 'kernel_FreeBSD' not in IUSE for media-libs/mesa-7.0
> 
> INFO: unpack
> Applying mesa-7.0-pthread.patch ...
> Removing DO_DEBUG defs in dri drivers...
> 
> INFO: install
> Moving libGL and friends for dynamic switching ...
> 
> QA: other
> QA Notice: The following files contain executable stacks
>  Files with executable stacks will not work properly (or at all!)
>  on some architectures/operating systems.  A bug should be filed
>  at http://bugs.gentoo.org/ to make sure the file is fixed.
>  For more information, see http://hardened.gentoo.org/gnu-stack.xml
>  Please include this file in your report:
>  /var/tmp/portage/media-libs/mesa-7.0/temp/scanelf-execstack.log
> --- --- RWX usr/lib/opengl/xorg-x11/lib/libGL.so.1.2
> 

could you attach the ebuild here?
because i've a r300 and its problems are fixed in the 7.0
Comment 5 Russell Harmon 2007-07-07 15:14:32 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > I'm running it now... no obvious problems. I installed it using the mesa-6.5.3
> > ebuild, and it works, with a few qa errors. Here's the log
> > 
> > QA: setup
> > QA Notice: USE Flag 'amd64-fbsd' not in IUSE for media-libs/mesa-7.0
> > QA Notice: USE Flag 'kernel_FreeBSD' not in IUSE for media-libs/mesa-7.0
> > 
> > INFO: unpack
> > Applying mesa-7.0-pthread.patch ...
> > Removing DO_DEBUG defs in dri drivers...
> > 
> > INFO: install
> > Moving libGL and friends for dynamic switching ...
> > 
> > QA: other
> > QA Notice: The following files contain executable stacks
> >  Files with executable stacks will not work properly (or at all!)
> >  on some architectures/operating systems.  A bug should be filed
> >  at http://bugs.gentoo.org/ to make sure the file is fixed.
> >  For more information, see http://hardened.gentoo.org/gnu-stack.xml
> >  Please include this file in your report:
> >  /var/tmp/portage/media-libs/mesa-7.0/temp/scanelf-execstack.log
> > --- --- RWX usr/lib/opengl/xorg-x11/lib/libGL.so.1.2
> > 
> 
> could you attach the ebuild here?
> because i've a r300 and its problems are fixed in the 7.0
> 

Just copy the old mesa-6.5.3.ebuild and rename it to mesa-7.0.ebuild
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-07-27 20:58:56 UTC
*** Bug 186833 has been marked as a duplicate of this bug. ***
Comment 7 Gert Wollny 2007-07-28 13:33:09 UTC
Created attachment 126222 [details]
an ebuild for mesa 7.0 that honours -dri builds 

The ebuild tests the dri use flag and compiles a non-accelerated mesa in case "-dri" is set. That's useful if you have an old nvidia graphics board (e.g. in a laptop) and want to develop for OpenGL 2.X. 
The ebuild has still some issues with libGL.la, i.e. it is not installed properly. 
Therefor the build is masked by "-*"
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-08-05 11:44:11 UTC
*** Bug 187804 has been marked as a duplicate of this bug. ***
Comment 9 Donnie Berkholz (RETIRED) gentoo-dev 2007-08-06 00:51:21 UTC
I'd like to get this in but my 3D's broken for reasons I haven't yet identified. Once I can fix that, I'll try to add this despite the problem in comment #1.
Comment 10 Christian Hoffmann (RETIRED) gentoo-dev 2007-10-28 08:50:04 UTC
Closing as dberkholz added mesa-7.0.1 to the tree on Aug 11th.