Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 183425

Summary: media-libs/gegl-0.0.12 (New package)
Product: Gentoo Linux Reporter: Piotr Szymaniak <bugzie>
Component: New packagesAssignee: Default Assignee for New Packages <maintainer-wanted>
Status: RESOLVED FIXED    
Severity: enhancement CC: pacho, peach, quazgar
Priority: High Keywords: EBUILD
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://www.gegl.org/
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 183423    
Bug Blocks: 149644    
Attachments: media-libs/gegl-0.0.12.ebuild
gegl-9999.ebuild
media-libs/gegl-0.0.16.ebuild
sandbox violation fixed
media-libs/gegl-9999.ebuild
media-libs/gegl-0.0.18.ebuild
media-libs/gegl-0.0.18.ebuild
media-libs/gegl-0.0.18.ebuild patched for >=media-video/ffmpeg-0.4.9_p20080326
gegl-libavformat.patch

Description Piotr Szymaniak 2007-06-27 15:52:00 UTC
GEGL (Generic Graphics Library) is a graph based image processing framework.

GEGLs original design was made to scratch GIMPs itches for a new compositing and processing core. This core is being designed to have minimal dependencies. and a simple well defined API.

Reproducible: Always

Steps to Reproduce:
Comment 1 Piotr Szymaniak 2007-06-27 15:52:35 UTC
Created attachment 123215 [details]
media-libs/gegl-0.0.12.ebuild
Comment 2 Yohan 2007-11-22 14:50:31 UTC
Basically you won't be needing the src_unpack part as it'll be done automagically from eutils.eclass
Comment 3 Matteo 'The Peach' Pescarin 2008-02-01 14:58:22 UTC
Created attachment 142405 [details]
gegl-9999.ebuild

I've managed to create an ebuild for svn version of gegl (just for those who're using gimp-svn)
ruby must be installed for the ebuild to work. (autogen.sh)
Comment 4 Christoph Brill (egore) (RESIGNED) 2008-03-02 23:05:53 UTC
Created attachment 145146 [details]
media-libs/gegl-0.0.16.ebuild

I bumped to 0.0.16. They seem to break autotools setup more and more. Now it even sandbox violates.
Comment 5 quazgar 2008-03-05 18:45:02 UTC
Gimp (from svn) doesn't need the svn versions of gegl/babl, the most current snapshot releases (0.0.16 and 0.0.20 respectively) work as well.
Comment 6 quazgar 2008-03-05 18:45:32 UTC
(In reply to comment #5)
> Gimp (from svn) doesn't need the svn versions of gegl/babl, the most current
> snapshot releases (0.0.16 and 0.0.20 respectively) work as well.
> 

sorry, reply went to the wrong bug
Comment 7 dack 2008-04-14 00:54:51 UTC
Created attachment 149640 [details]
sandbox violation fixed

I've attached a new ebuild that solves the sandbox violation.  The problem was when it was building the examples.  I simply set the GEGL_SWAP environment variable to ${WORKDIR}.
Comment 8 Matteo 'The Peach' Pescarin 2008-06-12 13:39:54 UTC
Created attachment 156493 [details]
media-libs/gegl-9999.ebuild

created new ebuild for gegl svn. 
0.0.16 is too old for gimp svn (currently) hope they will release a new version.
this ebuild is based on the 0.0.16 version posted here, removed lua as a dependancy and forced ruby for autotools to work.
Comment 9 quazgar 2008-06-14 21:15:46 UTC
0.0.18 was released some hours ago (please also change the summary), some excerpts from the announcement on the gimp-developer mailing list:

============
GEGL 0.0.18
⎺⎺⎺⎺⎺⎺⎺⎺⎺⎺⎺
GEGL (Generic Graphics Library) is a graph based image processing framework.

GEGL provides infrastructure to do demand based cached non destructive image
editing on larger than RAM buffers. Through babl it provides support for a
wide range of color models and pixel storage formats for input and output.

This development release will include optimizations for the cpu capabilities
of the host system. Pass --disable-mmx and --disable-sse to configure to
disable these when building packages that should work on a wider range of
hardware. Making GEGL adapt at runtime is a blocker for the next release.

There is no new API in this release thus bindings do not need to be updated.

[...]

GEGL and it's dependencies babl and glib can be fetched from:

ftp://ftp.gimp.org/pub/babl/0.0/babl-0.0.22.tar.bz2
ftp://ftp.gimp.org/pub/gegl/0.0/gegl-0.0.18.tar.bz2
ftp://ftp.gimp.org/pub/glib/2.14/glib-2.14.5.tar.bz2

The integrity of the tarballs can be verified with:

sha1sum *.bz2
9de50fb5833f41691f50f6e735d6422aad52ea94  babl-0.0.22.tar.bz2
f8113ad33161337eb107ad84c0ac968dca1d02d2  gegl-0.0.18.tar.bz2
d8ae9dcb744ebfcb23809c3c552f4d724cb2458c  glib-2.14.5.tar.bz2
============

The "hard" dependencies seem to be babl-0.0.22 and glib-2.12.0; if GTK+ is installed, some examples will be built as well.
Comment 10 quazgar 2008-06-14 21:42:33 UTC
Created attachment 156785 [details]
media-libs/gegl-0.0.18.ebuild

Ebuild for gegl-0.0.18, compiles fine here on amd64.  Added recognition of the sse and mmx USE flags, changed the result of the doc USE flag slightly, adapted dependencies.
Comment 11 quazgar 2008-06-14 21:43:57 UTC
Upstream seems to be at least slightly aware of the sandbox violation:
http://bugzilla.gnome.org/show_bug.cgi?id=529668
Comment 12 Matteo 'The Peach' Pescarin 2008-06-14 22:44:26 UTC
thanks rubik's cube for update.
where does the lua dependancy come from? I've removed it in the svn ebuild I've made and it gives no error. I neither can see it in the requirements section on gegl homepage: http://www.gegl.org/#_dependencies
Comment 13 quazgar 2008-06-15 00:09:36 UTC
Created attachment 156811 [details]
media-libs/gegl-0.0.18.ebuild

I have to admit, I just took those options from the older ebuilds, but now I asked for the several dependencies, reordered them a bit in the ebuild and added some comments.  Lua was needed if the workshop (development directory) was built, I changed the dependency accordingly.  That should hardly ever be the case though for normal users so maybe that USE flag should be removed, at least for the non-svn ebuilds.
Comment 14 Geert Vanhaute 2008-06-20 19:09:00 UTC
Created attachment 157817 [details]
media-libs/gegl-0.0.18.ebuild patched for >=media-video/ffmpeg-0.4.9_p20080326

See bug http://bugs.gentoo.org/show_bug.cgi?id=219938
Comment 15 Geert Vanhaute 2008-06-20 19:10:39 UTC
Created attachment 157819 [details]
gegl-libavformat.patch

Use this patch with above ebuild to be able to compile with media-video/ffmpeg-0.4.9_p20080326
Comment 16 Dan Coats 2008-07-24 18:41:59 UTC
the svn ebuild needs the patch as well.
Comment 17 Hanno Böck gentoo-dev 2008-10-07 22:12:29 UTC
added, reduced useflags to avoid introducing new flags.

The tons of options make this one difficult, there are probably issues but anyway, I wanna get this in so we can get forward with gimp 2.6.