Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 183390

Summary: [dev-libs/pcre++-0.9.5-r1] needs automake-1.9 and some tweaking on building
Product: Gentoo Linux Reporter: Cobo <jacobopolavieja>
Component: New packagesAssignee: C++ Team [disbanded] <cpp+disabled>
Severity: normal CC: gentoo
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 226305    

Description Cobo 2007-06-27 11:32:51 UTC
pcre++ needs automake-1.9 to build but it doesn't require it when emerging.

Also, a developer

Reproducible: Always

Steps to Reproduce:
#emerge pcre++

>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-libs/pcre++-0.9.5-r1/work/pcre++-0.9.5 ...
 * econf: updating pcre++-0.9.5/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating pcre++-0.9.5/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu
./configure: line 1704: syntax error near unexpected token `libpcre++/config.h'
./configure: line 1704: `AM_CONFIG_HEADER(libpcre++/config.h)'
!!! Please attach the following file when filing a report to
!!! /var/tmp/portage/dev-libs/pcre++-0.9.5-r1/work/pcre++-0.9.5/config.log
!!! ERROR: dev-libs/pcre++-0.9.5-r1 failed.
Call stack:
#, line 1615:   Called dyn_compile
#, line 972:   Called qa_call 'src_compile'
#, line 44:   Called src_compile
#, line 643:   Called econf
#, line 578:   Called die
!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/dev-libs/pcre++-0.9.5-r1/temp/build.log'.
Actual Results:  
emerge of the package failed with the above error and description

Expected Results:  
build and finish the emerge
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-06-27 11:35:37 UTC
Try w/ 0.9.5-r1 please.
Comment 2 Fernando J. Pereda (RETIRED) gentoo-dev 2007-06-27 13:26:28 UTC
Jakub: He tried with -r1 :)

I *think* I know what is going on here. Mainly that my autogen.bash patch is a bit lousy. Will fix in a month (I'll be out of the internet in a couple of hours until then) if nobody beats me.

- ferdy
Comment 3 Fernando J. Pereda (RETIRED) gentoo-dev 2007-06-27 13:28:17 UTC
Stupid bugzie, won't let me do everything at once. Sorry for the bugspam guys.

- ferdy
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-06-27 13:36:36 UTC
(In reply to comment #2)
> Jakub: He tried with -r1 :)

Eh, indeed... :)
Comment 5 Jason Kridner 2007-10-14 14:38:27 UTC
I don't understand enough about emerge to be able to fix the ebuild file, but I was able to complete the pcre++ installation by executing the following commands after the initial failure:

# cd /var/temp/portage/dev-libs/pcre++-0.9.5-r1/work/pcre++-0.9.5
# aclocal-1.10
# autoheader
# autoconf
# automake -a --copy
# ./configure
# make && make install

Note that I don't know how to clean-up the portage database to let it be known the library is installed.  But, this let me build libopkele-0.3, which is what I was trying to do in the first place.
Comment 6 Łukasz Damentko (RETIRED) gentoo-dev 2009-03-17 22:31:47 UTC
Moving to herd since Ferdy left Gentoo.
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-09 21:23:39 UTC
This was fixed along the way.