Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 182656

Summary: kdepim crypt?() is downgrading gpg when it shouldn't
Product: Gentoo Linux Reporter: Michael Cummings (RETIRED) <mcummings>
Component: New packagesAssignee: Gentoo KDE team <kde>
Status: VERIFIED TEST-REQUEST    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Michael Cummings (RETIRED) gentoo-dev 2007-06-20 11:37:44 UTC
OK, not convinced this is a kdepim bug per se, but that's where I see it :)

Attempting to emerge kde, I see:

[ebuild  N    ]  kde-base/kdeaddons-3.5.7  USE="berkdb sdl xinerama -arts -debug -kdeenablefinal" 1,696 kB
[ebuild  N    ]   kde-base/kdepim-3.5.7  USE="crypt xinerama -arts -debug -gnokii -kdeenablefinal" 13,835 kB
[ebuild     UD]    app-crypt/gnupg-1.4.7-r1 [2.0.4] USE="ldap readline%* usb%* zlib%* -bindist% -bzip2 -curl% -ecc% -idea% -nls (-selinux) -smartcard -static% (-doc%) (-openct%*) (-pcsc-lite%*)" LINGUAS="-ru%" 3,126 kB

but in the ebuild for kdepim-3.5.7,

        crypt? ( >=app-crypt/gpgme-1.1.2-r1
                || ( >=app-crypt/gnupg-2.0.1-r1 <app-crypt/gnupg-1.9 ) )

I have app-crypt/gnupg-2.0.4 installed, so the downgrade shouldn't be happening. My brain is rusted out, but I think the || syntax looks right (at least at a first glance). Thanks :)
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-06-20 12:59:02 UTC
13:42:12 <@jakub> mcummings: hmmm... which gpgme version you have?                                                                 
13:44:40 <@mcummings> jakub: must be slotted, because i have 0.3.14(&&-r1), 0.4.0, and 1.1.4 
13:44:54 <@jakub> WTF                                                                                                               
13:45:00  * mcummings ponders how, even slotted, i could end up with 0.3.14 and 0.3.14-r1 
13:45:43 <@jakub> yeah, 0.3.14 will be causing this                                    
13:46:10 <@jakub> because, all the stuff in portage doesn't force <gnupg-2 anywhere AFAICS

Please, unmerge both ~0.3.14 versions, re-emerge 0.3.14-r1 and try again.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-06-20 13:00:03 UTC
Oh, and unmerge 0.4.0 as well, it doesn't exist any more.
Comment 3 Michael Cummings (RETIRED) gentoo-dev 2007-06-21 11:14:26 UTC
this is depressing. i had an outdated overlay that still had a package.mask for gnupg-2.0.4 from when robbat2 was testing it. i am...ah...glad we had this mind exercise on how to debug why a package would randomly downgrade. you all pass.