Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 18160

Summary: freetype 2.1.3.r2 fails to build
Product: Gentoo Linux Reporter: oliver stieber <oliverthered>
Component: [OLD] LibraryAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: VERIFIED FIXED    
Severity: normal CC: azarah, dking, foser, roger
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description oliver stieber 2003-03-25 13:37:10 UTC
>>> emerge (1 of 1) media-libs/freetype-2.1.3-r2 to / 
>>> md5 ;-) freetype-2.1.3.tar.bz2 
>>> Unpacking source... 
>>> Unpacking freetype-2.1.3.tar.bz2 to /var/tmp/portage/freetype-2.1.3-r2/work 
 * Applying freetype-2.1.3-slighthint.patch...                            [ ok ] 
>>> Source unpacked. 
./builds/unix/configure --host=i686-pc-linux-gnu --prefix=/usr 
configure: WARNING: If you wanted to set the --build type, don't use --host. 
    If a cross compiler is detected then cross compile mode will be used. 
checking build system type... i686-pc-linux-gnu 
checking host system type... i686-pc-linux-gnu 
checking target system type... i686-pc-linux-gnu 
checking for i686-pc-linux-gnu-gcc... gcc 
checking for C compiler default output... a.out 
checking whether the C compiler works... yes 
checking whether we are cross compiling... no 
checking for suffix of executables... 
checking for suffix of object files... o 
checking whether we are using the GNU C compiler... yes 
checking whether gcc accepts -g... yes 
checking how to run the C preprocessor... gcc -E 
checking for rm... rm -f 
checking for rmdir... rmdir 
checking for a BSD-compatible install... /bin/install -c 
checking for ANSI C header files... yes 
checking for sys/types.h... yes 
checking for sys/stat.h... yes 
checking for stdlib.h... yes 
checking for string.h... yes 
checking for memory.h... yes 
checking for strings.h... yes 
checking for inttypes.h... yes 
checking for stdint.h... yes 
checking for unistd.h... yes 
checking fcntl.h usability... yes 
checking fcntl.h presence... yes 
checking for fcntl.h... yes 
checking for unistd.h... (cached) yes 
checking for gcc option to accept ANSI C... none needed 
checking for an ANSI C-conforming const... yes 
checking for int... yes 
checking size of int... 4 
checking for long... yes 
checking size of long... 4 
checking for stdlib.h... (cached) yes 
checking for unistd.h... (cached) yes 
checking for getpagesize... yes 
checking for working mmap... yes 
checking whether munmap must be declared... no 
checking for munmap's first parameter type... void * 
checking for memcpy... yes 
checking for memmove... yes 
checking for ld used by GCC... /usr/i686-pc-linux-gnu/bin/ld 
checking if the linker (/usr/i686-pc-linux-gnu/bin/ld) is GNU ld... yes 
checking for /usr/i686-pc-linux-gnu/bin/ld option to reload object files... -r 
checking for BSD-compatible nm... nm 
checking whether ln -s works... yes 
checking how to recognise dependant libraries... pass_all 
checking command to parse nm output... ok 
checking dlfcn.h usability... yes 
checking dlfcn.h presence... yes 
checking for dlfcn.h... yes 
checking for i686-pc-linux-gnu-ranlib... no 
checking for ranlib... ranlib 
checking for i686-pc-linux-gnu-strip... no 
checking for strip... strip 
checking for objdir... .libs 
checking for gcc option to produce PIC... -fPIC 
checking if gcc PIC flag -fPIC works... yes 
checking if gcc static flag -static works... yes 
checking if gcc supports -c -o file.o... yes 
checking if gcc supports -c -o file.lo... yes 
checking if gcc supports -fno-rtti -fno-exceptions... yes 
checking whether the linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... 
yes 
checking how to hardcode library paths into programs... immediate 
checking whether stripping libraries is possible... yes 
checking dynamic linker characteristics... GNU/Linux ld.so 
checking if libtool supports shared libraries... yes 
checking whether to build shared libraries... yes 
checking whether to build static libraries... yes 
checking whether -lc should be explicitly linked in... no 
creating libtool 
configure: creating ./config.status 
config.status: creating unix-cc.mk 
config.status: creating unix-def.mk 
config.status: creating freetype-config 
config.status: creating ftconfig.h 
 
FreeType build system -- automatic system detection 
 
The following settings are used: 
 
  platform                    unix 
  compiler                    gcc 
  configuration directory     ./builds/unix 
  configuration rules         ./builds/unix/unix.mk 
 
If this does not correspond to your system or settings please remove the file 
`config.mk' from this directory then read the INSTALL file for help. 
 
Otherwise, simply type `make' again to build the library. 
 
config.mk:21: /unix-def.mk: No such file or directory 
config.mk:22: /unix-cc.mk: No such file or directory 
builds/freetype.mk:206: no file name for `include' 
make: *** No rule to make target `/unix-cc.mk'.  Stop. 
 
!!! ERROR: media-libs/freetype-2.1.3-r2 failed. 
!!! Function src_compile, Line 44, Exitcode 2 
!!! (no error message) 
 
pwd 
/var/tmp/portage/freetype-2.1.3-r2/work/freetype-2.1.3 
 
ls 
ChangeLog   Makefile    config.log     descrip.mms      include  src 
Jamfile     README      config.mk      docs             install  tests 
Jamfile.in  README.UNX  config.status  freetype-config  libtool  unix-cc.mk 
Jamrules    builds      configure      ftconfig.h       objs     unix-def.mk
Comment 1 oliver stieber 2003-04-23 06:34:06 UTC
 
It looks like there's a path problem with the configure file 
 
./builds/unix/configure  
fails 
 
cd builds/unix 
./configure 
cd ../.. 
make  
works 
 
 
Comment 2 foser (RETIRED) gentoo-dev 2003-04-23 06:50:16 UTC
it's only a problem for you it seems, how's things with freetype 2.1.4 (~ in portage) ?
Comment 3 oliver stieber 2003-04-23 09:03:54 UTC
freetype 1.4 has build problems too, and freetype is the only build I've had problems with (except 
OpenOffice which fails with freetype) 
 
Other people seem to have problems with freetype too 
http://www.freetype.org/pipermail/freetype/2003-March/005950.html 
 
I guess part of the problem is a bad envoronment 
/unix-def.mk should be $SOMEPATH/unix-def.mk 
Comment 4 foser (RETIRED) gentoo-dev 2003-04-23 09:26:18 UTC
our openoffice uses its own freetype afaic, so you would be running into the same problem.
Comment 5 foser (RETIRED) gentoo-dev 2003-04-23 09:28:16 UTC
what is your 'emerge info' btw and are you using any special stuff shellwise (not so common shell, bash-completion of some sort , etc.) ?
Comment 6 oliver stieber 2003-04-23 10:35:33 UTC
bash with code completion 
 
USE="X kde alsa arts jpeg xml xml2 gtk2 gphoto2 perl qtmt avi libpdf libssl 3dno 
w xine cdr dvd imap ldap sse tiff usb css opengl" 
 
CHOST="i686-pc-linux-gnu" 
 
CFLAGS="-O3 -mcpu=athlon-xp -march=athlon-xp -pipe -funroll-loops -fno-inline -m 
mmx -msse -fomit-frame-pointer " 
 
CXXFLAGS="-O3 -mcpu=athlon-xp -march=athlon-xp -pipe -funroll-loops -fno-inline 
-mmmx -msse -ffast-math -fomit-frame-pointer " 
 
 
$PATH 
/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.2:/usr/X11R6/bin:/opt/blackdown-jdk-1.4.1/bin:/opt/blackdown-jdk-1.4.1/jre/bin:/usr/qt/3/bin:/usr/kde/3.1/sbin:/usr/kde/3.1/bin:/usr/qt/2/bin 
 
 
 
Comment 7 oliver stieber 2003-04-23 10:36:48 UTC
emerge info 
Portage 2.0.47-r10 (default-x86-1.4, gcc-3.2.2, glibc-2.3.1-r4) 
================================================================= 
System uname: 2.4.19-gentoo-r10 i686 AMD Athlon(tm) XP 2000+ 
GENTOO_MIRRORS="gentoo.linux.no" 
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/share/config 
/usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/share/config" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d" 
PORTDIR="/usr/portage" 
DISTDIR="/usr/portage/distfiles" 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp" 
PORTDIR_OVERLAY="" 
USE="x86 oss apm crypt cups encode gif gnome libg++ libwww mikmod mmx mpeg ncurses nls 
pdflib png quicktime spell truetype xmms xv zlib gdbm berkdb slang readline svga tcltk java guile 
postgres sdl gpm tcpd pam ssl python esd imlib oggvorbis gtk qt motif mozilla X kde alsa arts jpeg 
xml xml2 gtk2 gphoto2 perl qtmt avi libpdf libssl 3dnow xine cdr dvd imap ldap sse tiff usb css 
opengl" 
COMPILER="gcc3" 
CHOST="i686-pc-linux-gnu" 
CFLAGS="-O3 -mcpu=athlon-xp -march=athlon-xp -pipe -funroll-loops -fno-inline -mmmx -msse 
-fomit-frame-pointer " 
CXXFLAGS="-O3 -mcpu=athlon-xp -march=athlon-xp -pipe -funroll-loops -fno-inline -mmmx 
-msse -ffast-math -fomit-frame-pointer " 
ACCEPT_KEYWORDS="x86" 
MAKEOPTS="-j2" 
AUTOCLEAN="yes" 
SYNC="rsync://rsync.gentoo.org/gentoo-portage" 
FEATURES="sandbox ccache" 
 
 
 
Comment 8 foser (RETIRED) gentoo-dev 2003-04-23 10:39:13 UTC
and if you try without completion ? may sound silly, but i've seen it before breaking a configure.
Comment 9 oliver stieber 2003-04-25 07:46:44 UTC
the build still fails with code completion turned off. 
 
It looks like the makefile isn't calling ./builds/unix/configure properly since running config doesn't 
update unix-cc.mk etc... in  ./builds/unix 
Comment 10 Olaf Hering 2003-05-18 13:37:16 UTC
the 'unix' part is missing.
+       make setup CFG="--host=${CHOST} --prefix=/usr ${myconf}" unix || die

it did assume ansi for me, '~ppc'
Comment 11 foser (RETIRED) gentoo-dev 2003-08-10 12:21:51 UTC
yeah the whole config step seems to be missing. Revision bumped 2.1.4 to r1 and added an explicit unix setup step. Please test.

Think this should cover it, report problems back if found any.

Thanks for your patience.

Comment 12 oliver stieber 2004-05-25 12:00:40 UTC
I've just got my pc out of storage afte 6 months, and found out what the problem is.

The make scripts referance $OBJ_DIR without checking if it's set and search for a makefile in ($OBJ_DIR)/

for some weird reason I had a makefile in / so the wholemake process got confused.

the extra unix bit on make isn't required unix/config.mk  has unix as a dependanc of setup.


Comment 13 Denis Lukianov 2005-05-22 00:45:19 UTC
I have just encountered the same problem with 2.1.9.r1

If there exists a Makefile in / then the build will fail as above.
Comment 14 foser (RETIRED) gentoo-dev 2005-05-28 07:49:59 UTC
*** Bug 78186 has been marked as a duplicate of this bug. ***
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2007-05-05 09:21:12 UTC
*** Bug 177138 has been marked as a duplicate of this bug. ***